Previous 1 2 3 Next 39 Replies Latest reply: May 12, 2009 10:56 AM by Lucia K Go to original post
  • sgiwiz Level 1 Level 1 (5 points)
    UPDATE: That middle idea I suggested... changing the Gallery.html code to reference an old version of the .js files does not work. Don't know why, but it fails to solve the problem.
  • 4bizzymom Level 1 Level 1 (0 points)
    I was having the same problem. Uploading to ipower through the iweb ftp process. like you, everything worked fine on the desktop folder. When uploaded to the site, in the gallery, most photos showed up, a few did not. All showed up in the slide show, tho. I tried changing the file sizes, and still wouldn't work. got error messages about not connecting to the server, etc. After doing a little sherlock holmes, i noticed the thread that mentioned file naming issues. so i checked the missing photos in the gallery and they had a different file naming system that the others. i had a space in front the names, followed by a number. after omitting those 2 elements, i hit publish, and voila, everything is loading fine. So, keep your file names simple, and maybe that will help.
  • Negatetime Level 1 Level 1 (0 points)
    Add me to the list. I to have been having issues with my site after it is published. I have tried publishing to a folder and uploading using Transmit and using the built in FTP program without any change.
  • tiger81 Level 1 Level 1 (0 points)
    Same problem - photos do not show up
  • wetpaint Level 1 Level 1 (0 points)
    This worked, thanks! Back up and running.
  • Marc.Speth Level 1 Level 1 (0 points)
    I have the exact same problem. I updated our Railroad Club's web site and added new photos. Here's what I've discovered so far.

    From Firefox: all previously published photos still show up just fine, and the new photo I added to my personal page shows up just fine, but the new photos I just added to my Photos page (gallery) do not show up, while the old ones are still there (including the ones I deleted from the page during the update)

    From Safari: everything works perfectly. All photos, and changes, show up the way they are supposed to.

    Although I would like to try the fix of replacing the Java Scripts, I can't because when I installed iWeb 09 it erased iWeb 08 and I don't have a drive large enough to backup with TimeMachine. Therefore I don't have access to those scripts any more.
  • tiger81 Level 1 Level 1 (0 points)
    Thanks sgiwiz - your trick of swapping the javascripts worked for bringing back my photos. However, __my navbar is still missing__.

    Does this have anything to do with Earthlink being my host?

    Ironic that my pages made in the new iWeb work just fine on a PC w/Explorer, but have problems on a Mac using either Safari or Firefox. Hopefully Apple is fixing this soon - in the meantime, anyone know how I can get my navbars back?
  • Marc.Speth Level 1 Level 1 (0 points)
    I just finished going to Software Update, and among the 6 items listed (including updates to iPhoto, etc) was a 'iLife Support' update. I installed all six updates shown there and now my new photos show up properly in both Firefox and in Safari.

    My bet is that the "iLife Support" software update was the cure! So could someone else, please, also try getting that update and verify that it works for them also?

    Message was edited by: Marc.Speth
  • kathymac Level 1 Level 1 (5 points)
    Same problem here, and I know for sure it happened as a result of upgrading to '09. Nothing changed as far as what the server I ftp to allows. I have a video podcast and photo album page I create for a school and neither of them work with FTP. They work if uploaded to mobile me, but as these are not my personal sites, I need to be able to host them on the school server.

    Apple really needs to do something about this. My site is totally crippled right now because of this upgrade.

    I've always published to the same folders and ftp'd with Cyberduck. Everything works locally and then nothing works once it is uploaded.
  • tiger81 Level 1 Level 1 (0 points)
    Even with the updates that came out last night, I still have the problem of photos not showing up in the photo grids after publishing to a folder and uploading to Earthlink's server. The navbar also is missing once the site is online. (This is with Safari and Firefox on Macs. Ironicaly the site works fine on PCs w/Explorer).

    Fortunately, I am able to get the photos and navbar back by swapping javascript files from iWeb 08 before uploading as suggested by sgiwiz.
  • zengtr1 Level 1 Level 1 (0 points)
    Hi - could you describe what you had do to get it to work with firefox/safari after the update. Did you have to republish the site and replace the script files etc.
  • Vaj Level 1 Level 1 (0 points)
    From AppleInsider yesterday:

    "Also in the works, and reportedly undergoing internal testing, is iWeb 3.0.1. The update is believed to address issues with publishing iWeb pages to MobileMe and FTP, which has been one of the largest sources of complaints about the new Web editor that shipped last month as part of iLife '09.

    One thread running since late January concerns FTP publishing errors where a test worked properly but the publish failed. Others have reported issues with pictures not appearing correctly while still others have struggled with uploading for a month only to discover their sleep settings were putting the computer to sleep before it could finish the upload."

    Links lead to this thread.

    Thanks to all who have chimed in. It's nice to hear a fix is in the works.
  • kathymac Level 1 Level 1 (5 points)
    That is fantastic to hear. Others have said they've "fixed" their problems by swapping out files from '08. Since I don't have that option, I am really counting on Apple coming up with a fix in the update.
  • Lifedancer Level 1 Level 1 (0 points)
    All was well with a new site in iWeb09 until i went to publish using the ftp option. No go. It works using Cyberduck or iWebSEOtool, both excellent little apps (more of this good stuff in iWeb please apple). too bad since I bought iWeb09 to use ftp! My real issue now is that after 3 blog entries, the 4th one will not show up in Safari 3.2.1, but is there in Firefox 3.0.7! Very weird. I tried re doing the page but same result.
    Please help! I've run out of ideas. www.lifeclarityforums.com.au
  • Appeltjehehe Level 2 Level 2 (285 points)
    Send feedback, bug reports, and email support questions to Apple.
    Press reporters have started to ask for user reviews as they have also noted something is wrong with iWeb. So contact everyone you know at Apple and its neighbourhood.
    The point is that with a malfunctioning blog iWeb is for many of us pretty useless.
    I bought iLife09 for its extras, but it turns out the new version of iWeb has stopped my blogging. If they can't fix the blog bug, then Apple should return to the previous version and release an update that works with our present files.