Previous 1 2 3 Next 39 Replies Latest reply: May 12, 2009 10:56 AM by Lucia K
Vaj Level 1 (0 points)
I've tried to upload two different iWeb template "photo" pages and neither will display the actual photos in Safari or in Firefox. The same problem happens using iWeb's new FTP feature or uploading a published folder via a FTP client.

It's odd because the template features and titles show up, just +no photos+. Examining the upload site shows all the files are there. Publishing to a folder and viewing with a browser from the fold on my hard drive works flawlessly, as expected. However one they're uploaded, no photos.

I've tried everything, any suggestions oh Macintosh Illuminati!

Intel Mac Mini, Mac OS X (10.5.6)
  • zmcdermott Level 1 (0 points)
    I am having the same problem. I have two different sites. Both are behaving the same way. All the photos are present in the same folder they were when I uploaded with the old version of iWeb. I'm hopeful for a quick update from Apple on this program.
  • Vaj Level 1 (0 points)
    Thanks zmcdermott for sharing that.

    Just to clarify: I'm uploading to the "free website" storage I get with two of my accounts (Roadrunner and Earthlink). Roadrunner's tech support in India was kind enuff to let me know that they no longer support FTP uploads. Instead--if you didn't "migrate" your old (Adelphia, remember them?) site to Roadrunner, all they allow is their sitebuilding interface. No more uploaded HTML for them!

    Earthlink however still allows old users to upload HTML code to their legacy spaces. I have to wonder however since it appears new users cannot do this, if the problem I'm having has to do with the way their servers are now set up, on their side, to allow for their "site building" template style of site creation? Certainly it cuts down on their need to provide tech support to Joe and Jane Neophyte who has no clue how to FTP, let alone code HTML, etc. "Just use the site builder templates."

    So to test my theory, I signed up for a free MobileMe account.

    I uploaded the exact same sites.

    They worked perfectly on MobileMe.

    So that leaves me with two conclusions:

    -either Apple has crippled their created code to favor MobileMe


    -older websites, having lost their FTP server preferences no longer allowing for the same sophistication in their user-uploaded HTML code as they did before.
  • Old Toad Level 10 (135,522 points)
    It the site works OK locally from your Desktop it's either the uploading isn't correct or the servers are not supporting. Have you tried using CyberDuck to ftp the site to the server? It's very highly regarded in this forum and the new iWeb ftp is noted for having problems.
  • Vaj Level 1 (0 points)
    I have always used CyberDuck exclusively for uploading published folders (I've tried probably 10-12 times in this particular instance) with two different accounts. Uploads perfectly and includes all files.

    Same problem as with the built in iWeb FTP: no photos. It actually displays exactly the same with both methods.

    I've also tried site naming variations, i.e. no spaces, all lowercase, etc. and tried uploading to a directory as opposed to the root level: no difference.

    I'm getting the feeling this may just be the result of cost-cutting measures ISP's are now using.
  • dodici12 Level 1 (0 points)
    I'm having the same problem- I use Cyberduck and my gallery page does not show the 'album'- everything else is there- It should show a pixture, then when you click on it, it should bring you to the slideshow page- both are not showing up.
    It is
    click on gallery and you'll (not) see the pix
    Thanks for your reply.
  • zmcdermott Level 1 (0 points)
    I believe it's something on Mac's end. I was publishing just fine until I installed iWeb 9. My photos and slideshows appeared on the same server the day before I switched.
  • trlblzr Level 1 (115 points)
    Same here... my wife's website has the photo problem and also the blog pages don't work properly. The page is rendered but the blog entries are not showing up at all.

    Should have just stuck with '08
  • wetpaint Level 1 (0 points)
    Upgraded my site from iWeb 08 to iWeb 09 and now all my gallery pages are blank. Works in IE 7 & 6 on PC but won't work in Safari or Firefox on Mac. The pages will display properly from my desktop but once they are FTP'd either from iWeb 09 or Cyberduck something is lost in the transfer.
  • Old Toad Level 10 (135,522 points)
    Welcome to the Apple Discussions. Have you checked your site with Safari's Activity window to see if all your files are getting uploaded properly to the right location?
  • wetpaint Level 1 (0 points)
    +++Welcome to the Apple Discussions. Have you checked your site with Safari's Activity window to see if all your files are getting uploaded properly to the right location?+++

    That's not the problem. Everything is displaying properly on my server with IE 6 & 7. Safari, Firefox and Chrome won't see the galleries. They come up blank. The location path is correct in Safari. I'm now manually uploading with Cyberduck so in theory all the files should be in it's proper order. I've checked it folder by folder and all files seems to be intact on the server. I'm at a loss.
  • zmcdermott Level 1 (0 points)
    Apple knows there's a problem and it's on their end. They requested my domain file - and I'm sure many more- to investigate and attempt to correct.
  • wetpaint Level 1 (0 points)
    I hope they fix this soon, my gallery pages have been down for over a week. I guess 70% of the world can still see it with IE but it doesn't make sense that it's not working with an Apple browser.
  • Blue Water Guppi Level 1 (0 points)
    I'm having the same problem - but nothing to do with FTP. I have built a web site for a client that wants the information available on a CD - so I published to a File. On my Mac, it works just fine, but when I take the file and try and open it in IE on a PC, the photos are missing. I have turned off slide show and RSS thinking that might be the issue, but no change - my photos still don't appear.

    I also hope they fix this really really soon.
  • sgiwiz Level 1 (5 points)
    Same problem here, trouble shot for a while.

    In my case it all boils down to three javascript files that apparently were updated for '09.

    WARNING: These .js files contain a lot of the scripts for your site, not just the gallery. If, like me, you have lots of HTML snippets, they may fail if you use this fix. I got my gallery to work again and spotted a couple of nasty side effects.

    But, if you have a simple site that only uses these files for the gallery, then the culprits seem to be:


    These sit in the "Scripts" directory at the root level of the site. If you can swap those three files for the same files from an iWeb '08 gallery (Time Machine saves the day), then everything works. If you FTP, or manually upload your site, this is easy. If you publish to MobielMe you will have to access your iDisk/Web/Sites/ directory to gain access to the files and replace them.

    If you're willing to do a little code hacking, you could duplicate these old version files, and change ONLY the "Gallery.html" code to reference the old versions. Then in theory everything will work. "iWebSite_08.js" for example. I think these files are only referenced once each in the .html for the main gallery page.

    Huge pain in the rear though, so...

    A temp workaround until this gets fixed: The actual gallery sub-pages seem to work fine, it's only the master gallery page that links to them which has the issue. In my case, I have placed text only links directly to those gallery pages right below the main gallery interface. These will always be visible even if the java fails.

    Message was edited by: sgiwiz
Previous 1 2 3 Next