Previous 1 10 11 12 13 14 Next 236 Replies Latest reply: Dec 14, 2014 8:49 AM by Gary Scotland Go to original post
  • Bacterium Level 1 Level 1 (0 points)

    Hi!! I just encountered the same problem and this is what I did, but I was able to recover half of the presentation!

     

    1)put the keynote in The Unarchiver (this app was suggested in another post)

    2)put .key at the end of the folder created by The Unarchiver

     

    Before I put .key, I checked the folder and all the images and thumbnails were correct.

    But when I put the .key at the end of the folder, the new keynote only has half of the slides and images!

    Can anyone help me? Thank you!

  • ydesign5 Level 1 Level 1 (0 points)

    Thanks Bill-This works!

     

     

    Currently Being Moderated   

    Re: Can't open Keynote 09 file

       Jun 17, 2011 12:27 AM    (in response to Gordo007

      

    >>I figured out how to fix this problem after hour of freak'n out!

     

    >>1. Get info on file

     

    >>2. Change extension to ".zip"

     

    >>3. Right click (or control click) and open with "Archive Utility"

     

    >>5. The file will look like a folder... open it

     

    >>4. Find the file named index and re name "index.apxl.gz"

     

    >>5. Close Folder

     

    >>6. Get info and add ".key" extension (to the folder itself-weird but it works)

     

    >>7. File menu and open!

  • Wayne Wenzlaff Level 1 Level 1 (10 points)

    I traced the source of my problem to either a corrupt font or a bad cache, so in addition to everything you've read above:

     

    1. Quit Keynote

    2. Open Fontbook

         A. Select and validate all fonts

         B. Remove duplicates.

    3. Go to Home/Library/Preferences and delete the com.apple.iWork.Keynote.plist

    4. Go to Home/Library/Caches and delete everything that begins with com.apple.

    5. Restart

    6. Launch Keynote

    7. If the file you want to use still gives you the error, follow the instructions to archive and expamd the file.

     

    Note: Some files may be too corrupted to be recovered, but I had good results following these steps.

  • alc990 Level 1 Level 1 (0 points)

    Hi guys - i managed to open the file again by:

     

    - change the extension of the keynote file to zip

    - unzip the file

    - change the extension of the folder to .key

     

    hope it helps!

     

    andreea

  • DKBenjamin Level 1 Level 1 (0 points)

    Worked like a charm!!! Thanks!!!

  • fyffes Level 1 Level 1 (0 points)

    Hurray!

     

    Thanks guys, you made my day, my week, my month!

  • Christopher Werby Level 1 Level 1 (20 points)

    Same problem.  I was able to solve this by opening the file on a different system that also had Keynote 09 installed.  I don't know whether it was a font or some other issue, but the file that wouldn't open on the desktop did open on the laptop.

     

    When paging through the preview, I noticed that an Illustrator file that I had pasted seemed to choke the preview. I figured that might be the problem.  So once I got the file open on the laptop, I deleted and resaved the file.  Then I could open the file again on the desktop.

  • TeresaOdette Level 1 Level 1 (0 points)

    We figured it out –

    When you paste vectors over with text that hasnt been outlined it corrupts the file. So make sure text, tables etc is outlined, then copy to keynote.

    Test the file before you close it as once it has been closed and has these bad vectors, that's when you cant open it.

  • Martin von Siebenthal Level 1 Level 1 (0 points)

    hey, what if there is no index file in the unzipped keynote package? i can see that there is one in my other projects, but not in the one that is damaged. do you have any ideas? i'm pretty screwed right now.

  • startledfish Level 1 Level 1 (0 points)

    I've been having this problem and solved it by doing this...

    http://www.andreadenaro.com/italiano/2010/4/19/a-must-know-tip-for-apple-keynote -users-corrupted-file-recov.html

     

    straightforward and it worked immediately. Some of the images we're in place but at least I recovered the presentation.

  • Martin von Siebenthal Level 1 Level 1 (0 points)

    It didn't work for me. Maybe because the index file was missing. I've redone the presentation now as far as I could

     

    I just think it's really annoying because the actual cause of the problem was the version feature in keynote 09. Usually I save different versions from time to time, but because of this feature and because there is no "save as" function (how stupid is that?) I didn't. And because I couldn't open the file anymore I couldn't access the previous versions of it.

  • robertfromkearns Level 1 Level 1 (0 points)

    I proposed this solution several months ago when I was having the same problem. It has worked many times for me and for others:

     

    Send the file to your email as an attachment. It's the only way I've been able to get it to work. I am using two computers. I need the file on my MacBook Air for presentations, but it resides on my desktop machine. I've been successful with this method every time I've tried. I spent the better part of a day and into the wee hours of the morning before this solution occurred to me.

  • Saint wednesday Level 1 Level 1 (0 points)

    I've had this problem many times. It is frustrating.

     

    Try doing the following.

     

    1. In finder change the filename from 'mypresentation10.key' to 'mypresentation10.zip'  – finder will ask you if you really want to do this, of course you do.

     

    2. You now how what looks like a zipped file. Double click it – it will expand as a folder with all your linked files inside.

     

    3. Rename the folder back to a keynote file again. 'mypresentation10.key'

     

    4. Now you should be able to open it in Keynote.

     

    5. Try to save your file again – and keynote probably won't let you. If that is the case open a new keynote file and drag all your slide across.

     

    6. Now Save you new file.

     

    7. Last thing. Go through your presentation and try to fine the problem – there may be a corupt link – an image with an X, or something that has been rotated, or something that is too large. Fix that and then save again.

     

    I hope that helps.

  • amir05 Level 1 Level 1 (0 points)
  • matt_bones Level 1 Level 1 (0 points)

    I couldn't open zip file (error one message).

     

    But..I had a copy on my iMac that worked. Exactly same file wouldn't work on my macbook pro when I copied it over.

     

    It was 100mb with videos (25 without). So I went back to iMac version, deleted the videos, saved it under a different name and copied that file to MBP. That worked. Then I added videos again on MBP.

     

    Obviously something to do with videos or size of file. I was lucky to have a working copy I could edit. Hope this helps someone!

     

     

Previous 1 10 11 12 13 14 Next