Previous 1 11 12 13 14 15 16 Next 236 Replies Latest reply: Dec 14, 2014 8:49 AM by Gary Scotland Go to original post
  • ocr_a Level 1 Level 1 (0 points)

    Oh my god! Thanks to the freaking genius who figured this out. My absolute gratitude. Apple should really fix this bug, it's causing a ridiculous amount of headaches. Keynote is still a great program, but seriously. Major props and praises to the person who figured this out. May the gods bless you with many healthy and genius children.

  • BowenIMG Level 1 Level 1 (0 points)

    I tried a few other workaarounds and Roadpiza's worked like a charm. Amazing work around and you just saved me several hours of work. 

  • robson2 Level 1 Level 1 (0 points)

    Yet another situation with a presentation tomorrow, a file that has worked successfully before (built and presented on this very machine), and "Unable to open “MyFile.key” because it isn't a valid Keynote document."


    I've tried all the fixes noted above with no success. I reported to Apple.


    Fortunately, I have a PDF export of my slides. But that's not the way I wanted to present the information. PDFs can't do what Keynote can do--or used to be able to!

  • Wayne Wenzlaff Level 1 Level 1 (10 points)

    Unfortunately your statement that "I've tried all the fixes noted above" can be misunderstood. Did you try cleaning fonts, then using the advice on how to save the file with the 'wrong' extension, then reopening as instructed?


    I'm not trying to be a pain, but there are 13 pages of discussion here and it would be nice to know what you are actually doing. If you tell us more precisely what yuu've tried, which version of the OS and other details we can be a LOT more helpful...

  • Tenvox Level 1 Level 1 (0 points)

    Let's not put the world upside down. It is the task and duty of Apple to solve bugs and errors in their software... In our Studio we work also with Keynote and in the meantime some of my colleagues start to get irritated by Keynote. It's getting unreliable. As unreliable as PPT of MS. Fortunally their is not a very good alternative. But please Apple software development crew!!! Grab your buttocks together and solve this issue!!!!

  • zhuoxiuer Level 1 Level 1 (0 points)

    Solution to your problem:


    1) Add .zip after the file name, so it will be

    2) double click to unzip the file.

    3) double click to open the .key file.


    Note: make sure not to replace or remove .key, but to add .zip after the file name.

  • bobodoo Level 1 Level 1 (0 points)

    I encountered the same problem (cannot open Keynote file). I built the document on the iPad, in keynote and then I attempted to transfer it on the laptop. When I opened it on the laptop, there were some warnings regarding some fonts that cannot be found (Aardvark bold, Franklin Gothic Demi). That's when the crash happenned - after replacing the fonts and saving them (on the laptop). The second time I tried to open the document on the laptop, it gave me the error - "cannot open".


    I went back on the iPad and substituted the font that was giving the warning (Helvetica) with a plain Arial and it worked. It seems to be a problem of font compatibility between the 2 versions of Keynote (iPad version versus laptop version).


    What I don't understand is why I couldn't fix the warnings on the laptop....

  • AReyesJKD Level 1 Level 1 (0 points)

    Unfortunately none of the solutions mentioned thus far (I've gone through all 13 pages of comments) have worked for various reasons and I called Apple, but they couldn't help either.  I'm pretty desperate here as this is a vitally important file for my business that I've been working on for months now!  It's 271 Megabytes. 


    I'm going to try Apple again tomorrow, b/c one solution they offered has gotten weird in that I can't click on anything in a new user account I created on my Macbook.  I saved my file to a CD to see if opening under a different account on my computer would work.  Unfortunately I can't click on anything at all when I log into the new account. 


    All of my other Keynote files open just fine, so I'm figuring this one file has gotten corrupt. 


    Has anyone tried converting their files using a service like s-office-online-and-free/ ?  


    I'm about to email friends to see if anyone can offer any assistance. 


    - I've already validated and then deleted repeated fonts.  The steps that have been recommended following that and involving iWork files don't apply, b/c I have just Keynote and not the iWork suite of programs.  There are no "" files. 

    - The .zip and aren't working either, as Keynote still tries to open them. 


    Anything that anyone can offer would be most appreciated, as this is incredibly important and months worth of work has gone into it!  Thanks!!!! 

  • Antonio PureMacOnly Level 3 Level 3 (525 points)

    This worked for me: I've put the corrupted files in a pendrive and opened them on an old iMac with Snow Leopard. Removed some photos, fixed some font issues and saved the files with another name. The files could then be opened on my MacBookAir with Mountain Lion.


    Really hope this helps, because I do understand you. I had almost lost all my presentations that I regularly use in my teaching classes.




  • AReyesJKD Level 1 Level 1 (0 points)

    Thanks so much for your replay Antonio! 


    I don't have another system to open it up in, but I have saved it to disc and will try opening it at a FedEx Kinkos to play with it a little.  That's assuming their Macs even have Keynote.  Thanks for the idea! 


    I've put the word out to a lot of friends and I've been getting feedback to try a number of places and people so I'll be shopping around also for file repair specialists. 





  • Nealf Level 1 Level 1 (50 points)

    I have the same problem but so far nothing I have tried worked, not the zip file, not the plist deletion, not the reinstalling, not the different machine.

  • Antonio PureMacOnly Level 3 Level 3 (525 points)

    Have you tried a machine with Snow Leopard? Because according to my experience, the issue seems to affect Keynote files only on Lion and Mountain Lion.



  • Nealf Level 1 Level 1 (50 points)


    Thanks for the suggestion.  I had not tried that.  Both machines tested are running Mountain Lion.

  • Antonio PureMacOnly Level 3 Level 3 (525 points)

    Good to know, then try this and let me know, because this was the latest (and working) solution after I had tried eveything else.




  • AReyesJKD Level 1 Level 1 (0 points)

    Actually my laptop has Snow Leopard so the corruption ocurred with that OS (10.6.8). 


    According to someone who analyzed the file for me, Keynote underwent a bad save routine, when on Thursday night it tried to save my project, but crapped out as it was trying to save an unnecessarily large quicktime movie that was in it.  With the massive number of files I had in the presentation (png, jpg, .mov,) it grew quite big and crapped out at the last save attempt, thereby not saving the entire project correctly.  So the file became corrupt. 

    That's my situation. 


    I've had Drive Savers recommended a number of times, but it's $700 minimum for them to work on the drive.  It can go as high as $2,700!  That's over budget, so I've got to reconstruct the file from scratch. 


    The iWork team from Apple emailed me from these forums a couple of days and I sent them the info they needed.  I haven't heard anything yet. 


    BIGGEST LESSON LEARNED:  I took it for granted that everything would just work well, but never again!  I'm now a backup master and I'm creating numerous backup strategies to ensure something like this NEVER happens again!  2 external drives and cloud-based backups!!!