Skip navigation

Can't open Keynote 09 file

168888 Views 225 Replies Latest reply: Mar 11, 2014 8:10 PM by applesyappledo RSS
  • Sam0737 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 4, 2013 11:03 AM (in response to Nealf)

    Grrrrr killer!

     

    out of interest, at what point did the fix fail? did you get the folder of images etc...

  • Nealf Level 1 Level 1 (50 points)
    Currently Being Moderated
    Mar 4, 2013 11:15 AM (in response to Sam0737)

    Yes.  I got into the folders. It failed on the last step of changing back to a Keynote extension.

     

    The zip trick was handy for a way to access the images I had in the Keynote.  It made reconstruction a little easier.

     

    It looks like it was a QuickTime movie that caused Keynote to choke, although it was not an especially large one.

     

    After fixing this, I went back to PowerPoint.  Ironically, I had switch to Keynote a couple years ago because I liked the way it handled video.

  • reutsler Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 25, 2013 3:56 PM (in response to Bill Clarke)

    I was receiving the "Can't Open File" error when trying to open Keynote presentations created as templates for use by our company.

     

    The fix for me was to install fonts that were present in the Keynote file, but not present on my system.

     

    After troubleshooting the heck out of Keynote, installing the new fonts fixed the problem right away.

  • 5riccetti Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 2, 2013 10:07 AM (in response to Gary Scotland)

    I have the same problem... After properly saving the file, I cannot open it anymore...

     

    I use:

    Keynote '09

    Mountain Lion 10.8.3

    File size 800 MB

     

    Help me because otherwise I will have to go back to PPT, which to me is insane...

     

    Thank you!!!!

  • Maurizio Atzori Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 2, 2013 10:24 AM (in response to 5riccetti)

    Hi 5riccetti,

      I can feel your pain... I couldn't find any solution to this issue.

    I was contacted from the iWork team and I sent them my file, but we had no further communication and the problem is still there.

     

    I could open an old-old-old-old version of my presentation from TimeMachine, but then I decided to start again from scratch, since Keynote was going sluggish and that didn't sound as a good thing.

     

    It seems that the problem arises by using "vectorial shapes with outlined text".

    That's what some other user wrote on the Support Community and that's what the designer of the stencils I use acknowledged too.

     

    Repairing permissions, cleaning font cache, rename-unzip-zip and everything else you may want to try (even wiping the whole disk as I did) won't help at all.

     

     

    Regards,

    Maurizio

  • 5riccetti Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 15, 2013 11:43 PM (in response to Maurizio Atzori)

    Thank you Maurizio!

    The incredible thing is that APPLE is not fixing this...

     

    Ciao!

  • 5riccetti Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 15, 2013 11:44 PM (in response to reutsler)

    How to reinstall the original fonts?

  • Rays56 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jul 18, 2013 4:12 PM (in response to 5riccetti)

    I've had several recent problems with Keynote running under 10.8.4 - after editing a presentation, I get an error message saying that the file couldn't be located. What's worked so far is that I was able to save the presentation under a new name, but that doesn't inspire much confidence. Over the years, Keynote has been prone to file corruption problems, some recoverable, some not. At WWDC Apple said that they'd be releasing a new desktop version of iWork later this year, so I hope they take care of this issue.

     

    Until that happens, I'm taking the precaution of making a copy of the last good version of every Keynote presentation that I'm editing it before I make any changes to the original file.

  • Goliardhk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 8, 2013 11:01 PM (in response to Bill Clarke)

    I spent two hours trying the things I saw here -- various ways of zipping and unzipping, including installing another unarchiving program. They didn't work for me.

     

    What did work was using the technique described to turn my Keynote file into a folder then opening the folder and guessing what was corrupted. I had three .mov files in the presentation (thus in the folder). When I tried to play them in the folder they had no sound, which they should have done.

     

    I deleted them and replaced them with three files that did work (giving them the same names as the three files I deleted).

     

    The file then opened without problem and everything worked as it did. In a nutshell, it wasn't the entire presentation that was corrupted, just three files that could be replaced. Even if you don't have the originals you just need files in the same format that you can use as fillers and fix the problem when you can get your file open again.

     

    I hope this helps someone. I'm grateful to all the people in this thread whose suggestions I built on to come up with this. (Or maybe someone else suggested this in a post I read so long ago when it popped into my head I thought I'd had an original idea!)

  • 5riccetti Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2013 4:06 AM (in response to Bill Clarke)

    I have been following these posts for a while. I had all the problems listed. I tried all the solutions proposed...with no success.

     

    Sometimes I able to fix some issues following what Goliardhk did. But this was not always possible.

     

    The issue, on my opinion were the videos imported inside the keynote. I used third-party applications for converting the videos in different formats and different sizes. I think there was something wrong with the codecs used.

     

    I re-exported the videos from the original, with Final Cut Pro X, in Quicktime .MOV format. Then I made completely new keynotes and imported the newly converted videos. Fortunately I was able to recover the images from old presentations.

     

    So far... I solved the problem...

     

    I hope this could be useful for somebody else.

     

    GOOD LUCK!!!

     

    Ciao!!

  • mighty55 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2013 5:14 PM (in response to Bill Clarke)

    Delete Unused Master Slides Before Exporting To Keynote 09'

     

    One thing to try before exporting to 09 is to get rid of unused master slides. I received a file from a co-worker and ran through ever fix here then noticed that there were 80+ master slides for a 20 slide deck. I went through and deleted all the master slides not being used. I ended up with just three master slides. I exported out to 09 and BAM, it opened in 09 seamlessly. I know this is not a fix for everyone but it may be the fix for some.

     

    Cheers!

  • sycori Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2013 11:12 PM (in response to Bill Clarke)

    The true solution is actually even more simple: The iWorks 09 suite is still installed and most likely still on your dock. Yes, even though the icons have changed. So, open keynote from the Applications folder and try your document again. And for the future remove the iWorks 09 stuff from your dock and add the newer icons of the current version to the dock. Apple updated the iWorks package but obviously you bought the 09 version so they did not delete it from your machine. So you have both versions.

  • reutsler Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2013 11:20 PM (in response to sycori)

    Actually, the original posts predate the release of the latest version of the iWork apps.  A good thought, but not applicable in this situation. 

  • mighty55 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 18, 2013 11:07 AM (in response to Bill Clarke)

    Also to note is that I have also sloved this issue by gettign rid of the original master slides by duplicating them with new ones and then exporting out to 09 after. It seems to me that the most common problem that I have come across always goes back to the master slides. Creating new ones sloves it everytime even if it is just duplicating them. ~cheers

  • fof0 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 16, 2014 11:54 AM (in response to Bill Clarke)

    Hi,

    Please i need help with openning a keynote file... it keeps giving me this message:

     

    This presentation can't be opened because it's too old. To open it, save it with Keynote 09 first.

     

    there are many suggestions in this discussion but I don't know which one i should follow

    I'm at wrok and my boss really wants me to work on this presentation.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.