8 Replies Latest reply: Feb 3, 2009 12:23 AM by KOENIG Yvan
MisterMojo Level 1 Level 1
I want to prevent Pages from automatically adding the .pages suffix to files. It increases the size of the file name so the name is often missing the middle letters.

I do not see a preference setting for this option... Is there any way to do this?
  • Level 8 Level 8
    *_Never remove the extension names._* They are required for a correct behavior.

    You just may ask the Finder to stop displaying it which is not the same thing.

    Finder > Preferences > Advanced >
    uncheck the box "Show all file extensions".

    Yvan KOENIG (from FRANCE lundi 2 février 2009 21:55:51)
  • MisterMojo Level 1 Level 1
    Yvan, changing the Finder preference setting does not remove the .pages suffix. That's the first thing that I tried...
  • mizzlara Level 1 Level 1
    So you just don't want it to show up in the file name? When you click on save, the window comes up and in the bottom right corner there is a check box marked "Hide Extension", just click that and it will hide the .pages extension.
  • mizzlara Level 1 Level 1
    Also... for your existing files that have already been saved with the pages file extension you just need to go to Finder, locate the files, Ctrl+click on each one to pull up the info, click on Get Info, check the box marked "hide extension" under File name & extension.
  • MisterMojo Level 1 Level 1
    Thanks for reminding me about the option to hide the extension when saving a new file.

    As far as using the "Get Info" procedure to change existing files... well, I don't think that I am up for that!

    I would hope that there would be a universal preference setting for hiding file extensions since they do not seem to be necessary for proper handling of files.
  • mizzlara Level 1 Level 1
    No problem! I hear ya... I think the universal setting only applies to the files you save after you switch your preference in the "save as" window. Once that is checked then it will apply to all of your files that you save in the future. Maybe you can make it part of your daily routine to switch the old ones by just switching a few each day haha
  • PeterBreis0807 Level 7 Level 7
    expertise.iwork
    iWork
    MisterMojo,

    This is one of the problems of viewing your files in Columns View.

    To get around it, don't try and remove the file extension which is a recipe for trouble. Instead expand the column by dragging out on the double lines at the bottom of the column divider or switch to list view in the Finder.
  • Level 8 Level 8
    We may perfectly work with a system which doesn't display the extension name but never remove them !

    I repeat that "removing" is a thing, stopping their display" is a completely different one.

    Yvan KOENIG (from FRANCE mardi 3 février 2009 09:23:14)