3 Replies Latest reply: Feb 15, 2009 5:24 AM by QuickTimeKirk
k1kbxr Level 1 Level 1 (0 points)
Hi, I'm new to apple discussion forum, I have been searching for answer to my problems but couldn't find the resolution.

I have dozens of MP4 files which plays well on Quicktime on my other systems running XP-Pro. Recently I transferred my mp4 files on a portable drive and I wanted to open them up on a system which has 64-bit Vista. I can open all the files within iTunes without a problem (although it had to install files within iTunes first) but the same mp4 files won't run on Quicktime.

I wanted to be able to run the mp4 files on Quicktime without the need to open iTunes first, as I don't want to install these mp4 files in iTunes.

If any of these mp4 files are opened on Quicktime, I am getting an "Error -43: file not found..." message although the files are there. I don't think it's related to the 8 character limitation because I even tried to chunk-out the characters. I have tried many times to uninstall and reinstall both iTunes and Quicktime and also tried many times to run the standalone Quicktime setup by itself, but the same error-message remains.

I tried to run the mp4 file on RealPlayer as well as DivX but both program says it needed Quicktime to run the file, although Quicktime was installed it seemed like the programs cannot see quicktime, and yet when I run any of the mp4 files within iTunes they work fine.

Any reason why Quicktime won't open file and yet iTunes can open the same file?

I don't know of any but is there any known Quicktime compatibility problem with 64-bit Vista and if so what causes the conflict, or are there any workaround or patches? (can't find any related issues on Microsoft support)

Is there any way I can resolve this issue, and be able to open these mp4 files within Quicktime without getting error -43 message and without the need to install the mp4 files within iTunes first?

Any help from any good people out there are very much appreciated. Thanks very much in advance.

Toshiba A305, Windows Vista, 64-bit Ultimate
  • John Finley Level 1 Level 1 (0 points)
    I cannot provide you with any solution - but you are not alone. MANY people are experiencing this since upgrading to Quicktime 7.6. I'm having numerous issues with studdering playback as well on those files that WILL play.

    QT 7.6 is JUNK.
  • KKryvenchuk Level 1 Level 1 (0 points)
    Hi.

    Yes, I have the same exact problem. Running pretty much same Vista 64-bit system. When I double click to run a mp4 file I keep getting that same error -43: file not found. The video plays fine through iTunes but won't run at all through Quicktime (outside of iTunes).

    Hope someone can come up with an answer or Apple puts in fix.

    For now I set iTunes to be the default program to open for this file type but would it rather have remained Quicktime.

    Tried the uninstall and reinstall to latest Quicktime version but that didn't fix anything. Same problem....
  • QuickTimeKirk Level 8 Level 8 (49,605 points)
    There are few known issues with QuickTime Player and 64 bit Windows OS's. A "black" controller and troubles with QTVR files are two I know about. It is not supported in Windows 64 bit systems.
    Since iTunes uses QuickTime engine for playback I doubt it is the cause. Some improperly encoded .mp4 files give QuickTime trouble yet play without issue in iTunes.
    Setting QuickTime to run in "32 bit" mode may fix your troubles. My PC skills are lacking so you're on your own to find the 32 bit adjustment.