Previous 1 2 Next 22 Replies Latest reply: Jul 2, 2009 4:52 AM by dogonit3
Denny Mcnally Level 1 Level 1 (5 points)
When I double click a photo and go to edit mode with thumbnails on top the picture shows for a brief second and then goes black. Any ideas?

g5 Tower, Mac OS X (10.5.6)
  • mightyjlr Level 1 Level 1 (5 points)
    Yes. Move your mouse to the top of the screen and they reappear.
  • mightyjlr Level 1 Level 1 (5 points)
    Yes. Move your mouse cursor to the top of the screen.
  • Old Toad Level 10 Level 10 (127,705 points)
    First try the following: close iPhoto, delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your User/Library/Preferences folder, launch iPhoto and see if that helps.


  • Denny Mcnally Level 1 Level 1 (5 points)
    Tried that. Still doesn't show pics in edit mode?
  • Old Toad Level 10 Level 10 (127,705 points)
    When did this begin? Where are these photos originating from?
  • Tomasz Gutowski Level 1 Level 1 (5 points)
    I have a similar problem on my G5 Dual core 2.7 Ghz Powermac. Every time I try to edit a photo, the screen turns white. I tired reinstalling the app. deleting preference panes, repairing the drive, and permissions and nothing works. I went a far as reinstalling the system clean and reinstalling the iLife but the problem persists. This seems to be unique to my G5 computer because my intel MacBook Pro works fine with the same library. I hate to say it but it may be a bug.
  • Old Toad Level 10 Level 10 (127,705 points)
    Welcome to the Apple Discussions. Where are these photos from? What camera? It may some were having problems with a particular graphic card but I don't have that info at hand. Create a new library, import some of the offending photos and see if they behave the same there. Next log into another account and try there. If you don't have one create a new , non-admin account with no add ons. It's a great trouble shooting tool.


  • Tomasz Gutowski Level 1 Level 1 (5 points)
    I tried new library with only one photo in it and it does the same thing. This was on a reformatted, newly installed 10.5.6 that did not have anything else installed (just system and iLife). As I mentioned above, I used the same library on an Intel MacBook Pro and it works fine.
  • Viol8r__dk Level 1 Level 1 (10 points)
    Same problem here. Happens on about 10% of my photos.

    Here's a link to an image that goes black when edited in iPhoto 09.
    http://dft.demo.letsoftware.dk/IMG_0015.jpg (don't click unless you really want to try it as it's a big download).

    The image is from a Canon 8800F scanner. 95% of the photos are ok - they are all about the same size (some bigger, some smaller), so it doesnt appear to be a size/dimension issue.

    If I click the "effects"-button in iPhoto the full size image will however show up, but when adjusting using the edit controls nothing happens to the image.

    The graphic card is a NVIDIA 7600GT (some other users have indicated that it only happens with NVIDIA cards)...?

    Any ideas? (and I've tried reinstalling, deleting prefs and plists and all the usual stuff)...
  • Terence Devlin Level 10 Level 10 (133,960 points)
    Welcome to the Apple Discussions.

    I think there is a bug in here and it only affects Canon created shots.

    We had a poste rhere about 10 days ago, and his problem was the same. Shots taken with Canon 5d (I think, but definitely a Canon) would show up as black in edit more.

    But if you move the size slider lower left, the shot pops into view.

    However, the navigation window remains blank.

    Exactly like your shots do.

    iPhoto menu -> Provide iPhoto Feedback

    Edit: I Converted the shot to a tiff (using Graphic Converter) and it imported and displays correctly

    Regards

    TD

    Message was edited by: Terence Devlin
  • Viol8r__dk Level 1 Level 1 (10 points)
    I don't think it's a "canon" only issue.

    First of all - this is a negative scanned using MP Navigator - a Photo from a 5D would probably be very different.

    Also - if I open up the image in Photoshop and do a "save for web" as jpg (which basicly strips the image of all profiles and stuff) it still behaves the same (black edit window).

    EDIT:
    Just did some experiments:

    Same image - saved from Photoshop in different formats:

    1. TIFF - Works as it should (as you tried)
    2. JPEG (normal save) - Works as it should
    3. JPEG (save for web w. icc profile) - no go
    4. JPEG (save for web wo. icc profile) - also no go.
    5. JPEG (save for web, scaled 99%) - Works.
    6. JPEG (save for web, scaled 99% and scaled back to original size 6751x4326px) - no go...

    ?!?

    Message was edited by: Viol8r__dk
  • Old Toad Level 10 Level 10 (127,705 points)
    I just ran a series of tests on the file and what I found is that if the resolution is set to 4798 or less (document dimensions left at the 1.406 x .901) using Photoshop the file will behave as it should. But at a resolution of 4799 or greater it's lightsoutville.

    I then took one of my photos and resized it to 1.405 x .901 at 4800 dip, 4799 dpi and 4798 dpi. This photo acted just like yours. Above 4798 dpi it went black. So I'm guessing it's a number of pixels issue. Any file over 83.4 million pixels iPhoto can't handle properly. It's not just the file size as the two lower resolution files were 3 times as large as the original.

    OT


    Message was edited by: Old Toad
  • Viol8r__dk Level 1 Level 1 (10 points)
    Thanks Toad,

    But I'm just not convinced that's the reason why it doesn't work.


    Two images from the same batch scan with same settings, except dimensions:

    http://let.vmlinuz.dk/IMG_0015.jpg

    4800dpi, 6751x4326px, 27.85MP


    http://let.vmlinuz.dk/IMG_0018.jpg

    4800dpi, 6767x4424px, 28.55MP



    IMG_0015.jpg does not work. IMG_0018.jpg works fine.
    So maybe it has something to do with the proportions of the image or the image itself?
  • Old Toad Level 10 Level 10 (127,705 points)
    Another brilliant theory goes down in flames. I guess the engineers on the mother ship will have to step in and solve the mystery.
Previous 1 2 Next