9 Replies Latest reply: Mar 6, 2009 4:25 PM by Scott Herman
Scott Herman Level 1 Level 1 (25 points)
My MacBook Pro (original) has now randomly shut down 5 times since I installed 10.5.6 the week before Christmas. 4 of those 5 times happened with the power cord plugged in, the green indicator light on and the installed battery fully charged. I have two batteries and it has happened with each of them at least twice. Yesterday I got my first shutdown while on battery only. After each shutdown I was able to restart the computer and it operated normally, even the one on battery only.

These shutdowns are fast and complete. There is no warning of any kind. The screen just goes blank. It is not sleeping, there is no pulsing light on the front. Using the start key begins the process from scratch with the Apple "startup chime."

The occurrences have gotten more frequent. The first two were within 24 hours of when I installed 10.5.6 and they happened within several hours of each other. Both of these were with the power cord attached and fully charged batteries. I swapped the battery after the first one. When it happened again, I swapped them again.

The next time I had the problem was 1/30 (last Friday). The only significant software installation I had done between installing 10.5.6 and then was to install iLife '09 on 1/28. All software updates had been installed in a timely manner. Friday the laptop was plugged into external power and the battery was fully charged, but I don't know which battery was installed.

2/1 I had an issue where my computer couldn't locate the OS file on startup so I did a archive and install. It operated normally since then until yesterday, 2/4 when I had two shutdowns. The first I had the computer on external power and a fully charged battery. The second was the ONLY time I have had the shutdown occur while on battery power only. I was on a flight when the second shutdown occurred. I had used all the power in the battery that was installed when the first shutdown happened (down to about 11 minutes remaining). I then swapped batteries without shutting the computer down. The system rebuilt itself normally and I began working on iPhoto. About an hour later it just shutdown. I was able to restart the computer normally and used it for another 45 minutes or so before I shut it down for landing.

I called Apple Care this morning and they advised me to get an appointment with a Genius. I resist being without my laptop but will try this and let them look over the console log to see if they can find anything.

I have done all the basics, reset the PMU, zapped the PRAM and repaired disk permissions. The next thing I am going to do is to calibrate both batteries. I doubt this will have any impact on the issue because most of the shutdowns have occurred with external power connected. I just haven't done this in a while.

Any ideas out there? Anyone have a similar problem?

I have another issue on my Mac Pro since installing 10.5.6 and my wife's iMac G5 has a completely different issue since installing 10.5 (I didn't install this OS until last week so I could get the new iLife on it). Seems like this latest OS version is a bit buggy or at least incompatible with a lot of Apple's products in different ways.

Fight On!

MacBookPro 2.16, Mac OS X (10.5.6), 2.16 GHz, 2 GB RAM, 250 GB HD
  • Scott Herman Level 1 Level 1 (25 points)

    First, I did calibrate both batteries per the instructions located here in the Apple Support site. It took me a couple of days to actually get it done with two batteries.

    I got a reprieve for a while after the initial post but that lasted a week. Whatever is happening seems to be accelerating now. Here's the run down:

    2/11 Computer plugged in, battery fully charged, unattended.
    2/15 Computer plugged in, battery fully charged, unattended.
    2/17 Computer plugged in, battery fully charged, working on iPhoto, the '07 battery
    2/20 1314 CST Computer plugged in, battery 96% charged, watching streaming video in Safari, working on iPhoto, the full monty of programs open (see below for list), the '08 battery
    2/20 1350 CST Computer plugged in, battery fully charged, watching streaming video in Safari, working on iPhoto, only two other programs open (iChat & iCal), the '08 battery

    I don't know which battery I had installed for 2/11 & 2/15.

    I tend to keep Mail, Safari, iChat, Activity Monitor open all the time. In addition I often have iPhoto, iCal, Address Book, Firefox, MSExcel and Photoshop Elements 4 open (sometimes all, more likely some combination). This has been my pattern for a long time on this laptop.

    Mail, Safari and iChat are almost always open on this thing when it's on. I usually open them right after I start up. The exception to that would be iChat. If I am working on something it is usually photo's so iPhoto is the next most open program. IF I can't edit something in iPhoto I will also have Photoshop Elements open. The communication programs aren't open when I'm using it in flight.

    I have an appointment at the Genius Bar in the Escondido Store tomorrow at 6 PM. I'll be bringing these two posts to show them. I sure hope they can come up with something. This machine is now almost 3 years old and my Apple Care is about to expire!!! I guess I should be glad the problem showed up when it did instead of 3 months later.

    Fight On!
  • Scott Herman Level 1 Level 1 (25 points)

    Took this computer into the Apple Store near me (Escondido, CA). I printed out my two previous posts for them. They kept my computer overnight to "stress" test it. I knew that with the infrequency of this issue that it would probably not be fruitful. Next day about 1:30 PM I called and, surprise, they had not been able to duplicate the issue. I got my laptop back from them before 3:30 PM.

    Last night I had another event. This time the computer was unattended, power was plugged in and the '08 battery was fully charged. The shutdown occurred about 90 minutes after I last used it so it could have coincided with the computer going to sleep. I didn't note the exact time I last used the thing so that may be a reach. Besides, most of the other shutdowns have been when I was using the computer so even if it happened at sleep, it's kind of irrelevant. The only programs I had open were iPhoto, Mail, Safari, Firefox, MSExcel and iCal.

    I did copy the last few entries from the Console.

    These were the last Console Messages:
    2/23/09 10:46:58 PM com.apple.launchd[80] (com.epson.epw.agent[15414]) posix_spawnp("/Library/Printers/EPSON/InkjetPrinter/EPW/IJEPWAgent.app/Contents /MacOS/IJEPWAgent", ...): No such file or directory
    2/23/09 10:46:58 PM com.apple.launchd[80] (com.epson.epw.agent[15414]) Exited with exit code: 1
    2/23/09 10:46:58 PM com.apple.launchd[80] (com.epson.epw.agent) Throttling respawn: Will start in 10 seconds

    They repeat about every 10 minutes and seem to be benign.

    This was the last message from All Messages:

    2/23/09 10:47:02 PM /System/Library/CoreServices/backupd[15413] Node requires deep traversal:/Users/appleasd/Pictures/iPhoto Library reason:kFSEDBEventFlagContainsChanges|kFSEDBEventFlagMustScanSubDirs|kFSEDBEven tFlagReasonFSEvent|kFSEDBEventFlagReasonMissedReservation|

    It was different. I'll look into the All Messages from now on when it happens. Although the first shutdowns were right after 10.5.6 was installed, maybe it is more related to the new iPhoto.

    Fight On!
  • remoch Level 1 Level 1 (0 points)
    I am having the exact same issue with my MBP 17". This issue has only just recently come up. I am in the habit of putting the computer to sleep and carrying it to my next destination to resume work (did it with my iBook for 3 years, and then the white MacBook for a few years with no problems).

    Recently, the battery has been giving me serious troubles. It will either not be recognized (x in the battery icon in the menu bar) or it will go in and out of being recognized (and charging) to not being recognized. I also get random shutdowns if I attempt to run on battery power alone. Usually, the shut down occurs within minutes (~ 5 min or so) of removing the magsafe adapter. I have also recently been experiencing random shutdown while connected to the magsafe.

    I went to the Apple store and spoke to a genius and he performed a test on the battery and it showed up as bad so they immediately gave me a new one. The problem is that the new battery also exhibits the same behavior.

    I am convinced that it is an update issue, but I can't figure out exactly which update is responsible.

    I am taking my machine to the local apple repair shop to get it checked out, if they figure out what's going on I'll let everyone know.
  • Scott Herman Level 1 Level 1 (25 points)

    I thought it might be a battery issue but I am using two different batteries and each has been installed when this issue happened. I thought about the battery because a couple of years ago an update (battery firmware) fried one of my batteries. They replaced that one. Anyway, they don't think it is battery related after they checked everything out BUT they also don't know what is causing it.

    So you have the same problem that your MBP just shuts down? Both while you're using it and while you are not! No warning, no flashing screen, nothing but the sudden black screen? How often has this happened to you? How long has it been happening? Did it begin when you installed 10.5.6?

    Fight On!
  • Marcus Hammonds1 Level 1 Level 1 (5 points)
    Over the past few weeks, I've been facing the same issue and I'm on 10.5.5...

    It's occurred about 3 times, twice with the computer not connected to AC and once while connected to AC in sleep mode. No idea what's causing it, but I hope it's not a hardware issue...
  • Scott Herman Level 1 Level 1 (25 points)

    I had my laptop shutdown 4 times yesterday, one of them while on the phone with Apple Care about another issue. All four of these happened while the processors were busy with a task, looking for faces in iPhoto.

    Here's a rundown on the shutdowns....

    2:16 PM '07 battery installed and fully charged, ext power plugged in
    iPhoto searching for faces (after discarding face.db)
    Mail, Safari & iCal were also open

    5:12 PM '07 battery installed and fully charged, ext power plugged in
    iPhoto searching for faces (after discarding face.db again after rebuilding iPhoto)
    Mail, Safari, iCal, Console and MSWord were open.

    5:42 PM '08 battery installed and 32% charged, ext power plugged in
    iPhoto searching for faces again after restart
    MSWord & Console were the only things open

    5:51 PM '08 battery installed and 42% charged, ext power plugged in
    iPhoto searching for faces again after restart

    Here are the Console Messages for the last 3 shutdowns. They were all identical except the time...

    2/27/09 5:51:31 PM com.apple.launchctl.System[2] fsck_hfs: Volume is journaled. No checking performed.
    2/27/09 5:51:31 PM com.apple.launchctl.System[2] fsck_hfs: Use the -f option to force checking.
    2/27/09 5:51:35 PM com.apple.launchctl.System[2] launchctl: Please convert the following to launchd: /etc/mach_init.d/dashboardadvisoryd.plist
    2/27/09 5:51:35 PM com.apple.launchd[1] (com.apple.blued) Unknown key for boolean: EnableTransactions
    2/27/09 5:51:35 PM com.apple.launchd[1] (org.cups.cupsd) Unknown key: SHAuthorizationRight
    2/27/09 5:51:35 PM com.apple.launchd[1] (org.ntp.ntpd) Unknown key: SHAuthorizationRight

    I don't know if they mean anything but they are consistent.

    I called Apple Care again this morning and after much discussion with a Product Specialist his thought is it could be a logic board issue. I was told to take the laptop into an Apple Store and reference my case #. I'll let you know the result.


    Fight On!
  • Scott Herman Level 1 Level 1 (25 points)

    Service was due and now that I saw the machine fail 4 times in a day doing the same process I knew I could duplicate the issue on demand. That's a big bonus.

    Called Apple Care yesterday morning and the guy I spoke with read over the notes on my case after I told him what happened the day before (black friday, 4 shutdowns). While he didn't transfer me to a Product Specialist, he did talk to one for quite a while (I was on hold for about 20 minutes while he did this). He said I could ship it to Apple and they would look at it or I could take it to an Apple Store or Authorized Service Center. Thinking this was the next step I had secured a time at the Carlsbad Apple Store for late that afternoon (my usual & closest store, Escondido, was booked all weekend). They told me to take it in and reference the case number. The Product Specialist thought it sounded like a logic board and would duly note that diagnosis in the case history.

    After the conversation ended I decided to make sure I could cause the failure. So I started the process (threw out the face.db from the iPhoto Library package and opened iPhoto whereupon iPhoto begins a scan of the images for faces. Having over 12,000 images gives it a lot of work). This time I decided to monitor the workings of the laptop using iStat Pro (freeware widget download & I recommend making a small donation it's so good). I kept track of the processes at 5 minute intervals, the CPU usage, numerous temps AND the fan speed. The latter seemed to be the critical. Shortly after the fan speed got to 4700 the shutdown occurred. It took 36 minutes from the time I started. The fans kind of confirm to me that it could be the logic board.

    I took the laptop to the Apple Store and started the process in front of the "Genius." He read through the case as well as the printed copy of this thread and other notes I brought from previous shutdowns including the data I mined from iStat Pro. He was unimpressed and thought it was a non-issue. I guess that's only fair because I was unimpressed with him. He figures it's my system because of a software conflict somewhere. His answer was to do a clean install and reinstall all the software from the original disks. I told him I have spent over 50 hours on this issue to date and that what he was suggesting would take at least that much and guarantee nothing if it's a database issue...duh! Disagreement. Oh, and he also doubted it would fail just from making it work.

    43 minutes after starting the process, well after my "Genius" went home for the day (I was his last appointment), the failure occurred. The "Genius" he handed me off to was working with someone else next to where I was sitting. When the fans hit 4700 rpm I told her it was going to happen soon and as I finished my sentence the failure occurred! Cool.

    They have the machine and I'll let you know what they do.

    Fight On!
  • Scott Herman Level 1 Level 1 (25 points)

    I got my computer returned to me via Fedex on Wednesday morning. That means they had it about the minimum they could. The Apple Store where I left the MacBook Pro probably shipped it to the repair depot Monday AM; the repair depot fixed it and shipped it Tuesday PM.

    Apple replaced the logic board and both fans.

    I was on a trip and returned home this morning. I am testing it right now using the same process that got it to fail with such regularity, discarding the face.db in the iPhoto package and then opening iPhoto (which makes iPhoto search the Library for faces).

    So far the test has been going on for over 2 3/4 hours with the fans peaking at 3200 rpm a few minutes ago (they have settled back to 3080). When I last saw this computer it would fail under doing this process in under an hour. The failure seemed to occur when the fans hit 4700 rpm. This is a dramatic improvement. I also notice less heat being generated from the laptop.

    According to iPhoto it still has 175 minutes left in it's search for faces. I will let it run until it is complete with the task. I will report back with the final results but it is looking good.

    Fight On!
  • Scott Herman Level 1 Level 1 (25 points)

    After more than 5 hours using the process (scanning iPhoto Library for faces) that worked so well at triggering the failure (shutdown) last Friday (4 times) and Saturday 9 (2 times) my MacBook Pro failed to fail!!! Yippee. That's right, in more than 5 hours working the same process that triggered the shutdowns all in less than 50 minutes, my MacBook Pro with the new logic board and fans continued to operate flawlessly, never even approaching the 4700 rpm that seemed to be the trigger for these shutdowns. In fact, the peak fan rpm didn't top 3300 and soon after reaching that after 70 minutes, the fans actually began to slow, settling to under 2000 for the rest of the process.

    It is interesting to note that this issue arose in conjunction with the installation of 10.5.6 but appears, based on the fix, that it is coincidence and nothing more. It is a hardware, not a software issue.

    I am going to mark this issue OFFICIALLY over although the answer did not come from this forum.

    Fight On!