3 Replies Latest reply: Feb 10, 2009 4:10 PM by BDAqua
Grebus Level 1 Level 1 (0 points)
I am experiencing a problem with mail hanging up when trying to open it on my iMac G5. Force quitting and turning off the computer did not help. The spinning wheel just keeps spinning. My wife has a separate user account on the same computer and her mail works fine. My mail account at mac/me.com is fine. Also, mail works OK on my laptop. A previous entry describing a similar problem by Edz says he got his mail to work but did not say how. I can only hope there is a simple solution to restore mail.

iMac G5, Mac OS X (10.4.11)
  • BDAqua Level 10 Level 10 (120,655 points)
    Hi Grebus, and a warm welcome to the forums!

    Quit Mail...

    First I'd backup these two Mail folders, by right clicking on them in the Finder, then choose Archive/Compress.

    Users/YourUserName/Library/Mail

    Users/YourUserName/Library/Mail Downloads

    Right click on that Mail folder, choose archive, you'll get everything in the folder, and the folder itself in a file called Mail.zip, move it to a safe place, same for the Mail Downloads folder... only the plist is separate.

    /Users/YourUserName/Library/Preferences/com.apple.mail.plist

    Not certain, but this can fix myriad Mail problems...

    Safe Boot from the HD, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, then move these folder & file to the Desktop.

    Move this Folder to the Desktop...

    /Users/YourUserName/Library/Caches/Mail/

    Move this file to the Desktop...

    /Users/YourUserName/Library/Mail/Envelope Index

    Reboot.
  • Grebus Level 1 Level 1 (0 points)
    The problem is fixed. I am not an under-the-hood computer person but, once I figured out where the different folders were hiding, the steps provided by BDAqua were easy to follow. Thanks for the help.
  • BDAqua Level 10 Level 10 (120,655 points)
    Great news, good work on your part, and thank you for the report!