7 Replies Latest reply: Feb 9, 2009 3:46 PM by Barney-15E
simon12 Level 1 Level 1 (0 points)
This is driving me crazy!!! I hope someone can help.

I was in the Apple shop today and was shown briefly how to use the mac to transmit a wifi signal of my cable-connected internet connection.

When I got home, I seemed to be able to set up a "computer to computer" signal okay. My laptop connected to it and surfed the web. Now however, after fiddling a bit, I can't seem to be able to do this again. Instead, I can see the 'computer to computer' network but I can't connect to it.

If I go into Sharing and click on Internet Sharing, it then changes this network into a full Wireless network that my PC can still find but cannot connect to.

I have no idea where I am going with this other than around in circles so hopefully someone can help me.

imac, Mac OS X (10.5.6)
  • Barney-15E Level 8 Level 8 (40,340 points)
    I think file sharing and internet sharing are mutually exclusive on the same interface.
    Perhaps someone can provide a more definitive answer.
  • simon12 Level 1 Level 1 (0 points)
    OK - all of this is driving me mad. Here is a list of all the problems I am having. Can someone please help me with at least one of them.

    1. Can't connect my PC laptop (XP SP3) to my iMac's Airport signal as above.

    2. In the drop down menu on the airport fan icon, there is a section called 'devices'. In there I have the name of an old network I created when trying to solve this problem. I want to delete it but I can't. I HAVE TRIED TO FIND IT UNDER SYS PREF - NETWORK - AIRPORT - ADVANCED AND THEN DELETE NAMES UNDER PREFERRED NETWORKS BUT IT IS EMPTY.

    3. My PC laptop keeps finding network names that are not connected. I even switched the mac off and my PC kept seeing the network names as active with 5 bars. WHY!!!????

    4. I don't know what DHCP is, what hex names etc are, I have created unsecured networks using Internet sharing both ON (Airport icon has an up arrow) and OFF(Airport icon has a computer has a little computer screen). I don't get all these abbreviations that I am supposed to understand.

    I simply want the thing to work which it DID do at the start with Internet Sharing off and a local computer-to-computer network created.

    Can anyone suggest something that isn't mentioned above please?
  • Barney-15E Level 8 Level 8 (40,340 points)
    When you create a computer-to-computer network, there is no internet sharing involved. You can connect to the other computer to share files. That's it. It is called an ad-hoc network in Windows.

    If you set up Internet Sharing, you can file share and get internet to the computer. On the Mac, you will be able to only see the computer you are connected to in the Shared section of the sidebar. However, you can still connect to another computer on the network by entering the address directly in the Connect to Server… function in Finder.

    I can't tell you why your Windows machine sees a network that is not broadcasting. It could be that it doesn't keep updating and just shows what it's seen before.
  • BobHarris Level 6 Level 6 (14,925 points)
    While using your Mac as your WiFi base station (Internet Sharing) is fine when used on a limited time basis, however you will be much better served if you get yourself a WiFi base station. They are not very expensive, especially if you look for some deals (dealmac.com).
  • simon12 Level 1 Level 1 (0 points)
    Where is the Connect to Server function in Finder? I can't seem to find it.Please explain it in really simple terms!
  • Allan Eckert Level 8 Level 8 (46,100 points)
    Hi simon12;

    On my Mac the last entry in the pull down menu titled Go is Connect to Server. Hope that helps.

    Allan
    tiger
  • Barney-15E Level 8 Level 8 (40,340 points)
    It is where Allan said it was.
    To connect to a Mac, use afp://<IP Address> or afp://<Bonjour Name> as found in Sharing preferences.
    Examples: afp://192.168.1.4 or afp://Simon's iMac
    To connect to a PC, use smb://<Server IP Address>/sharename
    Examples: smb://192.168.1.4/C$ or smb://192.168.1.4/MySharedDocs/