12 Replies Latest reply: Feb 12, 2009 5:29 AM by Charles Dyer
alankellyeire Level 1 Level 1 (0 points)
the last day i connected to the next door neigbours routor. and there computer came up in the finder window and i was able to browse there shared folders. when i connect to my routor which has a windows xp laptop connected to it via wifi nothing comes up in the finder window.
does anyone know how i can get it to come up in the finder window and be able to browse the shared folders.
i have a macbook with 10.5.6

thanks for any help

MacBook, Mac OS X (10.5.6)
  • ericmeyers Level 4 Level 4 (1,410 points)
    Sometimes it can be flaky. You can manually connect to the Windows box by selecting Go->Connect To Server (in the Finder menu) and putting in smb://theipaddressofthewindowsbox as the server address.

    Eric
  • BobHarris Level 6 Level 6 (15,905 points)
    Make sure you are using the same Windows Workgroup
    System Preferences -> Network -> WINS and specify the same Workgroup that your Windows XP system is using.

    While you are in that control panel, you might also specify a simplified NetBIOS name. Keep it simple.

    You shouldn't have any WINS Servers as they tend to be something you see in a corporate environment.

    Another approach is to install *Bonjour for Windows* on your Windows XP system, which will get your Windows system to be more friendly towards you Mac
    <http://support.apple.com/downloads/BonjourforWindows>

    Sometimes your Firewall can interfere with discovery protocols. Experiment with this
    System Preferences -> Security -> Firewall

    One more point. You want to make sure that both your Windows XP system and your Mac are on the same subnet, as most of these automatic discovery protocols only work for system on the same subnet. You could be on different subnets if you have 2 routers in your home with one system attached to one router and the other system connected via the other router. For example, one system attached to an ISP provided broadband Modem/Router combo device, and the other system attached to a WiFi base station plugged into the ISP's broadband Modem/Router. In this situation, you would disable the WiFi base stations routing functions by either putting into "Bridge" mode, or disabling the NAT and DHCP servers in the WiFi base station. Again you would do this IF AND ONLY IF you had 2 active routers in your home.
  • Charles Dyer Level 4 Level 4 (2,620 points)
    How I do it is fairly simple:

    1 go to all the computers that I want to be able to access over the network, Mac or Windows, and get their MAC addresses.

    2 at any computer, Mac or Windows, and launch the router configuration page.

    3 proceed to the section of the router configuration page where I can set up DHCP reservations. Using the MAC addresses from step 1, reserve IPs.

    4 restart the router. On startup, the router will assign the reserved IP addresses to your computers.

    5 on the Windows machines, assign usernames and passwords as necessary to allow someone to log in from over the network. If your Windows machines are using NTFS file systems (probable if you're using XP, certain if you're using Vista) set the permissions; if you don't do that, network users will be able to read but not write to the file shares. On the Macs, assign usernames and passwords and set permissions for those users.

    6 in a Mac running OS X 10.5.x, look in the Finder sidebar. You should see the names of the various Mac and Windows computers, and any other shared device, such as a printer, on the network. Click on the name of the computer you want to access. It may request that you connect as a particular user; give the username and password you set up in step 5. Save it to your keychain. You're in, and your Mac will remember the computer name, IP address, and the username and password you used. You may have to select the actual folder you want to access. In a Windows machine running Vista or XP Pro, get the Network dialog up on screen. (On Vista, just select 'Network' from the Start menu; on XP, step through the Network shares windows as necessary.) You should see the various machines on the network. Double-click on the one you want, enter the username and password, tell Windows to remember it.

    You're golden. This works with wired or wireless networks, and (with slight changes) with any version of OS X from 10.2 up and any version of Windows from Windows 2000 up. I use reserved IPs because doing things that way makes it much simpler to remember the IP address if I have to go in by hand, and the system will remember the IP so that I don't have to go in by hand very often, and doing it that way means that I don't have to manually assign a fixed IP to everyone, which means that I can use DHCP and let others in to the network if necessary without having to go to a lot of trouble. You can just use DHCP, but it's not as reliable.

    Message was edited by: Charles Dyer
  • simon12 Level 1 Level 1 (0 points)
    I have been trying to get my xp machine to use the Mac's ability to use Airport as a wifi network but with no luck. See this post:http://discussions.apple.com/thread.jspa?threadID=1899013&tstart=45

    I am running an iMac aluminium 20" intel. It has Aiport built in and when I go to the airport utility, all the manual options of entering info are greyed out. The only thing it will let me do is scan for Apple wireless devices of which I have none.

    Could you advise me in FAR simpler language what you think I might need to do to manualy input all the info I need to get these two computers to connect? I don't know for sure where the fault lies - with the Mac or with XP. I can see the Mac's network I created but I can't connect to it. I have found the MAC addresses of both machines but I have no idea what to do now, or if I even need to 'do' anything since I figure these machines should simply connect with no problem.
  • Charles Dyer Level 4 Level 4 (2,620 points)
    You probably have the system set for DHCP. Select Manual setup instead. You can then input your own IP. I'd use a private Class C range, such as 192.168.0.x, where 'x' is 1 to 254, if I were you. Set the Windows machine to use another IP in the same range. (If the Mac uses 192.168.0.10, have the WinBox use 192.168.0.11. Or something, anything, so long as it isn't 192.168.0.0, 192.168.0.10, or 192.168.0.255 or larger.) The Subnet mask should be 255.255.255.0 and the router should be 192.168.0.10 if you use my example.

    It'd be a lot simpler to use a router running DHCP.
  • simon12 Level 1 Level 1 (0 points)
    I tried all that and I still have the same problem...the XP says it's connected but I can't get online. (I can always tell anyway because the wireless symbol says connected but my Skype icon keeps trying to connect and never does).

    I reset the numbers as you suggested and on the XP I set them by choosing the connection - change advanced settings - general - internet protocol (TCP/IP - properties - use the following IP address. Then I entered the info in the top box so that it was one number out but kept the same subnet mask. Should I have done anything else?
  • Charles Dyer Level 4 Level 4 (2,620 points)
    What are the exact IP addresses for your Mac, your router, and your XP machine? And what are the subnet masks? And have you input a DNS address? If so, what? If not, what happens when you input a DNS server address such as those for OpenDNS, 208.67.220.220 and 208.67.222.222?
  • simon12 Level 1 Level 1 (0 points)
    Hi,

    For the Mac, I am looking under Sys Prefs - Network - Airport - Advanced - TCP/IP button and it's configured as:
    Configure IPv4: Manually
    IPv4 address: 192.168.0.10
    Subnet Mask: 255.255.255.0
    Router: 192.168.0.10
    There were no DNS entries under DNS so I have inputted 208.67.220.220 and 208.67.222.222

    For the Windows, I am looking under Control Panel - Network Connections - Wireless Network Connections - rightclick to then go to Properties - stay under the General tab and click on Internet Protocol (TCP/IP)- Properties - click on Use The Following IP Address. The settings here are:
    IP address: 192.168.0.11
    Subnet mask: 255.255.255.0
    Default gateway: 192.168.0.11 (not sure if I should've left this as empty).

    There were no entries under "use the following DNS server addresses". I have now put in the numbers that you suggested. Under Pref DNS is 208.67
    220.220 and under Alt DNS is 208.67.222.222 .

    Under "advanced", the IP and subnet addresses are in the IP address box. The default gateway appears in its box and it says Automatic under Metric.

    Also, just to reiterate, I have this set as an open network with no data encryption (just so I can get it to work easier).

    Also, I have tried to look and see if I can change anything under the Airport Utility but all it does is scan for other Apple devices (of which I have none) and greys out all the options like manually inputting info.

    Unfortunately, even tho the XP does seem to 'connect' quicker it still fails to actually go online. I feel like I'm almost there but there is something really obvious I can't see. Hopefully you can!
  • Charles Dyer Level 4 Level 4 (2,620 points)
    The default gateway on the XP machine should be the same as the router address on the Mac. This is because the XP machine is using the Mac as its router.
  • simon12 Level 1 Level 1 (0 points)
    Still no luck. I have put in the default gateway on the XP machine as 192.168.0.10 which matches the router address under Airport on the mac.

    Someone I was speaking to suggested it may have something to do with Airport allowing my xp machine access using MAC fltering. I have found the MAC address (Airport ID) for the imac, but do you know where I find the area where I can turn filtering on or off and do you know where I find the MAC address for the XP machine?
  • simon12 Level 1 Level 1 (0 points)
    ...I may have answered this last question. I found both MAC addresses and I got into the software for my wired broadband modem (Thomson ST510) and from what I can see the modem doesn't support MAC filtering so that puts paid to that.

    So...back to where we were. Can you see anything obviously wrong? In case it helps, if I plug the modem directly into the XP machine, I can connect fine to the net so it doesn't appear to be a problem with the modem itself, more the connection between the imac and the PC.
  • Charles Dyer Level 4 Level 4 (2,620 points)
    You should be able to make it work. But if it's giving this much trouble, I'd just go and get a wireless router and have done with it.