1 Reply Latest reply: Feb 9, 2009 6:48 AM by gallai
gallai Level 1 Level 1 (25 points)
I have been experiencing very slow mail deliveries when trying to send from Mail. Regardless of which account I use (Gmail, Mobileme, etc...).
Progress window would just show "Delivering message" and "Connecting to server" for 30+ seconds before actually doing anything.

I was originally going to post this question here but after then I saw a tip from a guy in another topic.
That tip solved my problem!
That topic is already closed for replies so in case you are having this issue as well, here is what you need to do! I hope it helps someone.

Basically, add the IP address of your DNS (your ISP's name server) manually to your network preferences. It seems unnecessary but it worked like magic. SMTP sending now takes just a few seconds.

For those who don't know,
System Preferences -> Network -> Airport (or Ethernet if you're using a cable) -> Advanced... -> DNS
SCREENSHOT:
http://img187.imageshack.us/my.php?image=picture3si4.jpg

Macbook Pro, Mac OS X (10.5.6)