Skip navigation
This discussion is archived

no jdns_sd in java.library.path in Linux

5045 Views 1 Reply Latest reply: Feb 17, 2009 6:53 AM by alorenzo RSS
alorenzo Calculating status...
Currently Being Moderated
Feb 10, 2009 2:15 PM
I have compiled mDNSResponder-107.6 successfully. When I run in Linux;
Linux itx-01 2.6.26.8-57.fc8 #1 SMP Thu Dec 18 19:19:45 EST 2008 i686 i686 i386 GNU/Linux
I get:
Exception in thread "main" java.lang.UnsatisfiedLinkError: no jdns_sd in java.library.path
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1682)
at java.lang.Runtime.loadLibrary0(Runtime.java:823)
at java.lang.System.loadLibrary(System.java:1030)
at com.apple.dnssd.AppleDNSSD.<clinit>(DNSSD.java:567)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at com.apple.dnssd.DNSSD.<clinit>(DNSSD.java:503)
at SimpleChat.<init>(SimpleChat.java:98)
at SimpleChat.main(SimpleChat.java:246)

Here is my cmd line:
java -cp .:BrowserApp.jar:SimpleChat.jar:../../lib/dns_sd.jar SimpleChat
mdnsd is running:
nobody 5472 0.0 0.0 2036 876 ? Ss 15:30 0:00 /usr/sbin/mdnsd

Thanks for the help!
alorenzo
Other OS

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.