Previous 1 10 11 12 13 14 Next 586 Replies Latest reply: Jul 4, 2015 1:29 PM by Gregster Go to original post Branched to a new discussion.
  • Dave Rathbun Level 1 Level 1 (50 points)

    I did not have the problem until the 10.6 update. I have been working (as shown by the various posts here) to try to isolate the root cause, and so far have not had much luck. The latest cd I riopped when over to my iPod 100% and then the files on the hard drive were completely erased, even the album folder was gone. That was the first time that had happened.

     

    Songs on the iPod will not sync "back" to your PC. The iPod sync process is one-way, which is Apple's way of preventing you from easily giving a copy of your entire music library to someone else simply by syncing your iPod to their computer. Same for iPhone and iPad. There are some 3rd party tools or scripts that will allow you to retrieve music files from your iPod if you really need to, but I've never used them.

     

    I tried going back to 10.5 and found out that my libary would no longer work. I could use the older version of my library, but I've ripped about 850 songs since the last update (yes, even with the deleting problems) and don't feel like going through that again. <sigh>

  • Dave Rathbun Level 1 Level 1 (50 points)

    So I may have figured out my problem, and it has nothing to do with iTunes. Well, not directly anyway. iTunes is still responsible for deleting the songs but I think the issue was caused by an incorrect time setting.

     

    Background Info: I keep my media files on a network file server (device) made by NetGear. It's a simple home RAID disk cabinet. I have two of these devices, each with redundant disks. I have my iTunes configured so rip / save files to this device.

     

    A bit over a month ago I purchased an upgraded unit. It had larger drives, but more importantly it was a faster CPU and had more memory, so the overall performance upgrade was very nice. That's where my iTunes library lives now.

     

    On or about the same time I upgraded the system software for both units to the latest version.

     

    All of this was done, and I never noticed any issues with iTunes. So I discounted that this might be part of the problem.

     

    However, if you've been reading my (frequent) updates to this thread, you might remember that as a test I used iTunes 10.6 to rip a few discs to my wife's computer to see if I could recreate the problem. I could not, as everything worked. Yet on my computer it was still happening. In fact, the last test I ran involved ripping a single cd and them immediately syncing to my iPod. The entire CD was deleted from my library, yet every one of the songs got copied to my iPod.

     

    Fast forward to this morning. I have a backup script that runs on the NetGear device at about 2:30 am, and I get an email from the script showing that the files were successfully copied. The files are stamped wtih the date and time of the backup. Now some time back (weeks ago) I started noticing that the backup times were off by one hour, but I chalked it up to a daylight savings time issue and didn't bother to investigate. This morning my backup files were stamped as August (which is wrong) of 1992 (which is not only wrong, but really, really wrong). After some investigation it seems that the NetGear time service was messed up. I reset to a different time service, and not only did the 1992 date get corrected by the hour difference was fixed as well.

     

    Hmm, I thought to myself. Was iTunes getting confused because the songs were ripped an hour in the future? I decided to run a few tests. Keeping in mind that since I first encountered this problem, I have never been able to successfully rip and then sync a full disc. Always some seemingly random number of songs would get deleted. After fixing my time server, iTunes worked perfectly.

     

    I have no explanation for this. But I would suggest that if you're storing your iTunes media on a different computer than what you're syncing from, that you carefully check to see that the time settings are the same on both machines. Later on (when I'm bored) I will go back and "break" the time setting on my NetGear storage device once again and test some ripping, just to see if the problem comes back. But for now things seem to be working.

     

    Go figure. Never would have figued this out without the "1992" screw up from NetGear this morning.

  • Opticnerver Level 1 Level 1 (0 points)

    I did two things when I decided to digitize my 250 CD library and use iTunes as the database...

     

    1. Make Multiple Backups Of All Media

    2. Make Multiple Backups Of All Library and Support Files

     

    and third;  any media that I buy without "hardcopy" I consider "volatile".

     

    This is "consumer software" folks, and we are more sheeple that "client."

     

    Caveat Emptor.

  • Eric Trueheart Level 1 Level 1 (30 points)

    My problem is a little bit different.  The songs disappear from iTunes, but they're still on the hard drive.

     

    When I try to drag them back into my iTunes library, they STILL don't appear.  iTunes will play them just fine, but it won't show them on the master song lists.  Weird!

  • Mexicali30 Level 1 Level 1 (0 points)

    Well I guess you can chalk me up for another baffled Itunes user.  So My Music folder is located on an external 1 Tb Hardrive that is attached via USB to my Time Capsule.  I have relocated my "Itunes Music Folder" to this location.

     

    It was working with zero issues for about a month.  I was able to access the music via two Mac's, My TV, and My PS3 which is attached to another TV.  No problems getting to any of the music.

     

    Then all of a sudden one day I go to the folder to move some of the music to my Android.  The music is gone.  I go to my Itunes and I am able to play EVERY single song.  I right click to "Get info," and it indicates it is still in the same location.  I right click the "location" to go to it.. and it goes directly to the folder like it's looking for the music.. but it never stops looking and the music never shows.  

     

    I am now unable to view the music in the folder from the TV/PS3 or either MAC.  Yet, I can still play the music via Itunes.  

     

    It's about 50 gb worth of music. 

     

    One last note.. I upgraded to snow leopard about a week ago.  I have a strong feeling this has something to do with it.. but I can't figure out what exactly. 

     

    I am also stunned that this has ZERO fixes after going on for so long.

     

    Help me Obi Wan Kenobi..

  • Eric Trueheart Level 1 Level 1 (30 points)

    Mexicali,

     

    I had some trouble finding my files the last time I upgraded my system.

     

    Have you tried repairing the permissions with Disk Utility and simply rebooting?  I know it's kind of basic, but that helped me out that last time.

  • Mexicali30 Level 1 Level 1 (0 points)

    Just so you now..  year and a half I am having this same issue.  Did you ever come up with a resolution?

  • Mexicali30 Level 1 Level 1 (0 points)

    I will give it a try.. I am not sure how repairing the permission would help though.  I can play the music via itunes.. I just can't get to it or even see it for that matter.  Even if I search for .mp3 nothing comes up except for a few scattered .mp3's I had on my machine. 

  • Eric Trueheart Level 1 Level 1 (30 points)

    A solution to my tracks disappearing from the library list?

     

    Yeah, it was as simple as quitting iTunes and starting it up again.  Everything magically reappeared.  Go figure.

  • Mexicali30 Level 1 Level 1 (0 points)

    I wrote that to RC178.   I am not having trouble with the tracks disappearing from itunes.. I am having trouble with the tracks disappearing from the folder in which they are contained.. yet still play.  Craziness.

  • Eric Trueheart Level 1 Level 1 (30 points)

    I have absolutely no idea why repairing the permissions helped me, but it did.  Honestly, a lot of this stuff feels like voodoo to me.

  • Mexicali30 Level 1 Level 1 (0 points)

    So how do I repair the permission to an external hard drive? 

  • Chris CA Level 9 Level 9 (78,015 points)

    Mexicali30 wrote:

     

    So how do I repair the permission to an external hard drive? 

    You don't need to.

    Select the external in the Finder then right click - get info.
    Scroll to the bottom and tick Ignore permissions.

  • Mexicali30 Level 1 Level 1 (0 points)

    UPDATE:

     

    Well I was unable to change the permissions on the actual folder. 

     

    What I have done to temporarily fix my problem.  I did two things and am not sure which one fixed it yet.  I enable my iMAC to view all hidden files.  I also removed the external hard drive from my wireless TC and direcly connected it to my PC.  Well when I enable the MAC to view all hidden files nothing happened.  The next day when I was removing the external from the TC and connecting it to my MAC nothing was happening.  I was unable to view the External HD at all.  So I did a reboot.  Upon reboot I was able to view all hidden files AND the external.  I went straight to the music folder and there it was.. all my music.  My itunes still played from that external just fine and I was able to move the music on/off the folder if need be. 

     

    I was happy.. and tired.. so I haven't attached the external back to the TC or I haven't disabled showing hidden files on my mac.  One of those two were the solution. 

     

    Thanks for all the help and feedback. 

  • Dave Rathbun Level 1 Level 1 (50 points)

    Jumping back in to say for what it's worth, iTunes started deleting tracks on syncing again today. I checked all of my earlier issues (mentioned previously in this topic) and the time seems accurate, and I could not find anything else out of sorts. Really frustrating.

Previous 1 10 11 12 13 14 Next