5 Replies Latest reply: Feb 12, 2009 6:54 PM by Tom Gewecke
foamtech Level 1 Level 1 (0 points)
Hi..for me Vista has a good way to help me to find letters on the keyboard ..with (on screen keyboard ) i write stuff in different languages and i hope mac got it somewhere hidden cos i did not find it ..please anyone could tell me how to turn the screen keyboard on ..thank you ..

MacBookPro4,1, Mac OS X (10.5.6), Intel Core 2 Duo 2.5
  • Malcolm Rayfield Level 7 Level 7 (28,075 points)
    In the "Input Menu" tab of "International" system preference, enable "Keyboard Viewer" (near top of window) and "Show input menu in menu Bar" (bottom of window. A flag should show in the menu bar. Click it to show the Keyboard Viewer. Press Option, Shift-Option, or Command-Option, to see special characters. If an accent mark is shown with a solid background, it will be placed on the next character typed.
  • Joe Salafia Level 2 Level 2 (255 points)
    System Preferences>International>Click on the input tab
    Check the box next to Keyboard Viewer. A little flag will now be in
    the Menu Bar on the right. Check the boxes next to the
    languages you wish to see. They will now appear in a list under the flag icon in
    the Menu Bar. Click on the flag & choose Show keyboard viewer.
    You can now easily switch between them any time you wish.

    Do a search in the help menu for keyboard viewer for more info.
  • foamtech Level 1 Level 1 (0 points)
    Thanks for your help ..but i need to get the keyboard on sreen where i could see it while i type ..
  • Barney-15E Level 8 Level 8 (44,220 points)
    Where does the keyboard show up when you follow the instructions given by the other posters?
    It shows up on the screen for me.
  • Tom Gewecke Level 9 Level 9 (75,970 points)
    i need to get the keyboard on sreen where i could see it while i type ..

    If you go to the "flag" menu at the top right of the Finder and down to Show Keyboard Viewer, it will appear on your screen.

    If you do not have Keyboard Viewer listed in the Input Menu and under the "flag" menu, the fix is here: