8 Replies Latest reply: Jun 21, 2009 6:31 PM by daneland
bamw504 Level 1 Level 1 (0 points)
I've read a bit about extraordinarily slow import speeds for iTunes 8 on Vista platforms - in the range of .1x to 3.5x - for a commercially purchased cd, but to no avail do have the knowledge yet to resolve this. Please, it is draining my reserves of futility. What can or should I do? Can I even do anything?

Toshiba Satellite A215, Windows Vista
  • GeorgeJames Level 1 Level 1 (0 points)
    yea im having the same problems too... im not sure if it is my cd drive or something else...
    i remember it used to imports cds at about 16x to 20x ish.
  • StrikerUK Level 1 Level 1 (10 points)
    The slowdown in itunes happened since version 7 if I remember right (error correction in preferances can slow down ripping as well). I used to have LG drives that where ripping at about 18x, then moved to Samsung and dropped to anything between 1x - 8x when I used to have an XP machine 3.0Ghz .
    And now the interesting bit.
    Since I built a new one with higher specs I expected that ripping would get faster. (I now have AMD Phenom II X4 3.00Ghz). The built is brand new from scratch. I tried ripping with the first DVDRW-ROM (LG) and got the same slow speed. This DVDRW-ROM is with IDE connection. When tried ripping with the other 2 LG BD-ROMs that are SATA connected speed shoot up to 26x!

    Try disabling error correction when ripping and see if there is a difference in speed, if not, if your motherboard supports SATA connection invest on a SATA DVDRW-ROM. It costs around £20.00 or approx $35.00. It worked for me.
  • maxsax Level 1 Level 1 (0 points)
    any progress on this? I updated to 8.1.052 tonight and now I cannot import CD's (err, I can at .1x if I want to wait all night). I used to import discs at full speed until now. i tried to update the gear drivers. reinstalled. tried to reinstall 7.7 (install failed). please advise if there's a cure.
  • Roy B Level 3 Level 3 (570 points)
    Hello everyone,

    If CD importing has gotten slow after updating to iTunes 8.1, please try this:
    1. Quit iTunes.
    2. Windows users: Launch iTunes while holding down the Ctrl and Shift keys on the keyboard.
    Mac users: Launch iTunes while holding down the Command and Option keys on the keyboard.
    You should get a notification telling you iTunes is opening in safe mode.
    3. Click Continue.
    4. Import a CD as you normally would.

    How is the performance? Please report back here.
  • Abd4253 Level 1 Level 1 (0 points)
    I just tried this and it made no difference at all. My ripping topped out at 4.5x when it used to be around 11x or 12x. Thanks for the suggestion, though! I wonder if Apple will address this with an update. I surely hope so.

  • Stephen Kreutzer Level 1 Level 1 (0 points)
    Same here - no difference whatsoever. Apple...get it fixed!
  • dealcloser76 Level 1 Level 1 (0 points)
    have similar problem with you. Any help? Thanks.
    <Edited by Moderator>
  • daneland Level 1 Level 1 (0 points)
    I experienced this issue, ripping a CD took forever w/iTunes 8. None of the suggested work-arounds helped. Problem went away when I upgraded to Windows 7 (RC)/iTunes