Previous 1 2 Next 17 Replies Latest reply: Mar 2, 2009 8:08 AM by Tonfelix
Tonfelix Level 1 Level 1 (0 points)
It is a very long story how I came to the point I am at right now, so I'll try to keep it really short:

My MPR stops booting and shows that Kernel Panic message (30s after starting the boot procedure with the grey screen and Apple logo), telling me to reboot. It even does not boot from CD/DVD anymore. Zapping PRAM doesn't help. Booting into Safe Mode doesnt work. Booting into Single User Mode and repairing the drive (/sbin/fsck -fy) did help a couple of times; scanning the system with Onyx and removing faulty preferences even helped a lot as well, everything seemed to work fine. But after the next system crash (happened during memtest procedure), I had the same problem again, this time even Single User Mode doesnt help. Booting from external FW-drive doesnt work. Every time: Kernel Panic.

Since I put in 4GB RAM four weeks ago (without any problems until last week), I replaced the new RAM with the old RAM. Still: Kernel Panic.

How I ran into the whole trouble? I replaced the original internal drive with a new 500GB WD drive. Now problems, until I accidently wiped the whole drive with BootCamp assistant.

At some point, I managed to boot from CD/DVD and (deep-)clean / format the whole internal disk, reinstalled 10.5.4, imported the settings and software from my old internal disk, and maybe f*ed everything up again by doing so. ONYX helped me to isolate a couple of preferences that went bad after that import, and after deleting them, everything seemed to be alright, especially after updating to 10.5.6. Until the system crashed next time, during a memtest. Memory seems to be ok though; as I already said, swapping it against the old RAM doesnt change anything, and TechTool didnt find anything. HD seems to be ok as well, neither Disk Utility nor ONYX nor TechTool did find any hardware fault.

After every crash so far, pcscd.pub was corrupted, with 17 instead of 16 blocks (Single User Mode fsck -fy fixed that), which is more than strange since I don't use any smart card stuff which that file is used for.

Now, even fixing that file doesnt help anymore.

Verbose mode shows that the boot process stops right after

Feb 15 18:00:43 localhost /System/Library/CoreServices/loginwindow.app/Contents/MacOs/loginwindow[57]: Login Window Application Started -- Threaded auth
Feb 15 18:0046 localhost mDNSResponder-176.3 (Sep 30 2008 16:59:38)[56]: starting
AirPort: Link Down on en1

It could be interesting to put back in the old internal drive, but I'd like to avoid that at almost any cost since putting back the cases lid was such a p. i. t. a. It doesnt seem to be necessary as the drive itself seems to be ok technically.

The thing that amazes me most is the fact that I can't boot neither from CD/DVD nor from external FW-drive(s) anymore.

Now I'm sitting here with a beautiful 2,5k$ brick and I'm wondering if anybody has a clue what I could do or who to ask (Apple Care won't be available before tomorrow). Thanks a lot in advance!

MacBook Pro Santa Rosa 2,4GHz 15", Mac OS X (10.5.6), 4GB RAM, 500GB HD
  • V.K. Level 9 Level 9 (56,130 points)
    since you can't boot from the DVD and zapping PRAM or changing RAM doesn't help I would suspect a hardware problem with the logic board. not something you can fix yourself. take it to a repair shop and have them test it.
  • nerowolfe Level 6 Level 6 (13,070 points)
    Welcome to Apple Discussions:
    I suspect that the logic board may be damaged if you can't boot from a DVD. It's possible that the new drive is not fully compatible with the rest of the hardware. Perhaps the new drive is overloading the powersupply or interfering with some bus signals??
    Also, be sure AppleCare knows you have installed a new drive. I am not sure how that affects the extended warranty.
  • V.K. Level 9 Level 9 (56,130 points)
    Also, be sure AppleCare knows you have installed a new drive. I am not sure how that affects the extended warranty.

    oh, come on! installing a new drive can't possibly affect the warranty.
  • Tonfelix Level 1 Level 1 (0 points)
    Thank you. But wouldn't a fried Logic Board prevent me from even getting so far in the booting process?!
  • V.K. Level 9 Level 9 (56,130 points)
    Tonfelix wrote:
    Thank you. But wouldn't a fried Logic Board prevent me from even getting so far in the booting process?!

    not necessarily. it depends how much of it has failed.
  • gumsie Level 4 Level 4 (2,150 points)
    V.K. wrote:
    oh, come on! installing a new drive can't possibly affect the warranty.

    It might if something about it didn't meet specs laid down by the computer manufacturer.
  • Tonfelix Level 1 Level 1 (0 points)
    Did a complete memtest under Single User Mode: everything seems to be alright in that part. After memtest, I did another fsck -fy. Result this time:

    "** The volume ... appears to be OK.

    *** FILE SYSTEM WAS MODIFIED ***"

    (nothing new until here, but then:)

    "*** REBOOT NOW ***
    /dev/rdisk0s2 (hfs) EXITED WITH SIGNAL 4"

    Hm, maybe it IS the drive? Gonna research that signal 4 thing. Anybody heard of it before?
  • Tonfelix Level 1 Level 1 (0 points)
    Alright, "Signal 4" means "illegal instruction", as "info signal" shows.

    Rebooting in Single User Mode and doing another fsck -fy shows that everything is as before: a damaged pcscd.pub (incorrect block count) and a "succesful repair" with "FILESYSTEM MODIFIED". Exiting Single User Mode and continuing boot up works this time . Very strange. Verifying the volume using Disk Utility: everything is ok; some of the rights were corrupted though (in detail:

    Die Zugriffsrechte unterscheiden sich für Library/Application Support/Apple/ParentalControls/ALRHelperJobs, Soll-Wert: drwxrwxr-x , Ist-Wert: drwxr-xr-x .
    Die Zugriffsrechte unterscheiden sich für System/Library/LaunchDaemons/com.apple.usbmuxd.plist, Soll-Wert: -rw-r--r-- , Ist-Wert: -rwxr-xr-x .
    Die Zugriffsrechte unterscheiden sich für Library/Application Support/Apple/ParentalControls/ContentFiltering, Soll-Wert: drwxrwxr-x , Ist-Wert: drwxr-xr-x .
    Die Zugriffsrechte unterscheiden sich für Library/Application Support/Apple/ParentalControls, Soll-Wert: drwxrwxr-x , Ist-Wert: drwxr-xr-x .),

    but repaired without problems. BTW, "Die Zugriffsrechte unterscheiden sich für..." means "Access rights differ...", "Soll-Wert" means "reference value", "Ist-Wert" means "actual value".

    Testing CPU, RAM, video RAM and USB using TechTool Deluxe: everything is ok.

    The crash log read as follows:

    System Configuration:

    Model: MacBookPro3,1, BootROM MBP31.0070.B07, 2 processors, Intel Core
    2 Duo, 2.4 GHz, 4 GB
    Graphics: GeForce 8600M GT, GeForce 8600M GT, spdisplayspciedevice,
    256 MB
    Memory Module: BANK 0/DIMM0, 2 GB, DDR2 SDRAM, 667 MHz
    Memory Module: BANK 1/DIMM1, 2 GB, DDR2 SDRAM, 667 MHz
    AirPort: spairportwireless_card_type_airportextreme (0x168C, 0x87),
    1.4.8.0
    Network Service: AirPort, AirPort, en1
    Network Service: Parallels Shared Networking Adapter, Ethernet, en2
    Network Service: Parallels Host-Only Networking Adapter, Ethernet, en3
    PCI Card: pci168c,24, sppci_othernetwork, PCI Slot 5
    Serial ATA Device: WDC WD5000BEVT-00ZAT0, 465,76 GB
    Parallel ATA Device: MATSHITADVD-R UJ-857E
    USB Device: Built-in iSight, (null) mA
    USB Device: Apple Internal Keyboard / Trackpad, (null) mA
    USB Device: IR Receiver, (null) mA
    USB Device: composite_device, (null) mA


    Problem Details

    Sun Feb 15 15:18:32 2009
    panic(cpu 0 caller 0x001A8CD4): Kernel trap at 0x640e50b7, type
    14=page fault, registers:
    CR0: 0x8001003b, CR2: 0x000000bc, CR3: 0x00e8f000, CR4: 0x00000660
    EAX: 0x54d91630, EBX: 0x06884c04, ECX: 0x06725800, EDX: 0x00000000
    CR2: 0x000000bc, EBP: 0x54d91668, ESI: 0x00000000, EDI: 0xffffffff
    EFL: 0x00010246, EIP: 0x640e50b7, CS: 0x00000008, DS: 0x06720010
    Error code: 0x00000000

    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x54d91408 : 0x12b0fa (0x4592a4 0x54d9143c 0x133243 0x0)
    0x54d91458 : 0x1a8cd4 (0x46280c 0x640e50b7 0xe 0x461fbc)
    0x54d91538 : 0x19ede5 (0x54d91550 0x9 0x54d91668 0x640e50b7)
    0x54d91548 : 0x640e50b7 (0xe 0x48 0x54d90010 0x64110010)
    0x54d91668 : 0x640ecea0 (0xc1d00001 0x1000000 0x1000003 0x40)
    0x54d916c8 : 0x640e1e2b (0x54d91858 0x6 0x0 0x0)
    0x54d91828 : 0x640d4f12 (0x0 0x600d600d 0x7027 0x54d91858)
    0x54d918e8 : 0x642a8942 (0xc1d00001 0x1000000 0x1000003 0x40)
    0x54d91918 : 0x642b1d86 (0x46536000 0x1000000 0x88100090 0x3e)
    0x54d938a8 : 0x64296056 (0x46536000 0x1000000 0x15 0x4653601c)
    0x54d939a8 : 0x640cf572 (0x46536000 0x0 0x54d93ab2 0x80)
    0x54d93a08 : 0x54f675a5 (0x6702800 0x0 0x54d93ab2 0x80)
    0x54d93b38 : 0x54f68d74 (0x6702800 0x54f6c358 0x54d93bec 0x4)
    0x54d93c08 : 0x54f54133 (0x6702800 0x1 0x0 0x13)
    0x54d93c68 : 0x54f4d93a (0x6702800 0x2507 0x54d93d2c 0x65dfbe4)
    0x54d93c98 : 0x40fc65 (0x6702800 0x65dfbe4 0x65dfbe4 0x0)
    Backtrace continues...
    Kernel loadable modules in backtrace (with dependencies):
    com.apple.NVDAResman(5.2.8)@0x640ce000->0x6430dfff
    dependency: com.apple.iokit.IONDRVSupport(1.5.2)@0x54f61000
    dependency: com.apple.iokit.IOPCIFamily(2.4.1)@0x54e54000
    dependency:
    com.apple.iokit.IOGraphicsFamily(1.5.2)@0x54f45000
    com.apple.iokit.IONDRVSupport(1.5.2)@0x54f61000->0x54f6efff
    dependency: com.apple.iokit.IOPCIFamily(2.4.1)@0x54e54000
    dependency:
    com.apple.iokit.IOGraphicsFamily(1.5.2)@0x54f45000
    com.apple.iokit.IOGraphicsFamily(1.5.2)@0x54f45000->0x54f60fff
    dependency: com.apple.iokit.IOPCIFamily(2.4.1)@0x54e54000

    BSD process name corresponding to current thread: WindowServer

    Mac OS version:
    9E25

    Kernel version:
    Darwin Kernel Version 9.4.0: Mon Jun 9 19:30:53 PDT 2008;
    root:xnu-1228.5.20~1/RELEASE_I386
    System model name: MacBookPro3,1 (Mac-F4238BC8)


    Interestingly the Kernel version mentioned in the crash log is 9.4.0, while ONYX states it is 9.6.0.

    Trying a reboot from CD and new clean install, then I'm planning to make extensive hardware tests.
  • R C-R Level 6 Level 6 (14,920 points)
    Tonfelix wrote:
    Trying a reboot from CD and new clean install, then I'm planning to make extensive hardware tests.


    Keep in mind that no software based test of hardware is 100% reliable. It can't be because software runs on hardware & the two might interact in undetectable ways to obscure certain problems. The only 100% definitive test is by substitution -- if a known good part works & another doesn't then the second is defective in some way.
  • Tonfelix Level 1 Level 1 (0 points)
    True, thanks for reminding me.

    Ok, booted from CD/DVD. Erased the complete internal drive (wrote zeros). Checked drive once more, everything is ok according to Disk Utility. Repaired access permissions on my former internal, now external drive.

    Tried to reboot from CD to run hardware tests (by pushing 'D'). Kernel Panic. Wow, this is really getting annoying. Must be hardware related; since the succesful attempts to boot either from CD or internal drive have been always in the morning, with the computer still cold, I think it might be connected to the temperature. Maybe it IS the logic board.

    If anybody has an idea what else I could try, please tell me. I have no other idea left than trying to find a good shop around here.
  • William Kucharski Level 6 Level 6 (14,890 points)
    The kernel panic you posted indicated it occurred in the NVidia graphics driver, which makes me think that perhaps your video hardware has gone bad.

    You might want to try contacting your local Apple Store or service agent, and you might want to reference Apple Tech Note 2377:

    In July 2008, NVIDIA publicly acknowledged a higher than normal failure rate for some of their graphics processors due to a packaging defect. At that same time, NVIDIA assured Apple that Mac computers with these graphics processors were not affected. However, after an Apple-led investigation, Apple has determined that some MacBook Pro computers with the NVIDIA GeForce 8600M GT graphics processor may be affected. If the NVIDIA graphics processor in your MacBook Pro has failed, or fails within two years of the original date of purchase, a repair will be done free of charge, even if your MacBook Pro is out of warranty.


    Normally, this only results in distorted or no video, but it's possible your problems could be related.

    It could also be a bad disk controller that is corrupting disk reads/writes, "causing" bad instructions.

    Regardless, it all sounds like hardware.
  • Tonfelix Level 1 Level 1 (0 points)
    After booting into Single User Mode (from CD!) and exiting it, the boot process continued just fine. Hm. Even restarting, zapping PRAM, then booting into Apple Hardware Test ('D') worked this time.

    The only thing that seems to be reproduceable about this whole problem seems to be the fact that is it not really reproduceable.

    Running hardware test right now.
  • Tonfelix Level 1 Level 1 (0 points)
    I already thought about that, too. It doesnt seem to be too likely though.

    I'll wait for the hardware test result, and in the meantime I'm checking for a good shop.

    Thank you.

    Any other suggestion, or similar experiences?
  • Tonfelix Level 1 Level 1 (0 points)
    Ok, first pass of Apple Hardware Test shows the following result:

    "Achtung! Apple Hardware Test hat einen Fehler gefunden.

    4VDC/1/40000003: VideoController

    Pass-Nummer:: 1,

    Testzeit insgesamt: 1 Stunde 31 Min. 9 Sek"

    ("Attention! Apple Hardware Test found an error.

    ... Pass number:: 1,

    Total testing time 1 hr 31 min 9 s").

    Hm, now it DOES look like it is a video hardware problem, like William Kucharski suggested. I started a looped hardware test; lets see whether the results change.
Previous 1 2 Next