Previous 1 2 3 4 Next 96 Replies Latest reply: Jul 8, 2015 2:33 PM by DrMaryCC Go to original post
  • Roger Paolo Level 1 Level 1 (0 points)
    I got it now. First I re-imported all my video into iMovie 09, optioned for 'move' files in the dialog. Then I went back to edit the project file and changed the path to the new location, that iMovie created itself. So now everything is linked again and working.

    Thanks for the support here.

    Apple: fix this, you don't want your iLife customers, who are generally a little less comfortable in changing system files than the pro app users to fiddle around with text editors and such.
  • mary_lou Level 1 Level 1 (0 points)
    well, i attempted this - but when i imported the clips from the video camera - the imovie gave them all random # on their names.. i have NO idea what clip belongs to what section of the project. i am furious with apple -- i should just be able to drag the proper clip over top of the one thats missing and have it re-link...
    i even deleted the two localized items (afte closing imovie) and reopened - nope no change.. its a blooming mess and a weeks worth of work lost.... and worse i attempted yesterday to move my project and events to an external nas (as they were getting to big for my local drive) - and i did it based on apples instructions (in the support forum) but it will NOT load the project or event from that nas (which is connected)... junk. should not be sold this way.
  • mary_lou Level 1 Level 1 (0 points)
    ok - i re-imported all the movie clips -- and while the ! are still there - the movie clips in my project play... so kudos for that idea

    thanks
  • Nitwacket Level 1 Level 1 (0 points)
    Fixed it for me.
    When I installed iMovie09 - I moved all my project files to an external drive - also copied events to an external storage drive. Got the missing events warning when I tried to export - because I didn't read the help file when I moved the clips.

    Yo have to hold down the Command key when you move an event or a project file. This MOVES the file - not copies it. Then Quit iMovie - relaunch - and iMovie reindexes where everything is.

    If you just click and move - it copies the files - but iMovie will search at the original location you stored your events and projects when you originally edited the movie.
  • mary_lou Level 1 Level 1 (0 points)
    being that i have a nas i am quite familiar with moving files. i moved both the event and project files together to their on subfolder... yet i movie would Not load them... (blank for both areas) - then i moved them back. yes i used the command key - as there is no other way to 'move' a file on mac os x as far as i know. (funny story when i first got my macbook i couldnt find cut and copy (old windows user) in the right click menu - so i called apple and was prompty told after they went to level 2 support that as a safety feature moving is disabled and not available in mac os x...)

    anyways after moving to my user folder - i got partial clips working... ! on others. then i went thru the project w/ bbedit... and fixed all the even links to my user folder (9 of em)... no change... so i reimported like the other person did - and the ! were still there but it played and exported and saved as normal - after exporting the ! finally disappeared. but it took me nearly a whole day to repair a weeks worth of work.

    in my opinion tracking source files is a very basic necessity -- i should have been able to right click on the ! and simple browse to the folder containing the clips.

    now i have a huge imovie folder that if i move kills the work i did - its a no win situation... and i need my hd space back.
  • Helen W. Lee Level 1 Level 1 (15 points)
    Jim2006 wrote:
    Now find one of the iMovie Projects that shows missing clips in the Finder. Right click on the project in the Finder and select Show Package Contents. Now open the Project file inside the project in bbedit or any editor like it. Search for iMovie Events and verify the your paths are correct. If not, fix them and save the Project file.


    Thanks for this info, Jim2006. I had no problem following your instructions and changing the name of the external drive my files are on (from 450 GIG to 450 GB - a change made after a hardware upgrade) in one (fortunately relatively expendable) project file.

    However, now the project has disappeared from the project list! I've tried double-clicking the project in the Finder - it acts as if it's opening in iMovie 09 (ie brings iMovie to the front) but the project is not in the list. I've tried dragging the file onto the app icon in the Dock - same thing: iMovie is active but the project isn't in the list. Oh - and I did quit iMovie and reboot it before trying to open the modified project file.

    At that point I thought, oh well - I'll just open a backup of the file in iMovie 08 and work with it there. However, there IS no iMovie 08 on my computer. In the "previous versions" folder there is only iMovie HD. Where on earth did 08 go?! Does 09 not keep 08 when it installs?!

    Any suggestions for getting this project to appear in the list will be appreciated. I'd like to follow Jim's instructions (ie change file name in BBEdit) on the rest of my projects but not if it means they will disappear on me. :>)
  • ette1 Level 1 Level 1 (0 points)
    I wish I could help but after rebuilding my project 4 times and 320 hours of
    classes, one on one and talking to numerous imovie specialists - I have found that "Apple" needs to do some MAJOR updates to imovie 09!! And no one has the answers! It would be nice if the software creators could actually let us know the limitations to imovie 09.

    I have tried everything! The last time I had to start from scratch the imovie specialist's comment was "I think WE inadvertently trashed your project" We tried everything - it was gone! Then while rebuilding and working on my fourth rebuild of the same project it magically appeared! Which tells me there is more than just bugs in imovie09. I found that every time I added clips to go with the 5th song in my project I would lose my source clips and the titles would all be scattered in my project. (total project time before I added the 5th song was approximately 20 mins) I also found that if I restarted or shut down my computer it would lose the source clips etc. I can surely understand the gentlemen who wanted to smash his computer and not ever buy a mac again! Or the one who ranted and raved - he had a right to. I am certainly tired of the imovie09 specialists comments - "that's why they call it software - it's soft" or "well its a double edge sword" or "we can't publish the limits of the product"

    Apple should be ashamed of themselves releasing imovie09 before assuring its users of such "MAJOR" bugs in their product!! And please don't say I shouldn't of upgraded to imovie09 - I didn't want to - another mistake by the apple genius
    when upgrading my operating system!

    Near as I can tell the people aren't trained as to what it does under the hood
    before the product is released. I sure would love to talk to the developers of imovie09!!

    ette1
  • uhyana Level 1 Level 1 (0 points)
    i love you!!!!!
  • chiphoto Level 1 Level 1 (0 points)
    Jim2006, thank you very, very much. I thought my projects were goners. But after editing the paths in the projects file, all is good now...
  • new2appletv Level 1 Level 1 (35 points)
    I was shocked to encounter this problem today. I wanted to add a new avi clip to one of existing projects. The existing project was already using many clips from my iPhoto library. When I opened it, I found that ALL the clips there have the "*triangle with exclamation*" with the error message saying that the associated media clips are no longer available at the path *+Datadisk/iPhoto Library/Originals/2006/...+*

    Datadisk is the volume name of the external drive I use to store my media on my Mac Mini.

    When I go look at the iMovie Events and Projects folders, they are pointing to *_Datadisk 1_* and iPhoto Library is also pointing to *_Datadisk 1_*.

    I opened two of the 30 projects that I have and both showed the same behavior. So, I created a new project and dragged and dropped two clips from iPhoto library and they are showing fine.

    +At one time a few months back, I did see an error once saying that it cannot find my iPhoto library. At that time, I shut down my Mac and rebooted. The problem disappeared at that time. I don't know if the photo library got renamed with Datadisk 1 during this process.+

    Either way, what is the solution? I suspect that if I point the iPhoto Library to Datadisk instead of Datadisk 1, it may correct the problem. Appreciate any help.
  • new2appletv Level 1 Level 1 (35 points)
    Bump!

    I am desperately looking for a solution as my old projects are unusable until then. Appreciate any help.
  • new2appletv Level 1 Level 1 (35 points)
    Bump!
  • new2appletv Level 1 Level 1 (35 points)
    Bump! Please help!
  • new2appletv Level 1 Level 1 (35 points)
    My problem was resolved by Niel when I submitted this question on the Leopard forum. The process seems to be very simple and for folks who are still facing this problem, here it is:

    1. Click on the eject icon next to the drive where your data is.
    2. In the Finder, go to menu GO--> Go to Folder
    3. Type /volumes/ there which will now show you items with some of them shown as "aliases" (little arrows at the bottom left of those).
    4. Ignore the aliases, and drag and drop the remaining items to the Desktop.
    5. Launch Disk Utilities, locate the drive/volume that you had disconnected earlier and click on Mount.

    Now when you go back to the movie where the clips were referencing a different volume, the exclamation marks should have disappeared.
  • rickyticky Level 1 Level 1 (0 points)
    Here's the quick fix that worked for me:

    If you are using videos in your Iphoto library, you need to make sure you have the right library open, on your computer, while editing content on it in IMovie09. I happened to have a different library open at the time and got the "source clip missing" icon. But as soon as I closed Iphoto and reopened it, using the right library, I was fine.
Previous 1 2 3 4 Next