Previous 1 2 3 4 5 Next 96 Replies Latest reply: Jul 8, 2015 2:33 PM by DrMaryCC Go to original post
  • originalKT Level 1 Level 1 (0 points)
    Excuse me, but the fact that "source clip is missing" is an item "not found" in the iMovie Help file means that there is a Tech Writer employed by Apple that needs to be fired immediately and replaced by one of the many competent and unemployed tech writers out there; one who will work with the developers on the product team and obtain a list of error messages and make absolutely sure that the product does not ship without a Help topic that corresponds to every possible error message. That is the job. Do it or get out of the way and let someone else do it.

    And by the way, Apple, this is ridiculously poor media management. Connecting to clips is the ABC's of non-linear editing - there is no excuse for a product in 9th rev to have this problem. And a solution for a fundamental aspect of your consumer video product that requires folks to download bbedit? Are you kidding me? Way too risky.
  • Jerry R. Level 1 Level 1 (0 points)
    Jim, I did exactly as you said, it makes perfect sense - unfortunately for me, Imovie in my case did not reconnect the media files, despite the fact that the path is now 100% sure all right.

    Let's hope Apple will give us the Reconnect Media button real soon - making things simple again. It's been the third time in the last two weeks that this happened, it's getting quite a nuisance, and it's not what you'd expect from an Apple
  • ProducerNYC Level 1 Level 1 (0 points)
    Jim 2006 , Thank you for saving my 8 hours of work. I just followed your advice and it all came back.
    I too had the mysterious missing links,yellow exclamation marks pop up on after the imovie 09 crashed. I did notice the crash happened after I had renamed my project and looks like this causes the links to the files to lose their place. I suggest to all do not change your project name after its been created. I will alert apple about this as well.

    For now everyone follow Jim 2006 advice and it should fix all. I used bbedit and did a find a replace on the correct folder name where the files are in the project. Jim 2006 take a bow!!! You are the man
  • lixi123 Level 1 Level 1 (0 points)
    Hey guys,

    better use this link, I think this sure certainly fix it...
  • luckyal Level 1 Level 1 (0 points)
    To avoid this problem do not rename events in the event library after you have used clips from that particular event. To restore links, rename the events back to the original name. To find out what the original name is hover over the caution sign and it should give you a path, match the event name to the folder name.
  • richard sullivan1 Level 1 Level 1 (15 points)
    This problem REALLY ticks me off. The clips are in the Event Library right there, but not available in the Project I've spent weeks on.

    I believe there's a new generation at Apple, and they all have their heads up their #$%&!!

    I had to finally go in and re-do all the clips, but how long will that last? This is the 3rd project that has made me crazy because of this latest of very quirky flaws in iMovie.

    The newest, today, is that all my playlist folders in iTunes from which I want to add music to iMovie, have transformed from folder icons to page icons, and the contents cannot be accessed.

    Add the idiotic structure of iWeb, and iLife is more like iHell.

    Apple sure ain't what it used to be.
  • AppleMan1958 Level 7 Level 7 (27,400 points)
    Just to add to this thread...I discovered a bug similar to one mentioned here where iMovie started appending 1, 2, etc. to volume names.

    I had external drives named Media Library Volume 1, Media Library Volume 2, etc.

    This worked fine in iMovie 08.

    In iMovie 09, the Event library had no problem with these volume names. However, the iMovie Project Library was not able to deal with these volume names. The ability to move projects to an external drive is a new feature in iMovie 09, and they appeared to screw it up. The Project Library is limited to volume names of about 8 to 10 characters, while the Event Library can handle much longer volume names. This is why it randomly appends a 1 to a volume name like Media Library Volume 1 1, because it only reads "Media Library" and reads that there are four other drives with the same name.

    I fixed this by a tedious process of moving all my events to a newly reformatted drive with a short volume name (Media 1, Media 2, etc.) I had to repeat this 4 times to get everything.

    If the fixes mentioned in this thread work, then do that rather than my tedious way.
  • Brightspark Level 1 Level 1 (20 points)

    To successfully use Jim's Solution you must first convert the file to text from its original binary format. To do this please use the following command in Terminal - Open terminal and then type cd followed by a space then drag the project file to the terminal this should add the full path of the project. Before you hit enter remove the word project as you want to navigate to the folder containing the project and not the project file itself.

    Then use "plutil -convert xml1 Project" and hit enter.
    Then use "open -a TextEdit Project" and make the changes that you want so as to point to the correct media files. Please use the complete path from the get info screen of your media file when making changes.
    After making all your changes then save the Project File.
    Now we need to convert the file back to binary so imovie can read it.
    Please use "plutil -convert binary1 Project" and hit enter.

    You Project is ready to use ans should point to the correct media files.
  • Level 1 Level 1 (0 points)
    Oh man... my problem is even worse....

    1. I moved my source files for a project off to a larger drive.
    2. Before I moved my project, I actaully reorganized my event clips into 6 different events separating them by shot type (outdoors/indoors/location A/location B/etc.)
    3. Moved my project back into iMovie.

    Now it can't find the source files because 1. they are on a new volume and 2. they are in new events.

    I'm going to have to traverse the Package Contents and MANUALLY change 100+ of these monster statements: "%2FVolumes%2FTera%20II%201%2FiMovie%20Events%2Elocalized%2F200%20Market%200908 16%2Fclip-2009-08-16%2018;57;57%2Emov"
    There should be a "Reconnect to Source" menu item to say the least.

    Ugh. CLUNKY at best. Apple?
  • groovearchitect Level 1 Level 1 (0 points)
    Thanks Jim!

    Worked for me. I had moved the iMovie events folder on the external drive this project was on. That's why iMovie couldn't find it. Placed it back and it worked again.

    However, it is TOTALLY inexcusable from Apple that iMovie'09 doesn't have a "reconnect" or "find missing source clips" option!!!??? I'm sure many people will experience this same problem and I'm equally sure that Apple doesn't expect (or want?) everyone to go mess with project files inside packages..

    So, expecting this will be added to the first following update!

  • john Nall Level 1 Level 1 (0 points)
    Add me to the list of people having this problem. I'm not a code person, but tried the various solutions outlined in this discussion, AND read through the instructions someone posted a link to. No luck. My project folder doesn't show anything missing--I get the "source clip" message for two movies I recently was working on, the third is fine, the 4th didn't even save in project status (where DID I read that saves were automatic?).

    Since my event folder is intact, I'll just have to re-edit the movies and pictures in Project, add music, etc.

    My vote is with people who say Apple needs to fix this.
  • RiverdaleMAC Level 1 Level 1 (0 points)
    I have spent WAY too much time editing my project to just redo it so I need a solution. The 13 page how to document looks a little intimidating so I'm going to hold off on that one for the moment.

    How about Time Machine? Would that be of any help here? I did all my editing on my MBP while I was away. I came home and everything would have then backed up to my TC. It was a few days later when I decided to move all the events etc. to an additional external HD. So, being new to TM/TC, is there a way this can be of help? Somehow restore everything back to the way it was before I moved things?
  • groovearchitect Level 1 Level 1 (0 points)
    It's a pain and a major design falw that there is no option to reconnect or relocate the "missing" files from within iMovie. However, the workaround is to indeed place files back to where they were. This worked for me. If not, in this thread is a pretty simple 3 step solution as well.
    Good luck
  • RiverdaleMAC Level 1 Level 1 (0 points)
    Well, I decided to give TM a whirl and it worked perfectly in my case. I just restored the 60GB of iMovie Events and iMovie Project folders from the day I finished all my editing (a couple of weeks ago). Next time I may not be so lucky so I'm leaving everything on my primary drive until we get a simple, working "relocate" button.

    Just an aside - I only got my TC a few weeks ago and already it has proved its worth to me. I still back stuff up to three other on-site/off-site drives but TC certainly performed beautifully in this scenario.
  • tanialepe Level 1 Level 1 (0 points)
    i've also encountered the same problem and after reading through many forums trying to find a solution (nothing was working), i finally figured out something that solve the problem for me.

    What I did:
    •In Imovie, File, make a New Event.
    •In Finder, find the folder that contains all your video clips. Copy it!
    •Then in your Finder window, there should now be a folder called Imovie Events. Paste the folder with your clips there.
    • Close Imovie.
    •Re-open Imovie.
    • There should now be an event folder containing all your clips... The links between your project and event should be fixed.
Previous 1 2 3 4 5 Next