Previous 1 2 3 4 5 6 7 Next 96 Replies Latest reply: Jul 8, 2015 2:33 PM by DrMaryCC Go to original post
  • tanialepe Level 1 (0 points)

    i've also encountered the same problem and after reading through many forums trying to find a solution (nothing was working), i finally figured out something that solve the problem for me.

    What I did:
    • In Imovie, under File, make a New Event. Now close Imovie.
    • In Finder, find the folder that contains all your video clips. Copy it!
    • Then in your Finder window, clip on "Macintosh HD", there should now be a folder called "Imovie Events". Paste the folder with your clips here.
    • Once all the clips are finished being copied, you can close your finder window.
    • Re-open Imovie.
    • There should now be an event folder containing all your clips... The links between your project and event should be fixed.

    This worked for me but I have to repeat this process every time I open Imovie... It's kind of a pain but my movies still work...

    Hope this helps someone...
  • David Bozek Level 1 (65 points)
    *That worked!*

    *Whoever wrote that is a genius. Apple should give out awards for people who take the time to do such things.*

    Message was edited by: David Bozek
  • DPaskin Level 1 (0 points)
    Sorry if this is a repeat from someone else's answer, but, after reading the first few pages here, doing some more research and some more tinkering, I managed to solve the "Source Clip is Missing" issue the following way:

    1. Make sure iMovie is NOT running.
    2. Click on the missing clip on your "Project" window.
    3. Then, move your mouse (don't click, just move) over the yellow triangle. It'll tell you where it expected to find the source movie, and its name.
    4. With that info, I simply copied my movie files into that folder where iMovie told me it was expecting to find the footage.
    5. Ran iMovie, and there you go, all the movie is playing fine.

    If this works for you, you don't need to edit any files, replace text strings, or use Terminal as one how-to told me to.

  • Mtwins Level 1 (0 points)
    THANK YOU Jim 2006!!!!!!!!!!

    it worked! You wrote:


    The iMovie Events Folder should have a .localized extension on it. Verify that it does by doing a Get Info on the iMovie Events Folder.

    Now find one of the iMovie Projects (in your iMovie Projects folder, also make i suggest making a duplicate just in case...) that shows missing clips in the Finder. Right click on the project in the Finder and select Show Package Contents. Now open the Project file inside the project in bbedit or any editor like it. Search for iMovie Events and verify the your paths are correct. If not, fix them and save the Project file.

    This is a pain, but I think you can get your project back working. Good luck.

    I downloaded bbedit demo at

    Thanks again!!! My wife prayed and she is grateful...Jim2006 was the answer to her prayer!
  • Sally Ennis Level 1 (0 points)
    An alternative to all these complicated fixes is to put all the files back to where iMovie expects to find them.

    I also had this problem after my external harddrive failed. After I had recopied all my files back on to it and tried reaccessing my iMovie projects, all the links had disappeared. After trying some of the fixes here and failing, I just recopied my projects into a my Movie folder in my home user folder, called iMovie Projects and copied all my clips into a folder called iMovie events. On reopening iMovie, it took a little time for it to rebuild thumbnails etc., but at least everything is now accessable.
  • lcrock05 Level 1 (0 points)
    Ive gotten myself in a pickle,

    I read through the first part of these posts and went into the project file, show package contents, project and opened it in textedit. I altered the script of the project to try to redirect it to finding the missing source clips. It didnt work. So I changed the script back, and now the project won't open in iMovie 09.
    Any ideas? I don't know how to revert to how the project was previously either....
  • UtahDave Level 1 (0 points)
    Jim, Thanks for this excellent post. I was worried this fix was above my head, but with 1 hour, and patience, I perservered. Many thanks.
  • ckibsen Level 1 (0 points)
    Another approach which works for me is, after having moved the events to an external harddrive and realized that they couldn't be found by the project, to simply right click the event folder within 'iMovie events' on my external harddrive, select 'Make alias', move this alias (illustrated by a small arrow on the folder) to the 'iMovie events' folder on my iMac, rename from eg. 'Legoland alias' to 'Legoland', restart iMovie, and everything works fine again!
  • Ben Feingold Level 1 (40 points)
    This solution worked for me in iMovie 8.0.5.

    I had moved an old project to a new drive. When I loaded iMovie, all the clips were missing. Quick search landed me on this article. I grabbbed BBEdit, which has a free 30-day trial (should be plenty of time), and did a Find/Replace for the directory. I was back up and running in 10 min.

    - Ben
  • redsward Level 1 (15 points)
    Dear Jim ,
    Just to let you know that your solution is still working for thise of us with the dreaded source missing icon!|

    Cheers you saved all my home movies !

  • CanadaHerb Level 1 (10 points)
    Thanks AppleMan Stupid me I renamed this Event Folder and forgot what was the original name your tip "clicking on the yellow triangle and see what it thinks it is looking for" helped I renamed the Folder opened iMovie and hurray all is well Cheers
  • conquestdm Level 1 (0 points)
    I tried the suggestion by ckibsen:

    After having moved the events to an external harddrive and realized that they couldn't be found by the project:
    1. Simply right click the event folder within 'iMovie events' on my external harddrive
    2. Select 'Make alias', move this alias (illustrated by a small arrow on the folder) to the 'iMovie events' folder on my iMac.
    3. Rename from e.g., 'Legoland alias' to 'Legoland', restart iMovie, and everything works fine again!

    Simple, easy, and quick!
  • PaulyBUK Level 1 (0 points)
    I have read all these posts with great interest and tried a few. Not (I admit)) the one that requires editing the project file. That makes me very nervous and I am not sure it will help me in my case.... Unless I am missing something my problem seems a little different.

    I consolidated my files (imovie09 - moving them from a couple of locations to one location, within imovie. Now it sees some of them and not the others.

    They are actually in the folder where it thinks they should be so 'creating a new path' isn't the problem though I sympathize with those who have had to deal with it

    Is there any solution you can think of? My folder has the .localized appendage by the way

    Thanks! Very very anxious!
  • PaulyBUK Level 1 (0 points)
    I actually have my own solution to this now and it has worked very elegantly. I no longer fear losing source clips! I haven't seen this idea anywhere else so I hope it helps...

    I realised that the thumbnail is still showing in the events folder and I knew I still had the source clip. imovie09 actually told me where it wanted the file to be in the little warning window at the start of the events file. So - I simply gave it what it wanted. I re-imported the file to exactly where it wanted it to be and voila! I could have moved or copied the file but I copied to be safe and then deleted it from my original location.

    Sadly it is also worth reporting that I had called Apple help as part of this resolution process and they were absolutely no help although, in fairness they tried.
  • Augsburg57 Level 1 (0 points)
    I encountered this problem when I moved files around on my external drive to "better" organize them.

    I've found that the easiest way to determine where iMovie thinks the source clip is, is to:

    - Select the project from the Project Library
    - Click on Edit Project
    - Control click the project clip
    - Select "Reveal in Finder"

    Finder then pops up with the location of the source clip highlighted.

    Hopefully Apple can find an easier way. I have experienced similar problems sometimes in Adobe Lightroom 3. However, Adobe anticipated the problem and lets you click on the folder in the library and easily re-establish the path to the source photos.