Skip navigation

Source clip missing

104079 Views 93 Replies Latest reply: Jun 23, 2013 7:00 AM by EOINMCL RSS
  • Espritvoyageur.net Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2010 2:50 AM (in response to Bob McAdams)
    Same here....
    Veeeery frustrating.
    I am ready to move to FC pro right now...I have lost lots of my professional small editing projects as I transfer them to an external HD. And now it would take me years to reedite everything.
    Avoid Imovie if you intend to ever back up your files....
    In other words...
    Avoid Imovie...
    Macbook pro 17', Mac OS X (10.6.4)
  • St.Marco Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2010 1:41 PM (in response to lcrock05)
    Hello,
    i made the same mistake altering the file with texteditor, anyone any suggestions on how to fix this?

    thanks a lot

    Marco
    MacBook Pro, Mac OS X (10.5.8)
  • conquestdm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2010 6:43 AM (in response to Jim2006)
    This worked for me (Jim2006 of Re: Source clip missing Posted: Mar 16, 2009 10:51 PM). Thanks!
    iMac24, Mac OS X (10.6.4), iMovie 09 (8.0.6)
  • Spam_uk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2010 11:31 AM (in response to Jim2006)
    Jim 2006 - thank you so much, thought I had destroyed hours of work and your solution worked perfectly.
    iMac, Mac OS X (10.6.4)
  • Dwyerfen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2010 3:10 AM (in response to tanialepe)
    I tried the above but didn't work for me
    But this did:

    Hover your cursor over yellow triangle (bottom left in clip) and take a careful note of the path it is searching for. Check in Finder that you haven't renamed/moved anything and change back name and/or bring back clips so they match exactly the path shown when you hover over triangle.

    In my case iMovie was looking for 'New Event' within the path but I'd changed this to the title of the movie. I changed this back to 'New Event' in Finder, quit iMovie, opened iMovie and all the clips were back
    iMac, Mac OS X (10.5.7)
  • Hedblom Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2010 5:31 PM (in response to Jim2006)
    Jim,

    I was able to follow your first couple steps, however I got confused when you said to "verify the paths are correct". How does one go about doing this? What do you need to do in BBedit to verify paths?
  • NEil Wade Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 11, 2010 3:50 AM (in response to Espritvoyageur.net)
    Agreed.

    GOODBYE iMOVIE!!! (and good riddens)

    Weeks of editing work GONE!

    Two years since this thread started and still no solution from Apple.

    Sorry Apple, I usually like your stuff but you should be ashamed of this.
    Macbook Pro
  • Logic Bored Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2011 7:37 AM (in response to ckibsen)
    ckibsen's suggestion (10/15/07) worked perfectly. For me the problem was that many of my clips are contained in my iPhoto library which I have moved to another partition. I simply made an alias of my iPhoto library and put it in my Pictures directory on my main partition and problem fixed. So easy!
    iMac, Mac OS X (10.6.6)
  • dixonge Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 26, 2011 9:47 AM (in response to ckibsen)
    ckibsen - great tip on the whole alias thing! I had never considered that for some reason, but it works like a charm. The bonus is that my projects are still there when my external drive is disconnected, even though they won't find the clips. When the drive is reconnected, everything works fine.

    This is important when your event library is over 400GB and your MacBook Air has a measly 120GB SSD drive!
    MacBook Air, Mac OS X (10.6.6)
  • Dwyerfen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 26, 2011 2:34 PM (in response to Bob McAdams)
    You may have sorted this by now but just to say that although iMovie 09 doesn't give you the option to reconnect there's a way to do it yourself.

    If you hover your cursor over the yellow triangle (don't click) a box will appear giving you the path containing the location and name of the file iMovie is looking for. Make a note of this and if necessary move back the file and/or change back the name.

    Had to use iMovie recently but very glad to get out of there and back to Final Cut!
    iMac, Mac OS X (10.5.7)
  • jlvmusic Level 1 Level 1 (0 points)
    I have a variation of ckibsen's "alias solution" in case you have a lot of clips in your iphoto library.

    These "iPhoto" videos seem to reside in the iPhoto library and NOT "iMovie events" folder. For me, all of the recommended "consolidation and moving" methods failed when it came to clips that resided in iPhoto. No matter what I did (even the alias method) ended with "missing clips" until I tried "symbolic link" see link below:

    http://www.apple.com/downloads/macosx/systemdiskutilities/symboliclinker.html

    I basically copied my iPhoto library to the new external drive. Made a symbolic link by control clicking the "newly copied" iPhoto library file. Then moved this link back to the "Pictures" folder on my internal drive. Like the "alias method you need to rename the symbolic link "iphoto library" in this case. It seems to replicate the same file tree and solve the "missing clips" issue I was having with videos that came from iPhoto. The files are on the external drive but iMovie is tricked into thinking they are on the internal drive.

    Problem solved-- as far as I can tell : ).
    Various, Mac OS X (10.6.7)
  • TC (Techno Cat) Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 23, 2011 10:19 PM (in response to Bob McAdams)

    There is actually a way to fix these problems without losing any editing.  It does involve some Terminal work, though, so if you get freaked out by anything command-line-y, just use the rename or symbolic link solutions.  Personally, I like everything clean (i.e., named the way I want it (i.e., not something like “Screen Recording.mov” ) and with no symbolic links or anything) , so this works perfectly for me:

     

     

    (Warning: I tried this with iMovie '09.  Using this with another version of iMovie may corrupt your project, so back it up or copy it and do this with the copy.)

    (Note: There are two project files.  One is the iMovie project file (with the .rcproject extension) that contains the other file (named “Project” with no extension) .  Throughout this walkthrough, the former file is referred to as the “project package” and the latter is referred to as the “Project file” .)

     

     

    0. Make sure that you have a working backup of everything related (not totally required, but I like to be on the safe side) .

    1. Hover over the warning sign (yellow triangle with a black exclamation point) in the lower left corner of the moved|renamed|whatever clip.  This will give you a path to where the clip file is expected.  Note this path.  Repeat this step for all missing clips in the same project.

    2. Locate the clip in the Finder and note its path.  Do this for all missing clips you did step 1 for.

    3. Quit iMovie.

    4. Locate the project with references to the missing clip in the Finder.  Right-click it and choose “Show Package Contents” .

    5. In the project package, there should be a binary file (Quick Look says it's a “Document” ) called “Project” .  Copy this file to a workspace (the Desktop is fine) .

    6. Launch Terminal, type ‘cd ’ (that trailing space is important!) and drag the folder you copied the file from step 4 to into the Terminal window.  It should automatically copy the working folder's path onto the line, so if you used the Desktop, you should have ‘cd /Users/username/Desktop’ .  Hit the return key.

    7. You should get another prompt, but this time instead of ‘computername:~ username$’ it should be ‘computername:workingfolder username$’ .

    8. Type ‘plutil -convert xml1 Project && open -a TextEdit Project’ and hit return.  This tells Terminal to use plutil to convert the Project file to the xml1 format (which is human-readable) and if that succeeds, open the file with TextEdit.

    9. The Project file should now be open in TextEdit.  Find the path where the clip is expected, and change it to the path where the clip is now.  If you have multiple missing clips, repeat this step for each expected path | actual path pair.

    10. Save and close the Project file.  If you have closed the Terminal window you worked in in steps 6-8, redo step 6, then continue with step 11.

    11. In Terminal, type ‘plutil -convert binary1 Project’ and hit return.  This tells Terminal to use plutil to convert the Project file to the binary1 format (which is what iMovie recognizes) .

    12. Move the Project file from your working folder back to the project package.  The Finder will ask you if you want to replace the file.  Choose “Replace” .

    13. Close the Terminal window, and any Finder windows opened.

    14. Launch iMovie and check the project.

  • TC (Techno Cat) Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 23, 2011 10:21 PM (in response to TC (Techno Cat))

    Ta-da!  Fixed.  Now please stop hating on Apple and iMovie.  I agree that they should automate this process, though.

  • rillsor Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2011 8:40 PM (in response to Bob McAdams)

    I just encountered this problem as well and after reading TC's comments I was able to reconnect all of my media. It turned out that I only needed to change the Volume name for the paths in the project files. And there was actually a simpler and faster way to do it rather than using Terminal. Here's what I did:

     

    1. Download TextWrangler from App Store (it's currently free).

    2. Find the complete path for where the original video file recides and make a note of it if needed.

    3. Right click on you iMovie Project file and "Show Package Contents".

    4. Open the file named "Project" with TextWrangler.

    5. Use the Find & Replace function to quickly fix your links. (i.e. I only needed to change /Volume/Storage/ to /Volume/Mac Storage/).

    6. Save and close.

    Repeat steps 3 to 6 for the rest of your files and you should back on track!

     

    Thanks goes to TC for getting me on the right track!

     

    I must say, it sure is strange that Apple didn't implement a "reconnect"-feature for videos since iMovie can do it with sound and music tracks from iTunes in the same project...

  • PlayGrim Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 9, 2011 7:43 AM (in response to Jim2006)

    Thank you Jim2006 for leading the way. Love the new iMovie but this particular problem and a lack of special effects have torqued me off. The problem here people--listen carefully--is that you changed the name or moved the source file. Just move the cursor to the yellow triangle and memorize the file path. Go back to your finder and simply change the file name back to the original (when you inserted your clip) and move it to the correct spot then quite iMovie. Boot it up and voila! You saved lots of time that you may now squander, like surfing for picures of wooden boats.

1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.