Previous 1 3 4 5 6 7 Next 96 Replies Latest reply: Jul 8, 2015 2:33 PM by DrMaryCC Go to original post
  • petesguitar1 Level 1 (0 points)

    Ok, so is there an easy way I can get my edited movies off my MBP with iMovie 11 onto my iMac with iMovie 11. I bought 2 machines worth almost $4000 because I was told they were far superior for media editing - it's now very late and I'm very angry!

  • BlacklightShining Level 1 (0 points)

    That works too.

  • BlacklightShining Level 1 (0 points)

    That works, provided you don't mind having the old filepath.  You could also create a bunch of symbolic links and then chflags hidden them.  I personally like everything clean (i.e., no extra symbolic links or files at old paths) so I'll stick with my way.

  • l0k1 Level 1 (25 points)

    The directions provided in the linked pdf solved the problem for me.  Simply editing the Project file in its default format, which I'd initially tried, was not the ticket.  The key was to convert the Project file to xml first, via terminal with the plutil -convert command (as specified in the above-linked pdf), edit the converted Project file to make the necessary path changes, then convert the Project file back to binary (once again utilizing the plutil -convert command).  Once I'd done that, I reopened the project in iMovie and everything was copasetic.  The directions are very clearly outlined in the pdf.  Thank you.


    (btw, I'm using iMovie 11 and though the instructions in the pdf are for iMovie 09, they still worked just fine)

  • DanielMLondon Level 1 (0 points)

    I have saved my (almost complete) imovie projects on my imac. The source clips were on an external hard drive.


    Two of my movies I had not yet saved to the media browser and then my external hard drive crashed and cannot be repaired by data recovery companies.


    So, I have two almost complete projects and plenty of exclamation marks with source clip missing messages. Luckily I have the original video on my camcorder.


    If I reimport the video to a new hard disc drive, please can you let me know the easiest way to reconnect the clips where the source is missing to the original movies as just creating the same event and naming my external hard disc the same as the one which has crashed may not work.


    Many thanks

  • DanielMLondon Level 1 (0 points)

    I am using imovie 11, by the way. Am not sure if the tips above would work or not in imovie 11 as you cannot hover over the source clip missing comment with the original file path displayed

  • funnymole Level 1 (0 points)

    Hello Everyone,

    not sure it can help, but i find this thread defintely useful also for iMovie11:

    I got the classical "source clip missing" due to a mix of issues: external HDD where project footage was located changed its name ("FreeAgent Drive" instead of "Free Agent 2") and the footage path linked in the Project index was different. So Jim 2006's suggestion was the right starting point.
    Unfortunately, after messing up with some other suggestions to rename external drive as before, and succeding, something was still not OK.


    In the project, if I scrobbled over edited clips I did't get any image (still the !)...but the path was definitely correct because if right-clicked (or ctrl - clicked) and selected "reveal in finder", the right folder and clip was shown.

    If I selected reveal in event finder, while thumbanils preview was there, also here if I scrobbled I got nothing.


    Then in the event library I tried to create another empty event (New Event) in the same external HDD and I merged this one with the event containing the footage (I also changed the name of the new merged event) et voilà. It worked. Now also scrobbling on edited clips or footage was showing video. The movie was back.

  • DanielMLondon Level 1 (0 points)

    I followed some of the more basic tips from other users after my external hard disc drive died (events / original footage on external HDD, project was on my mac).

    I formatted the external HDD and renamed it Mac (ie the same name as the previous HDD). I reimported the original clips into an event and named that event with the same name as the original event.

    I saved the project as a new project and (most of) the footage was restored with the original edits made (I have a hard disc camcorder so each file has a unique name and assume the name remains the same when you reimport the footage).

    Much easier than having to change the Terminal settings etc

  • JustThatGuy Level 1 (10 points)

    Check this one out:



    I found the same thing, a number appended to the volume name. Turns out, Parallels created a file on a FOLDER named like my external drive in the VOLUMES folder. I had to delete the folder and remount the volume and voilà. It's weird huh?

  • breathe1273 Level 1 (0 points)

    Jim, that was indeed a solution.


    Found that .localized was ok. Checked the name of one clip, and it was renamed from what it is looking for. I just renamed it back to what it's looking for (removed 1 at the end, to match the name it wants). It started playing.


    it still showed the source clip is missing icon, but played it completely.


    I then restarted the app and the yellow warning signs were gone.


    Originally had an issue on iMovie 09. I upgraded to iMovie 11 thinking it's a good idea to have the latest one anyhow, but that did not by itself resolve the problem. The steps above resolved it.


    What's odd about all this is that it actually showed the clip, just didn't play it, showing "source is missing". it actually shows the image moving in the project library, but I presume that's cause it's cached or mini version of it.


    So doing the steps above resolved it and it's playing all the clips. There was no need to redo anything else.

  • Kiwi 2012 Level 1 (0 points)

    Jim Thanks!!!


    One would think Apple could create a simple batch file to help find mis-pathed source files.

  • chloefromma Level 1 (0 points)

    I`m really confused I don`t understand how to do any of that. i`m not good at all this technical stuff. Is there any easier way you could explain it..? (Please reply soon!)

  • bshammer Level 1 (0 points)

    So - If I attempted to edit my project file directly as test prior to converting to text from binary, am I out of luck completely?  Project I worked on for days, but all I have now for the project file is a file that looks a bit corrupted from what I can tell, but would love to hear any input on how I might be able to get the current file into the correct format, if at all.

  • DDDy94 Level 1 (0 points)

    I had this problem too, and ive been doing some research, i i found that this was the easiest way,

  • Chubblesmh Level 1 (0 points)

    When i go to terminal and do that step and press return it tells me "not a directory"


    i did everything i was supppose to. opened up terminal. typed CD put a space in between and dragged the project file to terminal pressed return then it tells me "not a directory"


    Any thing else i can try?

Previous 1 3 4 5 6 7 Next