Previous 1 2 3 4 Next 51 Replies Latest reply: Jul 31, 2009 4:51 AM by MacMesch
John_MJ Level 1 Level 1
My G4 failed to reboot when restarted after latest security updtate.
The gray screen with apple logo and rotating gear stays on forever.
I tried booting in safe mode but same thing occurred.
I was able to boot in single user mode and run fsck -yf and it ran fine.
Then when I tried to boot again, same thing all over again.
I am guessing there must be some problems with new updates in the start-up folder or something. But I am not sure how to get rid of the files related to the new updates. Your help would be really appreciated. Oh, I was also able to run disk utilities application when I inserted Mac OS X installation dvd and booted from it. Then when I try to boot from HD, the same thing all over again...

Powerbook G4, Mac OS X (10.4.11)
  • David Rodriguez2 Level 1 Level 1
    Hey buddy,
    I totally understand. I'm in the same boat since that new update two days ago now. Can someone PLEASE help us????? I NEED my laptop up and running with all my info!!!

    Message was edited by: David Rodriguez2
  • TypeNut Level 1 Level 1
    I have the same situation, cannot reboot since last update. I tried running the Apple Hardware Test disk version 1.2.3 which came with the Mac and it says it does not support this hardware. I booted from the system disk and was unable to verify or repair the disk. I was unable to boot in single user mode. This is incredibly frustrating. Any other ideas out there?
  • John_MJ Level 1 Level 1
    Does anyone have any suggestions what other ways I should try to solve this problem? Like another forum or apple tech support or anything, really...
    My laptop has been sitting cold since Tuesday.
    Any help would be appreciated. Thanks.
  • Dr. Math Level 1 Level 1
    Me Too. Same Problem and I am a College Prof. with all my work on my mac. Need it back and running soon. Please help.
  • jimboj Level 1 Level 1
    I just spent a good 3 hrs or so trying to figure out why my imac running os x 10.4.11 wasn't rebooting after I downloaded the latest security update 2009-001. I finally got it running again after browsing the many helpful comments from past rebooting issues. Here are the steps:

    1. On another computer, you'll have to download the security update that you believe froze your mac. In my case it was the 2009-001 update.
    2. Save this file to a usb key, or in my case, to my LACIE backup drive.
    3. Once downloaded, connect the USB key or backup drive to your mac.
    4. Insert your install disc that came with your mac. (I installed disc 1)
    5. Power down your mac. ( I did so by pressing and holding the power button on the back)
    6. Press and hold the 'C' key on your keyboard as you restart your mac.
    7. Let go of 'C' as the apple logo and spinning wheel come on. The start-up disc should start to run.
    8. Choose your language.
    9. At the top of your desktop you'll see 'Terminal'. Start it.
    10. at the prompt, type "mount" to see a list of your volumes (in my case, the volume was LACIE).
    11. type "find /Volumes/nameofyourUSB/*.dmg" Ex. "find /Volumes/LACIE/*.dmg" (This step will give the path of your update).
    12. type "hdiutil attach /Volumes/nameofyourUSB/pathoftheupdate/SecUpd2009-001Intel.dmg" (Note the space after hdiutil AND attach)
    13. type "/Volumes/Macintosh\ HD/usr/sbin/installer -pkg /Volumes/Security\ Update\ 2009-001/SecUpd2009-001Intel.pkg -target /Volumes/Macintosh\ HD" (Note the spaces again. Took me a few tries before I finally got it. If you get it right, you'll notice your hard-drive start to be active. Let it do it's thing before you exit Terminal.
    14. Exit Terminal.
    15. Go to 'Utilities' at the top of the desktop, select 'Startup Disk', and choose your OS (in my case, OS X 10.4.11).

    Good luck!
  • John_MJ Level 1 Level 1
    WOW. It worked flawlessly.
    I cannot thank you enough jimboj.
    I am going to print out your instructions for future references!
    Thanks again.
  • Dr. Math Level 1 Level 1
    I can't seem to get step 13 to work...I keep getting a path error.

    "/Volumes/Macintosh HD/usr/sbin/installer: No such file or directory"

    I m trying to nail down where the pkg went but so far no such luck. Everything up to here worked though.

    Thanks for any additional help,
  • John_MJ Level 1 Level 1
    Did you put a backslash between Macintosh and HD?

    /Volumes/Macintosh\ HD/usr/sbin/installer
  • Dr. Math Level 1 Level 1
    Yes...I did but what I forgot is that when I first got the thing I changed the name of the HD from Macintosh HD to HD and now that I changed that it's doing the update...Will repost in a few min with an update to the status.


  • Dr. Math Level 1 Level 1
    Well with the change form Macintosh HD to HD it did it's thing and told me it was successful, however still not able to boot. Any other things to try? I do have an intel machine too that I can use to make my ibook a firewire HD if there's is something that route that might work.

  • jimboj Level 1 Level 1
    Glad to hear it worked!

  • jimboj Level 1 Level 1
    Dr.Math, try a "Repair Disk" in utilities. Using your startup disc, go to Utilities, select Disk Utility. When open, you should see your HD. Select it. Then to your right you'll see a 'First Aid' tab. Choose it and run the 'Repair Disk' at the bottom. After it's complete, select 'Repair Disk Permissions'. After complete, try a reboot. If nothing, try the Terminal path I mentioned above again. Hope it works.

  • Grant Bennet-Alder Level 9 Level 9

    As i understand it, the technique you recommend is to:

    1) boot from your system CD - (at which point it would probably be a good idea to run Disk Utility "Repair" against your Hard drive.)
    2) Start Terminal
    3) find the pathname of the update - ( can you use the copy in the "Packages" folder? is it essential to download a fresh copy? Is the downloaded update always a .dmg where the auto-update is a .pkg? )
    4) hdiutil attach the .dmg file to mount the disk image.
    5) Run the command-line version of Installer to Install the update onto your hard drive.
    6) wait for the Install to complete, exit terminal, then Use Startup Disk to re-specify your Startup Disk and Restart.
  • CE_ Level 1 Level 1
    Hi jimboj
    Thanks - it worked great! perfect description.

    Greatings Carl
Previous 1 2 3 4 Next