3 Replies Latest reply: Mar 1, 2009 6:41 AM by jlefevre1
jlefevre1 Level 1 Level 1 (5 points)
I have reached the point where Safari (current version for Tiger) on Mac's running 10.4.11 (with all current updates) is totally unusable. It simply quits responding to calls to load web sites. I cannot even quit Safari using the Safari Quit Safari menu item. I have to use force quit (it shows Safari as NON RESPONDING.. I do not get a application quit unexpectaly, report to Apple, etc. screen.

This happens on four totally different machines in totally different environments. They all work just fine with Firefox on the same web sites. It is not web site specitic, or # of sites visited, it is totally random and it will occur EVERY time I use Safari on all 4 machines. One is an eMac, another an original iMac, another is a Ti power book and the 4 th is a G4 cube.

I have trolled all the sites for safari problems on 10.4.11 and tried some of the things indicated. None work. Safari on my 5 Mac's with 10.5.6 all work fine. But that is a different version.

Right now I am an unhappy Safari user on Tiger and a very happy Firefox user on Tiger.

Any ideas.

Yes I have tried downloading and installing the latest version from the web site on all 4 machines. I was using the prior version until it would no longer allow checking e-mail with mobile me login. Upgrading to the new version fixed that. But you have to start Safari from scratch and go to me.com first thing because if you try and surf around for a while Safari dies and you have to force quit and restart.

15 Macs, 4 ipods, iphone, Mac OS X (10.5), Some 10.4.10 that are too old to upgrade