6 Replies Latest reply: Apr 16, 2009 3:10 PM by Stuart Craig
km32davis Level 1 Level 1 (0 points)
When I plug in my Sandisk USB portable driver it won't open. I know it's compatible but can't figure out what's going on.

MacBook, Mac OS X (10.5.6)
  • Limnos Level 8 Level 8 (42,925 points)
    I think you mean drive (hardware) vs. driver (software to run a device).

    Are you plugging this into the computer directly? Some USB devices draw more power than the computer can supply and require a separate powered hub.

    If it's brand new it may need partitioning and formatting. Most come ready for PCs and are not in 100% ready condition for Macs, though usually they do at least show up on the desktop.
  • km32davis Level 1 Level 1 (0 points)
    I'm not very computer savvy so here's the exact name (SanDisk® Cruzer® USB flash drive).

    Not sure how to get it to recognize that I plugged it in. It's an 8GB flash drive.
  • Limnos Level 8 Level 8 (42,925 points)
    When you plug it in does it appear on your desktop as a drive? How about in the sidepanel in Finder? What about if you open Disk Utility, does it show there?

    Where are you plugging this into your computer? Have you tried other USB ports?

    Do you have a powered USB hub into which you can plug it versus plugging it directly into your computer?

    Are you sure it even works? Have you tried it in another computer?
  • Stuart Craig Level 1 Level 1 (0 points)
    I'm experiencing the same thing. I have a (brand new) TASCAM DR-07 audio recorder (very nice device). I can connect it and use it w/o trouble under OS10.4.11 on a G4 iBook. When I attempt the same on our brand new mini (OSX 10.5.6), it won't show in the finder. It shows under the System Profiler as USB device. The DR-07 also indicated that it is "connected". Same thing with a friend's iMac w/ OSX 10.5.6.

    If I remove the SD chip from the DR-07 and use a "Core Micro" or Verbatim USB card reader (on the same USB port), the SD chip shows up fine in the finder.
  • BigNComputing Level 1 Level 1 (0 points)
    This problem has started appearing rather frequently in the forums.
    (Did something happen in the upgrade to 10.5.6?)

    Here's how I fixed it:

    Open Finder->Preferences
    Select the "Sidebar" panel configuration at the top of the Finder Preferences box.

    Under the list of "DEVICES" see that "External Drive" has a box next to
    it. Chances are, it is not "checked" on your machine, but instead has either
    a minus sign "-" or an empty box. Click on the little box next to
    "External Disk" until it shows a check mark. Now your USB drive should appear.
  • Stuart Craig Level 1 Level 1 (0 points)
    Re the suggestion from BigNComputing that "external drive" is not selected, I'm afraid that this isn't the problem in my case. "External drive" is, and always was selected (with a full check-mark).