Previous 1 2 Next 16 Replies Latest reply: Feb 22, 2009 10:36 AM by Jon Chappell
ozxx Level 1 (0 points)
Hi... new to Shake, but have been watching lots of tutorials.

I'm trying to key out a green screen, but when I remove the green, it takes the green out of the whole image, so the image becomes purple. To solve this (correct me if I'm wrong), I need to make a matte of the stuff that's not the green screen (the actors, etc).

The problem is, to do this, I think I need to adjust the alpha channel (I hope this is right), but when I click on the Alpha channel button in the viewer, my footage goes all white.

So... firstly, why is my alpha channel all white?

(I've searched Google and this forum, and can't find an answer -- or at least not one I understand.)

I've gone into FCP and looked at the clip's item properties, and under Alpha it says "None/Ignore". I've tried changing it to "Straight" and to "White" but neither has any effect.

What am I doing wrong? And why can't I find any tutorials that really go this basic question? Hmm.

And secondly, am I missing something in the green screen process? I thought it should be simple -- drop in the footage, add the keyer node, create a matte of what's left (from the alpha channel), and then smooth out the edges. No?

Any help is HUGELY appreciated!!

MacBook Pro 2.4Ghz Intel Core 2 Duo, Mac OS X (10.5.6), 4GB RAM
  • Jon Chappell Level 5 (4,005 points)
    Which node are you using for keying?
  • stuckfootage Level 4 (3,040 points)
    Both Primatte and Keylight not only pull a key but can also composite the background.
    If you have a background image connected to the second input of the keyer,
    and if you select comp, the the color image result will be the foreground
    over the background, which is what you want, but if you look at the alpha
    channel, it will be all white, because you've comped in the background.
    If you disconnect the background image and look at the alpha channel,
    you should see the foreground as white and the greenscreen area as black.

    Another approach would be to select "alpha only" (Primatte) or "un premult" (Keylight),
    which will cause the keyer to ignore the background image. This will also let you see
    the keyed matte when viewed alpha-only. Either way would work.
  • ozxx Level 1 (0 points)
    If I select only the clip of the woman in car, and send to Shake from FCP, I give it a sequence name "woman in car", then in Shake there are 4 nodes. They are in a straight line, top to bottom:

    1) clip'smedia_filename
    2) womanin_carV1
    3) womanincar
    4) womanin_carout

    If I view any of these in the viewer and select the Alpha channel, it's all white. If I detach all the nodes from each other, it's still all white.

    If I select both clips (woman in car + street BG), and send to Shake from FCP, I give it a sequence name "driving comp", then in Shake there are 6 nodes. They are in a Y shape, with two nodes on the left (1 and 2 below), and two on the right (3 and 4 below), and then two at the bottom (5 and 6) below. Nodes 2 and 4 attach to node 5:

    1) backgroundclip's_media_filename
    2) drivingcompV1
    3) womanin_car_clip's_media_filename
    4) drivingcompV2
    5) driving_comp
    6) drivingcompout

    (Note the V1 and V2s refer to the video tracks in FCP. Strangely, V2 is above V1, but when Shake sees it, it puts it underneath. Weird.)

    Anyway, every combination of looking a this file (leaving nodes attached or detached or whatever) always show a white Alpha channel for both clips.

    (Oh, and above the viewer is an info bar that looks like it's describing properties of the clip -- and it says "clip'smedia_filename@1 RGBA 16bit 1920x1080", in case that helps.)

    Any ideas? Thanks!
  • ozxx Level 1 (0 points)
    But I'm seeing the all white alpha channel no matter what I do. With or without the keyer applied. Even if I just send the clip from FCP to Shake, the alpha channel is all white even before I apply a key.... hmmm...
  • Jon Chappell Level 5 (4,005 points)
    Ok, to make sure you're doing it correctly, follow these steps:

    1. Send both the foreground and background footage to Shake (you don't necessarily have to do this in FCP).

    2. Delete all nodes except the FileOut (the last one) and the two FileIns for your footage (the ones that say the media filename).

    3. Select the FileIn node for the woman in car clip and click the Keylight button in the Key tab to insert a Keylight node underneath the FileIn.

    4. Click the blue color swatch marked screenColour in the parameters window for the Keylight node. Scrub the mouse across the green/blue screen area on your footage.

    5. Drag a noodle from the bottom of the background FileOut onto the second input of the Keylight node.

    6. In the Keylight parameters, make sure output is set to Comp.

    7. Click the left side of the Keylight node to view the results in the viewer.

    8. Customize to meet your needs.

    You can also do this with Primatte - it's a similar method.
  • ozxx Level 1 (0 points)
    Thanks Jon... but the problem is when I get to Step 8.

    At that point, the keyer took out all the green from the woman in the car footage. So I can see some of the background through the roof of the car. And the footage has a very purple hue (because there's no green anymore).

    It's my understanding that I need to create an alpha matte of the woman in the car, and then bring up the white areas so that that part of the image stays solid on the original footage (is this correct?).

    The problem is that when I click on the footage and view it's alpha channel, the whole thing's white. So I can't create the alpha matte to keep the part I want opaque.

    Am I doing this wrong? Is there an easier way to do this? And is it because there's something wrong with the alpha channel (is it possible there isn't one?), or is it because I've got the process confused?

    Thanks in advance for your help!
  • Jon Chappell Level 5 (4,005 points)
    Well, if your footage has a lot of reflected green light in it, that will make your job much harder. You can try the SpillSupress node or the Primatte keyer, which offers finer control.

    If that doesn't work, use an animated Rotoshape to surround the areas you would like kept and then plug it into the Holdout input of the Keylight (input number 3) or Primatte node (input number 4).

    Don't put the matte on the FileIn directly as that will take away information that might have been useful elsewhere.
  • ozxx Level 1 (0 points)
    No, it's a pretty solid shot, no reflected green light at all.

    I think the point that's being missed here is that +I can't create a matte+. I can't create one at all... because my alpha channel is all white.

    This isn't complex enough to need a rotoscope.

    Here's a screen grab of the source:

    And here's a screen grab of the comp:

    Notice the background going through the roof of the car. That's because I pulled the green, and that made the roof partially opaque.

    If I check the alpha channel of that image, it's all white, so I can't create an alpha matte (which I would then make more solid, to block out the background image).

    What am I doing wrong?
  • Jon Chappell Level 5 (4,005 points)
    That's because you're compositing in the keyer. If you want to tweak the matte generated by the keyer you'll need to composite separately. Choose Unpremult in Keylight or Alpha Only in Primatte.

    Do what you need to do to the matte, then put it into an MMult (or SwitchMatte if you chose the Alpha Only option with Primatte) and then use an Over to combine it with the background.
  • ozxx Level 1 (0 points)
    Hi Jon. I really appreciate your help, but I'm afraid I just don't understand the instructions you're giving me. I can't find Unpremult, and in the tutorial I'm watching on Creative Cow
    he seems to be seeing the alpha channel from the keyer. When he looks at the alpha channel (about a minute in), he sees black where he's keyed out, and white where the image is to be opaque. When I do that, I see only white.

    Anyway, if anyone knows what I'm talking about, let me know. Thanks.
  • ozxx Level 1 (0 points)
    Alright... figured out the solution myself.

    In case anyone stumbles across this thread looking to solve the same problem, it's that I needed to simply disconnect the noodle from the background to the keyer.

    Here's the screen grab:

    Compare to the earlier screen grabs and pay attention to the connections on the nodes.

    I'm finding Shake to have a steep learning curve (and extremely jargon-heavy), but once it's clear, it's an awesome program.
  • stuckfootage Level 4 (3,040 points)
    ozxx, you wrote:
    I needed to simply disconnect the noodle from the background to the keyer.

    Hmmm...wasn't that what I wrote in my reply?
    If you disconnect the background image and look at the alpha channel,
    you should see the foreground as white and the greenscreen area as black.
  • ozxx Level 1 (0 points)
    Now that I understand how to do it, yes, I can see that's what you meant. But the explanation didn't make sense to me, because I didn't know what you meant by "disconnect the background image".

    Thanks for your help... I'll mark yours as helpful.
  • Jon Chappell Level 5 (4,005 points)
    And I said that as well....

    If you want to learn the ins and outs of Shake, the tutorial book that ships inside the box is excellent. It helped me a lot when I was learning.

    I also recommend this:
Previous 1 2 Next