5 Replies Latest reply: Jun 1, 2009 3:42 PM by John Mills1
Ian MJ Level 1 (35 points)
Hi to all who can help:

Just bought Belkin network usb hub (http://www.belkin.com/networkusbhub/) to link some of my ext hard disks. Installed the belkin program and on restart, it prompted me that SXUPTP Driver is missing and asked me to re install. and all this while it sits in the system extension folder. How do i link this file ? I am currently on Tiger, osx 10.4.10.

I downloaded the latest driver for 10.4 from Belkin support website ( http://www.belkin.com/support/article/?lid=en&pid=F5L009&aid=8547&scid=220) but it prompts me the same missing driver file. Out of curiousity and desperation, i downloaded the driver for Leopard 10.5 as well ( even though i am on tiger, guess how desperate i was
)and installed it . It too prompted for the missing SXUPTP driver file? What is going on?

Right now, the hub just sits and looks pretty , doing nothing.

Can anyone shed some light and how do some of the mac users get this hub to work with their machines?

Thanks in adavnce!!!!


2.33 ghz intel core 2 duo, Mac OS X (10.4.10), mac book pro
  • Carolyn Samit Level 10 (102,820 points)

    Your best bet would be to contact Belkin since they write the drivers. You're probably already familiar with the Support area but here's the link just in case. http://www.belkin.com/support/?lid=en

    You can contact them via e-mail and phone both.

    Go to Google and copy/paste this into the Search field: customer reviews for belkin usb hub
    You're not alone in problems with this driver.

  • Ian MJ Level 1 (35 points)
    Thanks carolyn,

    most of the reviews i read from the internet belongs to Pcs and as for mac it always says wait for the driver to be ready by September 2008..so all are old posts as the drivers are already up by now, just that they dont seem to work.

    I found this here in the apple discussion but it has been archived and thus i cannot post under that heading anymore...

    Its by user supergerg:

    Posts: 1
    From: California, USA
    Registered: Jul 13, 2008
    Re: Belkin Network USB Hub F5L009 Stops Working
    Posted: Jul 13, 2008 1:55 PM in response to: mayjercook

    I had the same problem. What I did was reboot my mac into Safe mode and manually load the SXUPTP.kext. After manually loading the kext, the Belkin app worked.

    So I ran the kextstat command while in Safe mode and rebooted into normal mode and compared the kextstat output from safe mode to normal mode.

    Luckily after I uninstalled the first app I tried the problem was solved. Not sure if the app would be the same on your machine, but the conflict on mine was TeleStream DriveIn software. Once I removed DriveIn software as well as their kext and rebooted the problem was fixed with the Belkin software.


    MacBook Mac OS X (10.5.4)

    I am a newbie to the world of networking thus the following questions:

    I think my question will be how does he ( as in step by step) manually load the SXUPTP.kext? and he mentioned he ran the kextstat command while in Safe mode.

    Where can i find the kextstat command?

    I hope supergreg or anyone who understands this can shed some light.

    and thanks again carolyn for the information and help.


  • WhoWantsToKnow Level 1 (0 points)
    that's exactly what I did : running kextstat (Utilities/Terminal.app) and checked all non apple/mac apps. I found iAntiVirus as candidate and de-installed it (even I did not have this app actually active). All went fine after that, no SXUPTP driver problems with BELKIN USB hub anymore.
  • John Mills1 Level 1 (10 points)
    Hi Ian,
    Please see http://photosinferno.blogspot.com/
    I think this may answer you question, I did some digging and found out all is not equal between the Belkin US site and the Uk site.
    Download the Pre-release version for 10.5x from the UK site
    I was on the verge of taking mine back this morning , thought I'd give it one last shot, just installed as normal no safe boot no nothing in terminal, just install under normal user, and voila it works.
    However if your using a laptop don't shut the case while the drives are connected as this just crashes not only the belkin control centre software it crashes your whole system so big big no no!!

    Hope this helps...let me know if it resolves your problem

  • John Mills1 Level 1 (10 points)
    Just to update my previous post about the Belkin drivers, I used them once then they kept crashing out...unstable as **** ...deleted the app ...boxed it back up and took it back ...rubbish.

    So not impressed ...moved onto a Time Capsule .....