Previous 1 2 3 4 5 Next 1,133 Replies Latest reply: Mar 14, 2015 1:38 PM by InspireGratitude Go to original post Branched to a new discussion.
  • fontmoss Level 1 Level 1 (0 points)
    just thought id post and say im having same issue here, all since that wonderful update...
  • milo7380 Level 1 Level 1 (0 points)
    Same issue here, I have used the drive sparingly only to play dvd's really. I do not think I have ever burned a disk and the "genius" bar want me to fork out for a machine that is 3 months over its one year warranty. I really like my macbook but this is poor.
  • Cornelius Qualley Level 2 Level 2 (300 points)
    Yeah, I'm 6 months over my warranty but I'm not even sure when this actually occurred. Since I barely ever use this drive, it may have been bad months ago and I would have never noticed. I don't know, all I'm saying is whether the machine is 1 day or 6 months out of warranty, this type of problem still shouldn't occur. These are top-of-the-line machines and optical drives should last for years, not months.
  • jasonmbowen Level 1 Level 1 (0 points)
    The thing that is irking about this is that my drive has had issues since the day I bought it. For some inane reason I decided to put up with it instead of immediately exchanging it, I though I could work around it. I know this is a widespread issue, I've met others with the issue and it is not isolated. Basically sometimes I have to try several times to get the drive to acknowledge a disc. I can't move the machine while a disc is playing as it will come loose, in fact one time I though I had a disc fracture in the drive from the cacophony that came from the drive when I moved my MBP. I've found concentric circles on discs that have been inserted in the drive so there are multiple issues with the drive. I couldn't put up with downtime when I finally had enough though so I bought an external firewire drive. I paid far too much for such a shoddy drive, quality control should be better for the price and that is the real issue. You pay $2000 for a laptop, you expect that $2000 is giving you a top of the line computer that will last for years.

    Hardware Overview:

    Model Name: MacBook Pro
    Model Identifier: MacBookPro3,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.2 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 4 MB
    Memory: 4 GB
    Bus Speed: 800 MHz
    Boot ROM Version: MBP31.0070.B07
    SMC Version: 1.16f10
    Serial Number: W8743*X91
    Sudden Motion Sensor:
    State: Enabled

    HL-DT-ST DVDRW GSA-S10N:

    Firmware Revision: AP09
    Interconnect: ATAPI
    Burn Support: Yes (Apple Shipping Drive)
    Cache: 2048 KB
    Reads DVD: Yes
    CD-Write: -R, -RW
    DVD-Write: -R, -R DL, -RW, +R, +R DL, +RW
    Write Strategies: CD-TAO, CD-SAO, CD-Raw, DVD-DAO
    Media: Insert media and refresh to show available burn speeds
  • OneCatFamily Level 1 Level 1 (30 points)
    I totally agree, and I keep a copy of the letter I emailed Steve Jobs on the subject, just in case you guys would like to rejoin.
  • dontlookback82 Level 1 Level 1 (0 points)
    Same problem here folks, was working fine until the other month and since last week my MBP has not accepted one DVD! Like others I have had to return my laptop once before due to a failing Pro Logic Board and not taking out an Apple Care Plan at the time (being a poor student) this surely shouldn't happen to a machine less than 18 months old!

    I really don't know what to do after searching up and down the internet all evening finding out similar problems, seems like Apple are not holding any responsibility at present. This is my first Apple computer and while I love it, this is getting rather very annoying!
  • S. Swanson Level 1 Level 1 (10 points)
    I'm starting to have the same problem. Oddly though it's only with Memorex DVD-R discs. Sony ones seem to read fine and burn fine. Is this a problem with the drive itself or is it really that picky? They used to work I believe.
  • coyote moon Level 1 Level 1 (75 points)
    Add my name to the list. M MBP is 26 months old. The original Superdrive failed within a couple months of purchase and was replaced under warranty. Now the replacement has seemingly failed. It won't spin up and load anything. You can hear it trying to spin up, sometimes repeatedly and then the disks would get stuck. Found a post on Mac Fixit that suggested compressed air. Well that helped only to the point that at least now the disks don't get stuck. After a few attempts at loading it just ejects them.

    I have to agree with the majority of the others, seems clearly this is a hardware issue that Apple should address. I've been using nothing but Macs since the old 512K Fatmac. I've never had tech problems and so have never bought AppleCare - as i don't most extended warranty programs. However I'm wishing I had this time - hae had the super drive replaced, keyboard replaced (2x!) and my batter is defective. (To Apple's credit they are replacing it even though I'm out of warranty).

    I'm in desktop publishing and I burn CDs/DVDs every month. This clearly does not appear to be a random problem. We already pay a premium price for Macs vs Brads X,Y,Z so it wold be nice to see Apple do the right thing, step up and admit there's a problem and fix it!
  • coyote moon Level 1 Level 1 (75 points)
    http://discussions.apple.com/thread.jspa?threadID=1163304&tstart=0

    Look for the post by J.Noir. He posts a fix for Matsushita type drives.


    Found the above in an earlier post in this thread, went to the link and fund J. Noir's post. It's a fix that you have do using terminal. I downloaded the fix but can't figure out how to run it. If anyone else can, please advise.
  • Gryff Level 1 Level 1 (15 points)
    Thanks for posting, but unfortunately it isn't applicable to my drive (a GSA-S10N...I think it is a Hitachi or LG drive).
  • OneCatFamily Level 1 Level 1 (30 points)
    This is for flashing your SuperDrive firmware (Matshita only), and it didn't work on my unit at all. That kind of operation is not to be taken lightly, as it can "brick" you drive once and for all...

    You can try it as a desperate measure, but be aware that Apple could then renege on any extended warranty agreement they passed with you, since you're not supposed to mettle with these things on your own...

    Also, from reading numerous accounts of failing to solve SuperDrive issues with flashing firmware, I can almost predict no improvement in the long run...
  • AlienMust Level 1 Level 1 (0 points)
    To further add to this dilemma. I also have this problem. Blank DVD's sound like they are being read, then they just automatically eject. I have a MBP 2.4ghz from late 07'. And i have had this problem once in a while, but usually worked on 2nd try if it automatically ejected on 1st insertion.
    I just did a large update to *Microsoft Office 08'* the other day, and Now i have this problem. That is the only update i have done, and i have this problem now. It would seem to me that either it is just coincidence, or it has something to do with it. I am going to try to uninstall MS Office 08' all together and see what happens.
    I also tried the *Repair Permissions strategy*, and it did not work either.
  • coyote moon Level 1 Level 1 (75 points)
    Due respect to Didier, but my MBP IS out of warranty. the drive IS "Bricked" - as it will not read anything. I have no extended warranty, so what have I got to loose? If it doesn't work, then I'm back to replacing the drive which is where I'm at now. Problem is I don't know how to use 'Terminal' so I'm unable to use the flash method.

    I did find, on another forum, several people who have experienced this problem and corrected it by using a simple CD/DVD lense cleaner disc. While I'm doubtful, I'm going to give that a try. As noted I've burned 2-3 discs per month for the past 2 years, so I won't rule out the lense is filthy. I must note that a couple shots of compressed air and the drive is at least ejecting discs now where before they would get stuck and I had to use Disc Utility to eject them, so I suppose anything is possible.

    I bought a cleaning disc off Amazon and when it arrives in a few days I'll give it a try and report back. Meanwhile I'm still willing to try the flash if I can figure out how to do it.
  • OneCatFamily Level 1 Level 1 (30 points)
    If you're willing to take the risk, and if you're 100% SURE your optical drive is a Matshita UJ-857, here's what you've got to do:

    1) Download the .zip file mentioned in the post (for memory's sake: http://rapidshare.com/files/57312123/SimpleFlash.zip.html ) and save it, for example, on your Desktop

    2) Unzip it

    3) Open Terminal (in Applications/Utilities)

    4) In Terminal, type "cd Users/youruser's_name/Desktop/Name_of_the_unzippedfolder", without quotes

    5) Copy-and-paste the instruction line (singular!!!) corresponding to your optical drive AND region (mine would be HAEA since I'm in Western Europe), including the dot at the beginning of the line

    6) Press Enter

    7) Confirm your choice (type Y or Yes or yes, the press Enter)

    8) Wait a while, because the whole operation takes between thirty seconds and one full minute. You should see your Terminal going back to prompt at the end of the operation

    Your drive firmware has now been flashed. Reboot your machine and tell us if it worked for you.

    Message was edited by: Didier Caizergues
  • OneCatFamily Level 1 Level 1 (30 points)
    Some users mention that repairing permissions work better in safe mode. Maybe you should try it. I did and it didn't make my SuperDrive return from the dead, but it might work with yours.
Previous 1 2 3 4 5 Next