3 Replies Latest reply: Mar 10, 2009 4:38 PM by HMI5600
HMI5600 Level 1 Level 1 (0 points)
Hi,

I'm desperate for a solution! Would somebody please help me!
Here is my problem:

I have a 6th Generation 160GB iPod Classic that will no longer mount onto my PPC G4 10.4.11.
On this iPod I have a few thousand photos of a trip to Mexico that I kept on here until I returned home to sync them.

The other day, I started synching them into iPhoto 6.0.6, and it was working fine for the first half, but stalled around the middle. I could not find any way to get the synching process to continue or to quit / force quit the program successfully. Force quit did not actually terminate the process/program. I know at the time it was a mistake, but I unplugged the iPod cable from the iPod and held the computer's power button until it shut off.

Today, when plugging the iPod back into the computer:
1) it no longer mounts (though the iPod partition is viewable (grayed out) in Disk Utility.
2) because it does not mount in Disk Utility (I've tried many times including a separate iPod restart) it is also not viewable in Finder or in Terminal.
3) The iPod Settings Display that it is completely empty (though I know the files are still on there).
4) iPhoto recognized that there were more photos that still needed to be synched and asked if I wanted to continue, which I'm not able to do.
5) iTunes 8.0.2 tells me that I need to restore my iPod (which I can't do because I need these files, and can't erase them off of the iPod).

Does anybody know a workaround to save these files, which are extremely important to me, and cannot be erased under any circumstances? I would be extremely grateful for any help!

Please Help Me!

Thanks.

Dual 1.25 Ghz PPC Power Mac G4 (Mirror)/ 2GB RAM / iPhoto 6.0.6 / iTunes 8.0.2 / 160 GB iPod Classic, Mac OS X (10.4.11), Powermac G4 (Mirror) 2GB RAM
  • deggie Level 9 Level 9 (50,440 points)
    Try the ideas Jeff Bryan presents in this thread:
    http://discussions.apple.com/thread.jspa?threadID=1930891&tstart=0
  • HMI5600 Level 1 Level 1 (0 points)
    deggie,

    thanks for responding.

    just to let you know, I had the same problem before (when my iPod was brand new), but the problem was just with media already in my iTunes Library, so I tried to restore a bunch of times, and that didn't work. At the time, I had Apple Care, so I brought it to a Genius to restore. When I arrived home, it still wouldn't sync, but one last restore in my iTunes, and I got it working fine again. Ridiculous!


    This time, I have already tried the iPod disk mode / Diagnostic mode, as -well-as connecting on a new user computer account (same computer), and on a different computer using a different iPod cable. All of this yielded the exact same results. The USB drive is detected (such as dev/disk2), but the iPod partition (dev/disk2s2) is grayed out in Disk Utility and is not accessible.

    The closest luck I've had so far is downloading/installing the demo of Disk Rescue II, which produced a "thorough scan" of the entire drive (one block at a time). I was able to see somewhere between half to most of my files on there, and am not sure about the remaining undetected files. The demo only let me restore a single 5MB file, but am at least assured that most of it should be able to be recovered once I pay for the full version.

    I am, however, interested to understand why some of my files were not recognizable. For example, during a class, I had a bunch of 100MB-400MB .wav files recorded with a Belkin TuneTalk Stereo Microphone that connects via the iPod Dock connector. The majority of these files I moved into a separate folder I created on the iPod as a way to organize them. Those files were either not discovered, or somehow not viewable in the Data Rescue II scan results. The last couple of files I recorded with the mic (and did not move elsewhere on the iPod) interestingly were automatically synced and playlisted in my iTunes (I did not tell it to sync), and are still playable on my iPod. Also, I may be wrong, but I don't believe all of my photos were detected by Data Rescue II. It seems like many random photos from each photo folder I created on my iPod were missing/not detected/not viewable, so at first glance it might appear like they all show up, but the file count doesn't look correct. I was expecting more files to be detected than there were. To my knowledge the Scanning between Demo version/full version should be the same, so I can only speculate until I buy the full version/restore to see which files I'm dealing with.

    I would love to hear any other thoughts/ideas/solutions.

    No doubt this iPod is getting restored (possibly at an apple store) when this is all done. From now on, I'm doing everything possible to backup on DVD's while on trips. I can't trust my iPod alone to be a dependable backup. This is unnacceptable!
  • HMI5600 Level 1 Level 1 (0 points)
    just a note:

    I just brought my iPod to an apple store Genius for them to take a look at. They confirmed that this is indeed a hardware issue, and that I had tried all the same methods to fix this as they would have. Their recommendation is what I have already begun exploring - Third Party Data Recovery Applications/Utilities. I'll continue pursuing this and update my success.

    Just out of curiosity, does anyone suggest a particular data recovery application they feel is best? What experience did you have with it? what results did this application have for you? I'd love to know!

    Thanks!