Previous 1 2 Next 18 Replies Latest reply: May 17, 2009 6:38 PM by Rod@1
dyl123456789 Level 1 Level 1
I had backed up information on an external hard drive. I got an error message (can't remember what it was) so I went and reselected the drive as my backup. When I did that I got the error message: "You do not have appropriate access privileges to save file '.0016cb89df84' in folder 'Mac OS X external'."

I have read and write privileges, and I used disk utility to verify the disk, but I keep getting this error. I tried deleting all of my previous backup data, but that did not work. I don't know what the issue is.

Macbook Pro, Mac OS X (10.5)
Solved by Kappy on Mar 5, 2009 7:07 PM Solved
What to do if Time Machine reports you don't have permission

This was posted in the Apple Discussions by V.K. I have only modified it slightly to be more generic.

The problem seems to be that 10.5.6 changes permissions on a file so that even the root user doesn't have write peivileges. I have no idea why they did this. The workaround suggested in [an]other post will probably work, too, but i did something less drastic. Instead of deleting the file I changed permissions on it, and it worked just fine. An added benefit is that the permission change seems to stick, so you don't have to delete the file every time you change a drive.

[Open the Terminal application in your Utilities folder. At the prompt [enter] the following command:
sudo chmod 644 /volumes/"TM drive name"/.xxxxxxxxxxxx


The name of the file .xxxxxxxxxxxx is based on the MAC address of your computer and will be different for every computer. Put the name of the TM drive in the above and keep the quotes.

You'll have to enter your admin password (which you won't see) which is normal.

This was edited by Kappy just for cleanup.

Enable Finder to Show Invisible Files and Folders

Open the Terminal application in your Utilities folder. At the prompt enter or paste the following command line then press RETURN.
defaults write com.apple.finder AppleShowAllFiles TRUE

To turn off the display of invisible files and folders enter or paste the following command line and press RETURN.
defaults write com.apple.finder AppleShowAllFiles FALSE


Alternatively you can use one of the numerous third-party utilities such as TinkerTool or ShowHideInvisibleFiles - VersionTracker or MacUpdate.
  • Kappy Level 10 Level 10
    What to do if Time Machine reports you don't have permission

    This was posted in the Apple Discussions by V.K. I have only modified it slightly to be more generic.

    The problem seems to be that 10.5.6 changes permissions on a file so that even the root user doesn't have write peivileges. I have no idea why they did this. The workaround suggested in [an]other post will probably work, too, but i did something less drastic. Instead of deleting the file I changed permissions on it, and it worked just fine. An added benefit is that the permission change seems to stick, so you don't have to delete the file every time you change a drive.

    [Open the Terminal application in your Utilities folder. At the prompt [enter] the following command:
    sudo chmod 644 /volumes/"TM drive name"/.xxxxxxxxxxxx


    The name of the file .xxxxxxxxxxxx is based on the MAC address of your computer and will be different for every computer. Put the name of the TM drive in the above and keep the quotes.

    You'll have to enter your admin password (which you won't see) which is normal.

    This was edited by Kappy just for cleanup.

    Enable Finder to Show Invisible Files and Folders

    Open the Terminal application in your Utilities folder. At the prompt enter or paste the following command line then press RETURN.
    defaults write com.apple.finder AppleShowAllFiles TRUE

    To turn off the display of invisible files and folders enter or paste the following command line and press RETURN.
    defaults write com.apple.finder AppleShowAllFiles FALSE


    Alternatively you can use one of the numerous third-party utilities such as TinkerTool or ShowHideInvisibleFiles - VersionTracker or MacUpdate.
  • Rain_in_winter Level 1 Level 1
    I'm getting the same error message.

    I'd been having trouble with my Time Capsule so had been backing up to a USB drive attached to my mini. With the 7.4.1 update, I tried backing up to the TC; still no joy. So I went back to the USB drive I've been backing up to for the last six months and got the same error that dylx+ did.

    Unfortunately, the fix offered didn't work (it said the .xxxxxxxxxx (yes, I filled in the long name given in the error msg) did not exist).

    Any other solutions?
  • Kappy Level 10 Level 10
    Did you subsitute .0016cb89df84 for the .xxxxxxxxxxxx?
  • Rain_in_winter Level 1 Level 1
    I used the file name that was in the error message. It was similar to what you wrote (in format) but different letters and numbers.
  • Kappy Level 10 Level 10
    You used your TM volume name followed by the .xxxxxxxxxxxx MAC address? The latter being the same as you wrote in your original post?
  • Ravisj Level 1 Level 1
    This work perfectly for my yesterday, thank you very much for the advise.

    The first back up after you get it working again might take a while (preparing, backing up and finishing). It did for me anyway.

    Dave
  • Kappy Level 10 Level 10
    Sorry, I did not realize your were not the OP. You need to substitute the hex digits for the MAC address of your machine for the .xxxxxxxxxxxx. This address would have been given during the error message such as what the OP reported.
  • Drew Stadel Level 1 Level 1
    This was a big help.

    Thanks!
  • Rain_in_winter Level 1 Level 1
    Yes, that's what I did, but got the 'file not found' msg in terminal.

    I'll keep trying to get this to work.
  • Robert Robinson7 Level 1 Level 1
    Same problem exactly -- did you ever figure this out?
  • JohnCiprus Level 1 Level 1
    After switching to a new external drive, TM would not allow access to the original drive. Thanks for the solution. It works!
  • Topher Kessler Level 6 Level 6
    For this problem, try turning off Time Machine and then deselecting the drive in the Time Machine system preferences. Then turn TM back on and add the drive again.
  • Berndt Level 1 Level 1
    I had the same problem on my iMac G5 (messages in German) under 10.5.6 and your terminal procedure worked. Funny enough TM backups from my 10.5.6 G4 PowerBook via WLAN (sparsebundle) kept working all the time.

    Thanks!

    Berndt
  • scottrd Level 1 Level 1
    expertise.icloud
    iCloud
    I tried this but it isn't working. Here's the text from Terminal:

    Mac-SRD:~ SRD$ defaults write com.apple.finder AppleShowAllFiles TRUE
    Mac-SRD:~ SRD$ sudo chmod 644 /volumes/"TM drive name"/.001b63a5e390
    Password:
    chmod: /volumes/TM drive name/.001b63a5e390: No such file or directory

    I tried Time Machine again anyway but continue to get the same error message:

    You do not have appropriate access privileges to save file “.001b63a5e390” in folder “MacBackup”.
    To view or change access privileges, select the item in Finder and choose File > Get Info.

    Any suggestions?
Previous 1 2 Next