1 2 Previous Next 19 Replies Latest reply: Sep 15, 2009 8:44 AM by symonty Gresham
adrian musolino1 Level 1 Level 1 (95 points)
Hello,

I am running Safari Version 3.0.4 and I am having problems with Yahoo Mail.

I can login into Mail and check my mail but I can't do anything else - it won't allow me to compose etc, it's like it is partially frozen.

I have contacted Yahoo but their suggestions (allow Javascript etc) didn't do anything and I know Yahoo Mail has had issues working on Safari previously.

Can anyone recommend anything? I really need Yahoo Mail back!

Cheers.

iBook G4 14inch 1Ghz, Mac OS X (10.5)
  • 1. Re: Yahoo Mail not working with Safari
    Hawaiian_Starman Level 7 Level 7 (21,415 points)
    Hi Adrian

    Which version of OS X are you using?

    If you haven't done so, in Safari I suggest you "empty cache" via the Safari Menu, and in Safari Preferences>Security>Show Cookies, type Yahoo in the spotlight panel, then remove the cookies. Restart Safari and try Yahoo mail again.
  • 2. Re: Yahoo Mail not working with Safari
    yzgrrr77 Level 1 Level 1 (0 points)
    I am having the exact same problem with yahoo mail not letting me compose or reply in safari. it's been giving me problems for the last five days, but was never a problem previously.

    I'm also running safari 3.0.4. I've tried reseting safari, emptying cache, deleting yahoo cookies and restarting. Nothing works and it's just saying "Loading" up at the top right of my yahoo screen. I've read switching to classic mail will do the trick, but when i try to switch to classic mail it will not, it keeps saying "Loading".

    Somebody help! What a pain!
  • 3. Re: Yahoo Mail not working with Safari
    adrian musolino1 Level 1 Level 1 (95 points)
    I am running 10.5.

    I have tried resetting Safari, disabling firewall, disabling plug ins and nothing has worked.

    It's the exact same problem as yzgrrr77

    Anyone know what to do?
  • 4. Re: Yahoo Mail not working with Safari
    yzgrrr77 Level 1 Level 1 (0 points)
    I found a way around the problem, but you have to switch to yahoo classic mail...so you loose some of the cool functionality like dragging messages to folders... But here's how i did it. i logged into yahoo mail on firefox (other browsers would probably work too), changed my yahoo mail to "mail classic" there's a link at the top left. then i went back to safari and logged on. now that the mail is in classic mode it's working fine through safari to compose and reply.

    Hope this helps!
  • 5. Re: Yahoo Mail not working with Safari
    yzgrrr77 Level 1 Level 1 (0 points)
    Also, when you switch to classic mail, yahoo gives you the opportunity to provide feedback. I told them about the problem. maybe if enough of us report, they will fix the bug!
  • 6. Re: Yahoo Mail not working with Safari
    adrian musolino1 Level 1 Level 1 (95 points)
    I have tried that but every time I sign in with Safari it reverts back to the the non classic Yahoo Mail and the same old problems.

    Is this a Java issue?

    I cannot believe such a popular email system doesn't work on Safari!
  • 7. Re: Yahoo Mail not working with Safari
    adrian musolino1 Level 1 Level 1 (95 points)
    Okay I have done a software update on my Mac and Yahoo Mail is now working with Safari.

    Cheers.
  • 8. Re: Yahoo Mail not working with Safari
    catg Level 1 Level 1 (0 points)
    Hi,

    I just wanted to say thanks for the info on this thread. I was having the same problem and it was driving me nuts. I did the software update and it worked like a charm. Thanks!
  • 9. Re: Yahoo Mail not working with Safari
    deetrakt Level 1 Level 1 (0 points)
    I too have been using Safari 3.0.4, as recommended, on my MacBook Pro. Last week, Yahoo sent out an e-mail to the effect that they would be upgrading Yahoo Mail. Since Saturday, like adrian musalino 1, I have been unable to send or reply to e-mails.

    After several online sessions with "Yahoo Mail Help", we were unable to fix the problem (after the usual cookies, cache and relaunch instructions) and *I then installed the newest version of Firefox, on which everything works fine.*

    Anyone else having problems with Safari + Yahoo Mail? Anyone know if the problem is a temporary glitch or something permanent?
  • 10. Re: Yahoo Mail not working with Safari
    barbsgram Level 1 Level 1 (0 points)
    I downloaded Mac OS 10.4.11 (Am waiting for the next update to buy a new OS.) on my husband's Power PC G4 so that we could get an newer version of Safari that would accept new Yahoo Mail. His For the past week or so since, we have been able to receive mail but not reply nor send new mail. At the right side of the screen are spinning arrows and says it is downloading but no matter how long you wait, it never finishes nor allows you to send. Surely Apple has knowledge of this by now and has some suggestion. It is very frustrating.
  • 11. Re: Yahoo Mail not working with Safari
    cbr79 Level 1 Level 1 (0 points)
    I am new to Apple and just bought an iMac.

    The problem I'm having is that I can get to yahoo.com, open Mail, but only one of my four Yahoo email accounts (I have domains for my business) opens when you click on it.

    The original Yahoo email account does work.

    Any suggestions?
  • 12. Re: Yahoo Mail not working with Safari
    editgrrl Level 3 Level 3 (855 points)
    The only thing that has worked for me is to go into mail via Firefox and switch back to Yahoo classic. I don't care for Firefox and so this whole thing has been really maddening. Certainly they know about the issues by now. Hopefully they will fix it at some point.

    Message was edited by: editgrrl
  • 13. Re: Yahoo Mail not working with Safari
    karanpatel77 Level 1 Level 1 (0 points)
    hi,
    i m working for apple in india
    n i found out the solution for this problem
    its nothing to do with mac or os
    i went to one customer's who bought a new imac , his internet was working fine but the only problem he was facing was tht yahoo mail was not opening he could not open his mail n it just used to show loading ,i installed windows on this system n i was facing the same problem.
    his other computer which was a pc (vista) was working fine.
    so i checked out using a lan cable n with tht it was working perfectly fine.
    so connected the imac with other wifi connection n with tht too it was working fine.
    so i asked him to change the wifi modem. once he changed the modem with was working fine
    so i think there is some firmware issue with the modem.
    it was a d-link modem

    so plz try doing this as it worked out for me
    there is no issue with safari or mac
  • 14. Re: Yahoo Mail not working with Safari
    stevenwalton Level 1 Level 1 (10 points)
    I have no wifi, and the problem only happens on a Mac with Safari. Not with Camino, not with firefox.
    It must be a Safari problem. There is no way something works with all other browsers on a Mac, but does not work with the newest Safari on a Mac.

    I have the latest software from Mac. I have cleared cache and all the other baloney.

    This happened with Safari 3x, so I stopped using it. Then Safari 4 came out and I thought I'd give it a try. It's still broken.
1 2 Previous Next