Previous 1 2 Next 26 Replies Latest reply: Apr 27, 2009 1:09 PM by dougX
Joel_H Level 1 Level 1 (0 points)
I hope someone can help me. Until recently I have used a wired time capsule to back my iMac up to. I switched to a G-Raid2 wired back up disk and now connect to my time capsule wirelessly, but didn't delete my backup from the time capsule. I realised there were still things on my time capsule backup that were no longer on my G-Raid2, so I switched drives in Time Machine and restored what I needed.

I then tried to switch back, and the "Change Disk..." button is depressing but not responding. A quick look in the console and I got the following dialogue:

06/03/2009 20:46:16 System Preferences[474] * -[NSCFDictionary setObject:forKey:]: attempt to insert nil value (key: BonjourServerURL)

Does anyone have any idea what is going on? I downloaded the buggy airport utility update 5.4.1, then reverted back to 5.3.2. Installed the time capsule firmware update, then reinstalled 5.4.1 (was the only way I could do it). I've restarted and still no luck.

I've tried to reinstall time machine from my OSX disks, but it doesn't seem to be included in the installation package with the time machine icon on.

Please help!


iMac, Mac OS X (10.5.6)
  • Pondini Level 8 Level 8 (38,720 points)
    Hi, and welcome to the forums.

    I haven't seen this before, but perhaps your TM preference file has been corrupted.

    Try this: Stop TM via TM Preferences. If you can get to Options note any exclusions, then quit System Preferences.

    Then delete the file (root level, not in your home folder) /Library/Preferences/com.apple.TimeMachine.plist

    Go into System Preferences > Sharing and make sure your computer name is exactly what it should be.

    Then to TM's preferences, see if you can re-select your TM drive, and re-enter any exclusions.
  • Joel_H Level 1 Level 1 (0 points)
    Thank you.

    I tried this, but when I go into the pref pane the 'choose backup disk..' button is still inactive. I get the same message in the console.

    Any further thoughts? Or had I better just reformat?
  • Pondini Level 8 Level 8 (38,720 points)
    Joel_H wrote:
    I tried this, but when I go into the pref pane the 'choose backup disk..' button is still inactive. I get the same message in the console.

    Any further thoughts? Or had I better just reformat?


    I don't think that will help, as it doesn't appear the drive is the problem -- you don't get far enough to tell. I assume you can see the TM disk, and +Enter Time Machine+ successfully?

    Do you by chance have the Pacifist app from http://www.charlessoft.com ? It's $20, and I've not used it, but have seen it recommended here. It might be able to load only the TM app from your Leopard disc.

    But that may give you another problem, if it's been changed since your disc's version of Leopard.

    Downloading and installing the 10.5.6 "combo" update might work: http://support.apple.com/downloads/MacOS_X_10-5-6_ComboUpdate
  • bambule Level 2 Level 2 (195 points)
    I would try something different first (cause I have the same exact problem and no real solution yet):

    Create a new user and try to invoke Time Machine from there.
    When I do that, it works flawlessly. I can press the button and change the disk and I can even start a Time Machine backup.

    Alas, when I’m back in my regular user account Time Machine is switched to off there and I still can’t get the "Change disk"-button to work.

    Asssuming it must be a user prefs problem I tried to delete (or move) certain plist-files from my home folder (for example com.apple.systempreferences.plist), but that didn’t work.

    But here comes the crazy part: I then moved the complete Preferences folder from my home Library to the desktop and it still didn’t work. Huh?

    Anyone any idea what the real problem might be?
  • Joel_H Level 1 Level 1 (0 points)
    Unfortunately, the 10.5.6 combo update did not render anything new, but I have created a second user that can access the time machine. This seems incredibly silly, but nevertheless - it works, and I'm currently able to back up using time machine.

    Bambule - how did this error start for you? Was it along the lines of my time machine firmware/airport utility bugs or something else?

    The error message specifically says it's a Bonjour problem. Is there any way I can tinker with my bonjour files? Were this a windows computer (not that I own one), I would just do a fresh installation of bonjour. Is there any way of doing this, or is it too integrated into the OS?
  • bambule Level 2 Level 2 (195 points)
    For me it happened when I wanted to start over with my Time Capsule. I deleted the drive and renamed it (in Airport Utility). When I then wanted to start Time Machine, I could press the button to "Change disk", but nothing ever happened.

    Unfortunately this was on he same day, I also upgraded Time Capsule’s firmware (and I think there was a new version of Airport Utility too). So I have no real clue what caused the problem in the first place.

    But as you too can make it work from a new user account, I don’t think tinkering with system wide services like Bonjour will help. It likely is a problem in our main user account.

    Interesting sidenote: a Googlesearch for BonjourServerURL will exactly produce on hit. This very thread. So it is a rare problem. But maybe it’s a new problem too? Introduced by either the new TC Firmware or the new Airport Utility?
  • Pondini Level 8 Level 8 (38,720 points)
    See if you have a file like the following:

    <your home folder>/Preferences/ByHost/com.apple.TimeMachine.<list of numbers>.plist

    If you do, stop TM, quit System Preferences, delete that file, then try again.

    Worth a shot!
  • bambule Level 2 Level 2 (195 points)
    It might work. And I hope it does for Joel.

    Alas, it didn’t help me. As I’ve written above even deleting (i.e. moving to the Desktop) my complete Preferences folder, then even restarting the Mac and then trying to invoke Time Machine didn’t work for me.

    Which is extremely crazy, because here is my solution:
    I made a backup of my complete home folder to an external drive. Then I created a new admin user, logged out of the current user and logged in as the new one.
    I deleted my old main user. Then, still logged in as the new admin, I created another new admin user. I gave this one the exact same details as my previous main user.

    And then the whole way back: logged out from first new admin, logged in as new/old main user, deleted first new admin user.

    Checked if Time Machine was working. It did.

    From what I know and understand, this should have the same result as creating a blank Preferences folder in my home directory (by moving the existing one to the desktop and rebooting). But it didn’t. Fortunately creating a complete new user worked.

    Then I copied all my documents and other files from the external drive into my new user’s home folder. I also brought back some stuff from the backup-Library (like Mail, Calendars, a few prefs files, etc), but left most of the prefs alone.

    In between moving stuff I often logged out and back in, just to check if Time Machine is still working. The whole procedure did cost a few hours, but now I have a working Time Machine and also a fairly fresh user Library. =]

    Would still like to know the reason for all this hassle though.
  • Joel_H Level 1 Level 1 (0 points)
    Thanks for your suggestions and for letting me know all your failed attempts - saves me a lot of time. Unfortunately, nothing suggested has worked other than creating a new admin account to do it. Instead of migrating to a new account on the same system, I think I'll wait until Snow Leopard comes out and do a clean installation. I can still use time machine for the time being,

    Joel.
  • Joel_H Level 1 Level 1 (0 points)
    Update: This is now affecting my macbook! I tried to bypass making a new account by instead logging into the guest account and using my admin username to unlock the pref pane. Same problem. Time machine complained that it couldn't mount time capsule, even though finder had no problem doing so (even over the internet with the new mobileme feature). So it's looking like it's a problem with my login, and I should either do as you say and create a fresh admin login, or just reformat when snow leopard comes. Annoying either way!
  • [ian] Level 1 Level 1 (15 points)
    Just adding a "me too" for this one.
    Clicking the Change Disk button doesn't do anything - the button isn't greyed out or anything but when I click it nothing happens and I get the same message in Console.
    What a PITA!
  • [ian] Level 1 Level 1 (15 points)
    OK - been playing with this all day and here are my findings:

    IMHO this definitely arrises from changing the name of the backup volume.
    On a whim I plugged in my old backup disk and although the Change Disk button still didn't work, the settings were now filled out in TM pref pane, along with free space etc.

    I fixed it as follows - WARNING - this is probably overly heavy handed as doing this will wipe your machine name (which could potentially cause all sorts of trouble?) and AirPort settings but it worked for me so if you're feeling brave go ahead, just so long as you heed this warning first in case it breaks something.

    Read through to the end of this post before following instructions because there's something else I noted...

    Anyway...

    Make a note of you machine name before starting (in Sharing preferences).
    Delete /Library/Preferences/com.apple.TimeMachine.plist
    Delete /Library/Preferences/SystemConfiguration/
    Restart machine.
    Open System Preferences and select Sharing.
    The machine name will be blank so set it back to what it used to be.
    Reselect AirPort network from the status bar if you need to - I use a closed network so had to find it again... you might not have to if yours is open.
    Open Time Machine preferences and it will look as though TM has never been set up - you can set it up from here.

    This worked great for me and I was backing up.

    This is the extra bit I noted that I mentioned above...

    I set up TM backups on all the machines in the house and all was well.
    Then, for reason known only to myself I decided to change the Time Capsule's name (actually I did it because it's name was taking up too much space in Finder side bars!)
    Hey presto TM backups were now broken because the machine name of the Time Capsule had changed so Time Machine could no longer find the volume.

    So... I did the workaround above AGAIN because the Choose Disk button was broken again.
    After doing all of that I set about doing it on all the other machines too... BUT... in the time it had taken me to do the workaround on one machine, all the others had automagically picked up the new Time Capsule name via Bonjour so the Change Disk button on each machine did in fact work.
    this meant I could simply re-point Time Machine to my re-named Time Capsule.

    Incidently, each machine found it's previous backup on there so didn't have to start from scratch backing up.

    Hope that lot makes sense and is of some use to someone!
  • Joel_H Level 1 Level 1 (0 points)
    Hmm, food for thought. So it could have spread around my system as follows:

    I had a problem deleting a backup from an external drive so i erased the drive. It still had the same name when it came back and I backed up to it without changing the drive name.

    But here's the thing. I have never backed up to this external HDD with my macbook. That has always been through the time capsule (it's not backing up at all now). There does seem to be a bonjour aspect to all of this - maybe when it buggered up my iMac, mobileme helpfully sync'ed the bug with my macbook.
  • CeeB Level 1 Level 1 (0 points)
    I had/have the same issue. Checking around I noticed that a recent update changed my MobileMe Preferences and Started Back to My Mac. Turning that service Off instantly allowed me to use the Change Disk option so I could enable backup to my new Time Capsule.
Previous 1 2 Next