6 Replies Latest reply: Mar 6, 2009 9:43 PM by DAOF
DAOF Level 1 Level 1 (0 points)
My iBook G4, running on OSX would not accept my user- and/or administrator-passwords and I could no longer install programs. Therefore I started it up on m Mac OSX Leopard v.10.5 dvd (holding down c) and used it resetting the passwords, then updated the system on the iBook (1,25 GB RAM). All went well, and soon the computer came up with logon with my name and a demand for password. I entered the new password, but NO, it comes up with the correct password hint, but will NOT accept the password. I am totally locked out. As my attempt to restart on installation dvd and redo the previous procedure failed and only brought me back to logon, I decided to try using the Startup Manager Procedure. This too failed, no alternative volumes came up, only a padlock (locked) and an arrow, and the dvd seems to be stucked inside, as the eject key failed to eject it. I desperately need your advise on how to handle this. Even if I have a MacBook Pro too, I really love my little iBook and use it every day in the living room. Your prompt attention to this matter would be greatly appreciated.

iBook G4, MacBook Pro, Mac OS X (10.5), None
  • V.K. Level 9 Level 9 (56,130 points)
    boot from the install DVD and try activating root user.
    http://support.apple.com/kb/TS1278

    then see if you can log in as root. if you can, try changing the password of your main account while logged in as root from system preferences->accounts.
  • DAOF Level 1 Level 1 (0 points)
    Thank you for getting involved. Part of the problem is that the computer will not boot from install-dvd anymore. I can not even get the dvd out. I am afraid that I have reset the hardware-/root-password as well, together with user- and administrator passwords, but how can it be that the computer suddenly refuse to accept the correct passwords?
    As explained,using the startup-manager only gives me a padlock, not an opportunity to choose startup-volume. Is there any simple way of re-formatting and re-installing OS? No vital datas on the computer that could not be restored.
    Please note that I need detailed how-to-instructions, as I am not very familiar with the problem-solving-side of Macs.
    Please do not give up on me if you have some ideas how to handle the problem. Dag
  • V.K. Level 9 Level 9 (56,130 points)
    if the startup manager is giving you a padlock it means that a firmware password is set. a firmware password is completely independent of the OS and is set in the computer hardware. you must have set it using the install DVD. it could be that you used the wrong password utility on the install DVD. they are right next to each other in the utilities menu. one is for firmware and the other one is for account password.

    you have to enter the firmware password at the screen with the padlock (there should be a prompt). after you do you'll get to the actual startup disk manager where you can choose to boot from the install DVD.
  • DAOF Level 1 Level 1 (0 points)
    Thanks again - this worked! What I am still puzzled about is how to access and chage/reset passwords on the key-ring as well. Perhaps that was where I failed last time. Passwords on key-ring are not altered/reset from the Utilities menue on installer. I says: "The password has been stored for the user....... Resetting of userpassword does not change the password for the users logonkey, så this will not automaticly be opened. Reset the password for the users logon-keyring by the help of Keyring-admission" But how can I access this without being able to login by start up? Accessible from installation-dvd?
    Dare I hope you are still there? Best regards, Dag
  • V.K. Level 9 Level 9 (56,130 points)
    DAOF wrote:
    Thanks again - this worked! What I am still puzzled about is how to access and chage/reset passwords on the key-ring as well.

    I assume you mean keychain . Keychain is separate from your login password. you can reset it once you are logged in normally. Log in and start Keychain Access application (it's in /Applications/Utilities). control-click on the login keychain in the sidebar and choose "change password". you'll have to enter your old keychain password to do it. by default it's set to be the same the as the account password when the account is created so you need to enter yopur old account password there.
  • DAOF Level 1 Level 1 (0 points)
    Norwegian system Thanks for great help! Problem solved.
    Have a beautiful day, Dag