5 Replies Latest reply: Mar 15, 2009 1:51 PM by Grant Bennet-Alder
GENERAL LUDD Level 1 Level 1 (0 points)
I guess a sub-heading of this would be connecting to the newest Mac from an older one.

Here is a problem: I can set up the G3 Beige (running Jaguar) as a file sharing server and very easily connect to it from the a Mac Mini by using top menu Go>Connect to server.

Where i run into what seems to be impossible is to do the same thing from the G3. Nothing seems to establish a connection. It is always rejected with a no connection error message.

Both machines are wirelessly connecting through a router. The mini with internal airport and the G3 beige using an external D-link bridge. Both work fine accessing the internet.

Main reason i wanted to do this is that my Shared Printer is on the Mini and i wanted to print something from the Beige to it.

Can anybody help, or am i attempting the impossible.

Mini, Mac OS X (10.5.6), Also Beige G3 running Jaguar
  • Grant Bennet-Alder Level 9 Level 9 (54,330 points)
    What you are attempting should be completely possible.

    To establish a File Sharing connection from the 10.2 Jaguar G3 to the Mac Mini \[also running Mac OS X?] you must be certain that, on the Mini, you have checked:
    System Preferences > Sharing > \[√] Personal File Sharing

    Then select "Connect to Server" from the G3, and the Mini should appear in the list to connect to. The login screen you see is sent from the Mini, so you must enter a username and password that is valid on the Mini. If you enter an Admin username and password, you can share all disks on the Mini.

    Sharing a Printer is completely different from File Sharing.
    What printer is it, and how is it connected to the Mini?
    Do you have the printer Driver installed on the G3?
  • GENERAL LUDD Level 1 Level 1 (0 points)
    Hello and thanks for your reply to my question. I have tried your suggestion on the G3. When select go to server, I get a screen that says (too bad these replies don't permit attachments) "Contacting Timeout in nn seconds" The first 10 characters are OK but where does that "548" come from?.

    After the timeout I get the error message "Connecting to afp://
    An error has occurred (error = -36)

    The Mac Mini is running Leopard 10.5.6. It has File Sharing turned on. So is the G3 which is running 10.2.8.

    Commonality of the connection is via my (remotely located) wireless router. There is no hardwiring between the computers.

    NOTE: This reply is being composed on the G3 and sent out of the ISPs server.
  • Grant Bennet-Alder Level 9 Level 9 (54,330 points) is a local IP Address, from a range normally assigned to private networks, often using DHCP. The :548 is the default "port number" normally reserved for Apple File \[Sharing] Protocol. Your suggesting this makes me think of a few possible issues:

    Are the IP adressess of the two computers similar (e.g., the same except for the last octet) but not identical? Are you using DHCP from your Router to assign the IP addresses for BOTH these computers, or is one Manual? Have you assigned (or allowed DHCP to determine automatically) a Subnet Mask so that both are on the same subnet?

    If you have a Router, its Firewall protects you from the bad guys on the Internet, so you do not generally need to use the FireWall on each individual Mac. If you choose to turn on the Firewalls on Individual computers, have you allowed for AFP transactions to pass through? This is configured in the Sharing preference pane FireWall subpane as allowing "Personal File Sharing".
  • GENERAL LUDD Level 1 Level 1 (0 points)
    DEAR Grant Bennet-Adler: Thank you for your last reply. I'm not sure exactly what i did but I was able to connect. To answer your questions:

    IP Addresses are similar. One is ...101 and the other is ...102.

    My router uses DHCP.

    What seemed to fix the problem was going to security>firewall on the MINI and checking
    o Allow all incoming messages.
    Not sure what ODS Agent.app is but it is highlighted as allow incoming vs blocked.

    Both computers "allow personal file sharing"

    On the G3 i was able to connect after a bit of trial and error: On the G3, when i "Connect to Server" i am presented with three choices of servers, one of which is the G3 itself--I wish the system wouldn't remember irrelevance.

    One of the choices is OK and when i checkit i get the ID and Password Dialog--again for ID i am presented with the MINI's name and not my user (Admin) name.

    Change that, type in the password and i am given a list of drives on the folder. That includes any opened from a .img.

    After i open one i then see it on my desktop and can get into it.

    One slight problem: Once into one, i can;t go back to "go to server" to open more. I get timeouts, error messages and other stuff. I have to start over. That also appears to be to include disconnecting the connection to the G3 server that gets set up on the MINI.


    p.s I hven't gotten into Shared Printer although i saw it did show up in the Firewall dialog.I think i have the Canon MP470 Software on the G3 as well as the Mini but i will have to check on it.

    p.p.s. Next thing is to try X PostFacto on the G3 again to try to install a later OS; but this time not making the mistakes that totally messed it up the last time, last year, that i tried it.
  • Grant Bennet-Alder Level 9 Level 9 (54,330 points)
    Only one article matches "ODSAgent". It seems to have something to do with adjusting your computer's FireWall for using Windows to share DVDs:

    MacBook Air: Can't see Remote Disc (DVD or CD Sharing) host computer on the network

    Since the computer's individaul firewalls are unnecessary when you are behind a Router's firewall, it should not be an issue.


    Printer sharing does not rely on File Sharing, and is accessed through a completely different mechanism.

    Please tell readers what printer you are trying to share, how it is connected and to which Mac, and whether you have drivers that will run on each Mac or only on certain Macs, e.g., Mac OS X 10.4 driver available, Mac OS 9 driver not available. Or consider starting a new thread with a Printer Sharing type title.