Previous 1 2 Next 16 Replies Latest reply: Apr 12, 2009 4:00 PM by Gnarlodious
Al_________ Level 1 Level 1
On every system I've had since around 1982 I've been able to change the default background to 18% grey or similar.

Obviously, something needs to go into "com.apple.CoreGraphics.plist" to override whatever the system uses to set colors on start up.

I've got 1 week to find an answer to this ridiculous issue or this mac pro goes back in the box and I resurrect my old Redhat system.

Please do not reply to this post say you don't know the answer or have any useful information pertaining to the original problem, or to say that the colors are not changeable, or explain the "DisplayUseForcedGray" and "DisplayUseInvertedPolarity", or, indeed answer a different question that was never posed, or explain that I can use CTRLOPTION+CMD8 in order to toggle "DisplayUseInvertedPolarity", or to say that I should give up as it can't be done. NO, I've not been doing this for 20 years and had countless posts flamed/hijacked by mindless (well meaning?) individuals.

I will patch/hex-edit the appropriate binary to change the 'hard-coded' value my self, but I'd rather not have to go to that length as I can't believe Apple are so arrogant they don't feel the need to give the user access to such fundamental parameters, even on STONG HEALTH AND SAFETY GROUNDS.

There is a way. It just depends where you look.

08/Pro/2.8, Mac OS X (10.5.6)
  • gumsie Level 4 Level 4
    Default what background? The windows?
    I don't think you have even the slightest hint of a case from a health and safety point.
  • Al_________ Level 1 Level 1
    Please explain why you replied to a post with no useful information?
  • gumsie Level 4 Level 4
    Look closely my friend, I said, *"Default what background? The windows?"* I need to be sure of what you are asking before I can figure out if I can be of any use.

    Given the length and tone of your post. I figure your issue can't be quite as simple as it seems.

    Message was edited by: gumsie
  • gumsie Level 4 Level 4
    Ok, I've linked to it, buy why?

    I'm sure you mean something other than what I am about to explain but here goes;

    Open a finder window and open the +'Show view Options'+ pane, (⌘J). Look down at the bottom and you will see the heading, 'Background'. Choose 'Color', click the little square to the right of that and an additional pane will open up. Select the first tab-a colourwheel and drag the slider down till you see the shade of grey, (if that's what you want), that you like. Click OK to close the colour palette and the click use as defaults.

    Open a new finder window. Voila

    Message was edited by: gumsie
  • thomas_r. Level 7 Level 7
    expertise.applewatch
    Apple Watch
    He's explaining his condition. (Sorry, that wasn't nice, but I couldn't resist...)

    To Al__, if you really want help with this, you would provide the information to someone who has offered. However, I get the feeling you just want to rant. You can do that elsewhere.

    If you're really looking for a solution to eye strain issues, I don't think that changing white to another color will help you, though I won't go into all my reasoning because I don't think you'd listen. Bottom line, I'd advise that you lower the brightness of the screen to achieve the effect you're looking for.
  • gumsie Level 4 Level 4
    Oh. For some reason that didn't occur to me. Still in addition if you have sight problems. Get the biggest monitor you can afford and alter your display resolution and system text to the largest possible.
  • i.3d Level 2 Level 2
    OK, now we understand and feel sorry for you.
  • Gary P Level 4 Level 4
    That only works for Icon View. The annoying fact remains that Apple provides no choice about all the glaring white in the List and Column Views. I, too would love to be able to kick this down a notch or 2, without resorting to lowering overall screen brightness, which is a workaround, not a solution.
  • AJ Level 5 Level 5
    How about trying some of the "Universal Access" features.

    Open the universal access control pane
    Click Seeing/display
    then change it from black on white to white on black.

    Alternately,
    the suggestion on show view options may work. Select by either the color wheel, or create/use the picture of your choice (if you make on of 18% grey that you like) then

    click set as default.
  • gumsie Level 4 Level 4
    Never knew that.
  • gumsie Level 4 Level 4
    You ever get to the bottom of it?
  • CT Level 6 Level 6
    expertise.notebooks
    Notebooks
    I am sure he has resurrected his Linux box and is being rude and grouchy and/or trolling on some other forum by now.

    charlie
  • gumsie Level 4 Level 4
    Would have been nice to find the answer though.
Previous 1 2 Next