Previous 1 2 3 Next 115 Replies Latest reply: Mar 5, 2015 3:16 PM by zioweb
Darren.McMurtrie Level 1 Level 1 (0 points)
One of the many issues I'm having with iTunes, Time Capsule (where the music is stored) and AirTunes.
Does anyone know how to terminate the 'determining gapless playback information' function? That is to say, keep it from even happening/starting?
Everytime I start iTunes, it does this. I have over 14,000 songs and I get the spinning beach ball and cannot use iTunes. If I let it run for awhile (2 hours?), I can eventually X out of it in the iTunes window.
I've dumped preferences and re-launched. I've unchecked the preferences that seem like they could be related (cross-fade, etc.).
When I DO get it to work, it plays one song and goes silent- although it shows the music as playing in the iTunes window. Separate issue, likely...
Thanks in advance for input.

iMac G5 1.8GHz, Mac OS X (10.5.6)
  • Darren.McMurtrie Level 1 Level 1 (0 points)
    I can't believe nobody else has this issue? My iTunes is essentially not usable, it's always completely locked up trying to determine gapless playback information...
  • schmattel Level 1 Level 1 (0 points)
    I have the same problem as well. We have about 50GB of songs and had to reformat our computer. Now we cannot use iTunes due to the gapless playback problem. Our music is stored on an external hard drive and we never had this problem until now. I have research this problems for hours and have not found a solution, just people commenting on how this is a bug that Apple cannot be bothered to fix.

    I have given up trying to fix it and I'm going to try alternatives to iTunes. There are some good reviews about alternatives. Good luck and hopefully they fix it soon.
  • phoenix1973 Level 1 Level 1 (0 points)
    I solved my problem by closing itunes, ejecting my external disk, restarted itunes- the gapless playback flew through 16,000 songs in about 10 seconds and then finished. I plugged in the external disk and I am listening to my music now
  • Tracy Reynolds Level 3 Level 3 (545 points)
    Have you tried letting it finish "determining"?

    BTW, all CD's are gapless if you think about it. I've set all of mine to gapless. Play an album in iTunes that is not gapless and try to synch it up to the actual CD in another player. iTunes adds a gap between every song unless you tell it not to. When songs fade to silence between tracks you don't notice the extra fraction of a second.
  • Tony Diaz1 Level 1 Level 1 (5 points)
    Some people claim "Gapless playback is the best feature of iTunes since the hard drive!" and that those of us who hate it checking are missing the point.

    ...the point is, I migrated a library to another drive and it's doing this now everytime I add so much as one file to the library, or make a meta-change, it picks 20-26 tracks and starts this "gap check" .. and practically locks up iTunes.

    .. letting it finish "determining".. I wish, according to my calculations it's going to take until rapture and the next coming of Noah to finish and then it won't matter.

    There needs to be a clear and concise way to SHUT THIS OFF. Period. If I want to designate Dark Side of the Moon as an item that needs gapless playback, I can do that. Since less than 1% of the average individuals collection requires this, it makes no sense to do it on all.
  • Chris CA Level 9 Level 9 (77,695 points)
    If I want to designate Dark Side of the Moon as an item that needs gapless playback, I can do that.

    No you can't. iTunes determines gapless automatically.
    Checking *Part of gapless album* on an album does one thing.
    If Cross Fade is turned on in iTunes prefs -> Playback and it is a gapless album, then the songs will not cross fade. see this -> What is Gapless Playback?
    But iTunes first needs to determine if it is a gapless album.

    Send suggestions here -> http://www.apple.com/feedback/itunesapp.html
  • Tony Diaz1 Level 1 Level 1 (5 points)
    By "I can do that" I really meant, "I can do that quite easily myself" by instructing iTunes to do whatever sniff test it needs to check this stuff to see if it's gapless.

    I've read the "what is gapless playback".

    I've sent feedback multiple times.

    I'm not the only one with issues of crap performance associated with gapless playback and the whole thing is ludicrous as it's a big waste of time and source of frustration over something that effects the ear candy/experience on less than 1% of what I can imagine the typical music library is. Even if it's 10% it's still stupid.

    "Gapless playback is always on", fine. Let us shut it off. Again, I say, if I want Dark Side of the Moon to play without gaps I can do the crossfade on/not part of a gapless album on everything else. It's easier and quicker to select those FEW items that need it vs. all the peoples time wasted on when it's not needed.
  • Tracy Reynolds Level 3 Level 3 (545 points)
    Actually, ALL albums are gapless. Don't believe me? Grab a CD you have ripped and play it synched up with the album in iTunes. iTunes adds a split second second between songs and the CD will finish first. You don't notice the gaps on studio albums because there is already silence between the tracks.

    How long have you left iTunes alone while "determining gapless"? It takes a while to go through several thousand songs. My iTunes will finish if I leave it alone.

    I have my entire library set to gapless.

    I have a lot of concert albums (319 so far out of 1124=28%) and I had to use crossfade until gapless came to iTunes. That was OK but it wasn't gapless and it really made my day when the feature finally appeared (after several messages to iTunes feedback).

    Oh, by the way, turning gapless on DOES NOT stop crossfading. I just checked on my new Mac mini with iTunes 9.0.2.
  • Chris CA Level 9 Level 9 (77,695 points)
    turning gapless on DOES NOT stop crossfading. I just checked on my new Mac mini with iTunes 9.0.2.

    It stops cross fading if the songs are consecutive on the same album. If the 2nd song is not the next consecutive song from the same album, it will cross fade.
  • Tony Diaz1 Level 1 Level 1 (5 points)
    iTunes ran for 20 days and it's still doing random gapless checking.

    I'd like to punch it in the gap.

    As best I can tell, it's at about the 24K mark, out of 75K tracks.

    Ridiculous. I can't do hardly anything with iTunes because as soon as I change something it picks the next 20 or so tracks to gap check.
  • Tracy Reynolds Level 3 Level 3 (545 points)
    Yes, I can see where that would make a difference. I only checked it with consecutive songs.

    Tracy
  • jbar Level 1 Level 1 (0 points)
    I've been building my library for five years or so and only just recently have run into the "Determining Gapless Playback Information" problem. Replaced an old iBook G4 with a new MacBook and transferred all 27,000 songs/2725 albums/120 gigs from an outboard hard drive onto the new laptop. While synching the 160 gig iPod for the first time with the new laptop's iTunes I noticed that some 7300 songs got run through this routine. I let it run. Then added three albums and it immediately went back into the routine starting again with some 7300 songs. This is only an issue when the iPod is connected... haven't ever seen it happen while playing iTunes from the laptop to AirTunes. But every time I update the iPod's library I get the same slow routine with the same 7300 songs. Luckily it happens at the end of the update/synch process and I have determined that simply clicking the "x" button on the right side in the "lozenge" window at the top of iTunes gets me out without having to force quit. Not a perfect solution but one that is acceptable for now.

    The question I have is whether this is source material based or if it is playlist based... or iTunes... or the iPod. I can't seem to find anything in common among the 7300 songs that keep requiring the same determination.
  • holtsch Level 1 Level 1 (0 points)
    I really like Apple - and I really like iTunes. But this just *****! I was hoping that this maybe got fixed with 9.0.3 ... but I'm still getting 72 of my MP3s do that stupid thing every time I start iTunes. Those are not songs but actually recordings from a seminar, so each is between around 45 minutes up to 2 1/2 hours. And this "gapless crap" takes about 2 or 3 minutes each time I start iTunes, and during that time, I can't use iTunes at all.

    I noticed there's a checkbox "Gapless album". I've tried switching this off for my complete library. No change. I've tried switching it on for my complete library. No change. I have crossfade songs disabled.

    What's so difficult about implementing an option "stop iTunes doing stupid stuff I don't need"??? Ok, sorry for being a bit upset but that's just annoying. Give me that "Disable Gapless Playback Check" and I'll be a all happy again
  • enti Level 1 Level 1 (0 points)
    I have the same pb since I switched from Win to Mac and fully agree with holtsch! On Win I ran this procedure once over night, and never saw it again.

    My music is on an external drive, the described problem appears sooner or later after the iTunes start. Currently I have to stop this 'service' (takes some time), but it restarts automatically after some time.

    I'm also thinking about alternatives to iTunes. It's frustrating and surprising that iTunes works better on 'second class' hardware and OS than in a full Apple environment. Should have known before...

    Most frustrating: No option to turn this 'service' off!
Previous 1 2 3 Next