Previous 1 2 3 4 Next 52 Replies Latest reply: Dec 30, 2009 8:20 AM by alancurtis
louiexiv Level 1 Level 1 (0 points)
This is extremely annoying. I have the box unchecked for "ask before sending a non-secure form from a secure web site" and the confirmation window still constantly pops up when I merely try to refresh/reload a page. People have been complaining about this since 2005 and there is still no way that I can find to turn the annoying confirmation off.

I am experiencing this annoyance while logged into a correspondence chess web site. I am not trying to buy or sell anything when this happens. I am not putting credit card information into a form. All I am trying to do is refresh/reload the web page so that I can see updated information about how many games require me to make my next move. I really don't need the aggravation when I am trying to play chess with people around the world as a way to relax and get my mind off work.

Apple needs to give users the option -- an effective option -- to turn this annoying confirmation OFF. Since it may be advisable not to have this irritant turned off universally, why not allow -- or, for security reasons, require -- the user to turn it off for one web site at a time. Since Safari keeps track of web sites and their unique login information for other purposes, it should be possible to allow/require users to turn this confirmation off site-by-site. For added protection, Safari can require an Administrator password for each and every such site, display a big red warning each time it is turned off, issue a special warning/confirmation if there appears to be credit card information on the page being refreshed/reloaded, and make the option difficult to locate so that only those who make an affirmative effort to learn how to do it can do it. Surely Apple can treat at least some of us like mature adults who can make informed decisions, on a site-by-site basis, to turn this annoyance off.

As I mentioned above, people have been asking about this since 2005 to no avail. Apple appears to "archive" every thread that gets started on this subject almost as soon as the question is posed. It would be nice if Apple would finally get around to addressing this issue in order to give Safari users an improved experience consistent with the Apple philosophy that technology should be fun to use. Come on, guys! Let me play chess in peace.

Mac OS X (10.5.6)
  • iBod Level 7 Level 7 (29,340 points)
    Hi louiexiv,

    People have been complaining about this since 2005 and there is still no way that I can find to turn the annoying confirmation off.


    This is standard practice across all the browsers out there and I don't think you'll find any that do what you want. Of course there's nothing to stop you asking Apple, but since we're all users here it may fall on deaf ears. Safari menu > Report Bugs to Apple... or http://www.apple.com/feedback/macosx.html are the best places to send feedback to the developers.

    It sounds like the website in question needs to update their site to allow for refreshing with submitting POST data. There's plenty of ways for them to handle this. Are you sure there isn't a link on the page to perform a refresh rather than using the refresh button? If there isn't it will be affecting everyone at the site regardless of them using Windows, Mac OS X, Linux, etc.

    Apple appears to "archive" every thread that gets started on this subject almost as soon as the question is posed


    Any thread that hasn't received any activity after a period of time will be archived. It's standard procedure to try and keep the forum up to speed and nothing sinister going on
  • Ezzyme Level 1 Level 1 (125 points)
    IBod you are so wrong!

    From an Apple support search:

    "Safari 2.0 Help

    Submitting forms to a secure website

    In some cases, forms you complete in Safari may be submitted in a nonsecure way to a secure website. Safari is set to display a message when this is about to happen, so you can prevent the form from being submitted if you are concerned about the security of your information.

    If you don't want to see this message, choose Preferences from the Safari menu and click Security. Deselect the checkbox labeled "Ask before sending a nonsecure form to a secure website."

    Keywords: khelp ksafari"

    So why doesn't this work???????!!!!!!! It doesn't. And it's not just this guys Chess website. This message pops up on many websites and I would greatly appreciate it if I could make it go away like Apple designed, with a feature that no longer works. <Edited by: Host>
  • hpr3 Level 5 Level 5 (5,725 points)
    Works for me.

    Message was edited by: hpr3
  • ~Bee Level 7 Level 7 (31,160 points)
    Ezzyme --
    You have no clue whereof you speak.

    iBod has researched everything Mac for years.
    He has received nearly 28,000 thank you points
    for providing solutions for AD posters.

    And after all those posts, I cannot remember ONE that
    started out, "You are so wrong."

    IBod rules.
  • iBod Level 7 Level 7 (29,340 points)
    Thanks ~Bee.

    Who knows, I may be wrong (happy to be corrected if I am) but as the original poster never replied it's hard to tell at the moment.

    Ezzyme, the article you quoted from is referring to a different thing from the original poster. The article is talking about the initial submission of a form from an unsecure page to a secure website. The original poster is referring to the refreshing of a page where without the warning they a referring to (a different warning) you can easily resubmit information (such as a shopping order) by accident.

    If you have a different issue to the original poster, it's best to start a new topic for your specific question. If your issue is the same as the original posters, then my previous advice still remains.

    Cheers!
    Hobbes
  • lincris Level 2 Level 2 (150 points)
    Well, unchecking the box doesn't work for me. I still get this annoying message, not once, but twice - each one requiring another pointless mouse movement across the page and click on "send". When this happens twice every time it is very, very annoying and so Micro$oft like. Of course I want to send the form again, didn't I just tell it to? Just like Micro$oft asking if you really want to shut down.

    Is there really no fix for this?
  • Ronda Wilson Level 8 Level 8 (41,075 points)
    This is not the fault of Safari, but of the coding of the website where you see this warning. If you want to complain about it, complain to the webmaster(s) of the site(s) in question. It has nothing to do with Apple (unless you happen to see it on Apple's website — which I never have).
  • Ezzyme Level 1 Level 1 (125 points)
    Then why did Apple post a solution for this issue? And why did it work for me in past versions of Safari, all the way to 10.5.7? Please only speak if you know what your talking about.

    http://docs.info.apple.com/article.html?path=Safari/2.0/en/ibr29.html

    "Safari 2.0 Help

    Submitting forms to a secure website

    In some cases, forms you complete in Safari may be submitted in a nonsecure way to a secure website. Safari is set to display a message when this is about to happen, so you can prevent the form from being submitted if you are concerned about the security of your information.

    If you don't want to see this message, choose Preferences from the Safari menu and click Security. Deselect the checkbox labeled "Ask before sending a nonsecure form to a secure website."

    Keywords: khelp ksafari"

    De-selecting this option has worked in the past but now does not work.
  • iBod Level 7 Level 7 (29,340 points)
    Ezzyme,

    It's still not clear which issue you are talking about.

    Are you talking about the same issue as the original poster, or the warning when submitting a non-secure form?

    (This is why it's usually a good idea to start a new topic for your own issues.)
  • hpr3 Level 5 Level 5 (5,725 points)
    Does the word threadjacking mean anything to you? Your tone is not unacceptable here and I for one wouldn't lift a finger to help you.
  • lincris Level 2 Level 2 (150 points)
    @Ronda Wilson

    Just so I'm clear on this. Like the original poser, I have the "ARE YOU SURE YOU WANT TO SEND A FORM AGAIN?" drop-down appearing twice when I want to go back to a previous page on certain websites in Safari. The insecure website warning/checkbox which Ezzyme is referring to appears to be a different issue altogether.

    It may be a website coding problem, but I'm not sure. The drop-down dialogue box has a Safari icon embedded and the words +"To open this page again, Safari must resend the form you completed to open the page the first time. This may cause the website to repeat actions it took the first time you sent the form."+

    I guess you are saying that while the drop-down dialogue box may be Safari, the reason it appears is due to poor coding on the website I'm using. Can anyone else confirm this please?
  • ~Bee Level 7 Level 7 (31,160 points)
    People, people. . . .

    There are some sites aimed at PC audiences, who every time you want to back up,
    ask this question over and over. It's not the end of the world . . . I've learned I
    can't do that on several banking sites, for security reasons. I've found a way around
    that . . .

    lincris, I'm confirming that.
    My bank for instance . . . It used to be terrible, and extremely user unfriendly (to Macs.)
    Apparently, enough customers have complained, that they are now (lat 5 months) really
    up to date for Macs.
  • Ronda Wilson Level 8 Level 8 (41,075 points)
    I think ~Bee covered it for you.
Previous 1 2 3 4 Next