Previous 1 2 Next 16 Replies Latest reply: Sep 14, 2009 3:49 PM by sam squarewave
Mitch Routman Level 1 Level 1 (0 points)
Hi all.

This is a recent issue I've been having, as of today, with Leopard. I'm trying to connect to my home network that I haven't had any trouble with until now. I've been experiencing all evening Airport errors, telling me that there's been a connection timeout. I've attempted to shut down my computer, restart it, turn airport on and back off, restarted the router, and I am now out of ideas.

It's finals time for me and I need the internet, and I don't have an ethernet cable to run the 80ft or so from my router to my desk. Any suggestions?

MacBook Pro, Mac OS X (10.5.6)
  • jabber_wok Level 1 Level 1 (0 points)
    well, it might depend on what type of router you are using. I have similar problems with my time capsule /airport device from time to time, and the best workaround i have found is towards the bottom of this page:

    http://discussions.apple.com/message.jspa?messageID=9155811#9155811

    if you are not using an airport base, and are using a regular router, then i am not sure. doing something similar may or may not work.

    Message was edited by: jabber_wokk
  • Mitch Routman Level 1 Level 1 (0 points)
    I'm not. I'm currently using a D-link DGL-4500, one of their gamer routers because my housemates have Xboxes. But that has never, ever effected my airport card. In fact, I've been the only one home in the last 24 hours during this problem and I still can't get on. I've even tried connecting to the wireless network on campus and I'm still getting the 'Connection timeout' errors. I thought maybe I had put in the wrong password or something but that's not the case. Everything has checked out fine.
  • bwfrank Level 1 Level 1 (5 points)
    I'm having the connection timeout problem with my MacBook Pro and updated system software also. I'm connecting to an Airport Express. The problem began recently but I'm not sure which update caused it to start.

    I have a solution but I do not like it. I have to unplug the Airport Express, wait 30 seconds, plug it in, and wait for it to restart. Then I can connect.

    I stay connected for as much as a day, lose the connection, and find I can not reconnect even though the WIFI base is listed. iStumbler finds it also but reconnecting requires unplug/plug routine.

    There are a number of unprotected WIFI signals here. I can connect to any of them even while not being able to coneect to my own (password protected) Airport Express.
  • ted21 Level 1 Level 1 (0 points)
    yea ive had the same exact problem since one of the last updates, its annoying me to death i have to stay tethered now, hopefully apple will realize the bug and fix it soon!!!!
  • srndur Level 1 Level 1 (0 points)
    nearly lost my mind the first time this happened to me. I ran out and bought an apple router, thinkin that was the pblm. Yay Apple! grrr I had the same pblm with this apple router than I had with the linksys. My Macbook Pro just decides it will not recognize the device in Airport Utility nor the wireless network (which is currently connecting my PC and iPhone). I would not buy another MBP.
    Apple has never admitted any problems along this line and I've read numerous threads where the owners have been told by Apple geniusbar employees and threads that it is a router problem.
    I wish I had a solution. Sometimes just toggling Airport on/off has found it. Other times I "join other network" and put in the same network info. Or reboot over and over til it works. Today, none of those workarounds are working so I will prob have to lug it upstairs and ethernet connect andn remake the same network. again. sigh.
  • devond Level 1 Level 1 (0 points)
    FWIW - I have the same problem. I've tried other routers, other channels, you name it. Given that, and the fact that the exact same network has zero problems for my numerous PCs - IMHO this is clearly a Mac side problem.

    To add some weight to that opinion (not that Apple cares, it's easier to hide behind a third party explanation) but I'm a project manager for an R&D engineering team at one of the top 3 IT companies in the world and we develop and support NETWORK MANAGEMENT solutions. This is an Apple HW/SW defect, there's no other explanation given what I've observed.

    This was my first and likely my last Mac.
  • GPK3 Level 1 Level 1 (0 points)
    I have had this problem since I got my new MacBook and have been EXTREMELY aggravated. But recently I switched to openDNS and havent had the issue since then. Hope that sheds some light on the ridiculous situation.
  • BrittonBK Level 1 Level 1 (0 points)
    Similar issues here with a MBP at work. Cannot connect to a non-broadcasting network (D-Link router). I was initially able to connect, but after that first day I haven't been able to connect again. I can connect to other networks without any problem. I just get a "connection timeout" message when it tries to connect. Interestingly enough, when I log into Windows XP (via bootcamp) it works. That makes me think it has something to do with the Mac Airport drivers. It's very frustrating.
  • WilsonLaidlaw Level 1 Level 1 (0 points)
    I thought Apple had sorted this pretty vital issue. My Macbook and iMac had, over the last few months, stopped doing it. Got my new 13 inch 2.53 MBP yesterday migrated, updated and back the old problem comes. I know I can usually fire it up via Network preferences but........I know I can also improve the problem by using MAC number limited access control security on my routers instead of encryption but that is a pain, as every time I have visitors to stay (often as I have a house in Provence), I have to reconfigure the router rather than just typing in the current password for them. I will phone the Genii at Apple today and see if they have any gems to offer. This is a serious issue. I know that my brother and one other friend went back to Windoze because of it. All the various work-arounds are clunky and should not be required.

    Wilson
  • WilsonLaidlaw Level 1 Level 1 (0 points)
    OK I think I may have a fix for this, at least for the latest MBP's, which have had their data migrated over. The migrated system configuration is not liked by the latest MBP's if migrated from an earlier MB or MBP. The solution is simple. Go to HD/library/preferences and drag the system configuration folder to the desktop. Then do a restart but do a PRAM (alt-cmd-P-R) reset on restart, holding for two sets of start up chimes. After doing this the connection time out disappeared. After the restart is successful, you can drag the system configuration file to trash.

    Wilson
  • jaeappleid Level 1 Level 1 (0 points)
    For me, the solution was to upgrade the firmware on the router. It's a Linksys WRT54GS version 4. Once I upgraded the firmware to the latest version the problem stopped.

    (Just for clarification, I never had trouble at home, but when I brought my MacBook to work it wouldn't connect to the router, regardless of what kind of security I used. As other users report, the connection dialog would simply say "Connection Timeout" instead of any sort of invalid password message.)
  • Mac-leop Level 1 Level 1 (0 points)
    Hello Everyone!!!
    I had a Macbook pro with OS 10.3 and last night i decided to upgrade it to OS 10.5.8. So far so good, i like the new version. Unfortunately, it is impossible to get the internet with airport however when i plug an Ethernet cable it does work properly.
    First of all, i went to "system preferences" then "network" in which the airport icon is ON with a yellow light. Then i opened "Safari" to get the network diagnostic but all the lights were red. I ticked the airport box as usual, selected a network, key in the password and was told that i might not put the right password (but that's not the case).
    I went to the airport status in the menu bar, to try again and but at the bottom of the window, it was written "Connection Timeout"...what does this mean?
    On the internet, it is said to have all the "Mac OS upgrades" but when i checked my "Software upgrade" everything was done.
    My housemate has a PC and he told me he could get connected wirelessly which means that i therefore put the right password and that the problem comes from my Mac.
    When install OS 10.8.5, i got "time machine" on my laptop but whether it's on or off, i don't think that's the problem.
    I really need to use a wireless connection, could you please help me to sort this out?!?
    Many thanks
  • sam squarewave Level 1 Level 1 (45 points)
    Same problem here. Upgraded my router, but no luck.
  • wve Rich Level 1 Level 1 (0 points)
    This solution did NOT work for me. I've tried different things. Nothing has worked. The problem just started. Very frustrating. I can connect to a optional Linksys wireless just fine, but can't connect to my Airport Extreme. I've used the system for months without this problem.
Previous 1 2 Next