14 Replies Latest reply: Mar 28, 2009 9:08 PM by jpl
IR Doc Level 1 Level 1 (0 points)
A problem has arisen with my old PowerBook G3 Pismo. When it turn it on a floppy disk image appears with a question mark on it. The PowerBook whirrs a few times but there is no boot. I am wondering whether it is the PRAM battery and bought a new one in case. Or is it that my hard drive or logic board has died? Can someone suggest whether my good old PB G3 can be saved, or should it be relegated to the dustbin of history?

Help please

Macbook Pro 2.2Gz, Mac OS X (10.5.6), 4 GB
  • a brody Level 9 Level 9 (64,285 points)
    This is normally not a display issue, but an issue with the directory of the hard drive, or the hard drive might be dying. Logicboard issues rarely cause such problems, though could. I would attempt to repair the directory as long as the data is backed up. If it isn't try a data recovery tool such as Prosoft Data Rescue, Subrosasoft Filesalvage, or Boomerang's Boomerang and a Firewire external hard drive at least as large as your Pismo. Once data is backed up, try Alsoft Disk Warrior to repair the hard drive.
    If that doesn't work, replace the internal hard drive and recover your data.
    If that doesn't work, get a new clock battery from an authorized service center.
    And if that doesn't work, ask them to run a hardware diagnostic. It is possible the RAM is bad. They could try different RAM.
  • jpl Level 7 Level 7 (28,285 points)
    IR Doc,

    If you have not installed the new PRAM battery, reset the PRAM and test:

    http://support.apple.com/kb/HT1379?viewlocale=en_US

    If unsuccessful, a new PRAM battery will make no difference. Follow the suggestions in this article:

    http://support.apple.com/kb/TS1440?viewlocale=en_US
  • IR Doc Level 1 Level 1 (0 points)
    Thanks folks. Booting the PB from the OS9 CD has produced an interesting outcome. The CD has been recognized, the Menu has come up, some squiggly horizontal lines have appeared, and the trash can is now present, but no sign of the hard drive. So am wondering whether my 10 year old PB G3 has actually died and gone to Mac heaven. Of course this leads to the next logical question: is there any point attempting to resurrect it? Any ideas?

    Many thanks
    Dave
  • a brody Level 9 Level 9 (64,285 points)
    A directory issue alone could lead to the hard drive being invisible. That does not mean the drive is dead.

    Horizontal lines though are not a good sign for the inverter board or the graphics driver of the Mac OS 9 booted CD. If the CD is not a retail installer CD newer than the Mac in question, or has a Mac model name on it, the horizontal lines simply indicate you booted from a CD with the wrong graphics drivers.

    Has the clock battery been replaced in the last 4 years?

    Does your Mac OS 9 installer disc look like *

    - * Links to my pages may give me compensation.

    Message was edited by: a brody
  • jpl Level 7 Level 7 (28,285 points)
    Dave,

    Just to check...have you reset the PRAM?

    Did the Pismo work properly the last time used? The squiggly lines on the display may indicate a RAM problem. A first step would be to reseat the RAM modules.

    Another possibility is the microprocessor card is not fully seated. One symptom of this condition is the HD goes missing and does not spin up.

    Put your ear close to the 'delete' key when you start the Pismo; do you hear the HD spin up?

    Since you can boot to the CD, open the Utilities folder on the CD, launch Disk First Aid and see if the HD is listed; if so, run Disk First Aid and see what turns up.

    If no success above, quit Disk First Aid, launch Drive Setup and see if the HD appears. If it does, you can try erasing the HD and reinstalling your OS. As you will be warned, all data will be lost.

    Is the 'book worth fixing? If you want to use the 'book and just the HD is shot, yes, it is worth fixing since HDs are very inexpensive and you can install it yourself.
  • IR Doc Level 1 Level 1 (0 points)
    I'll reply to both replies here, if its ok. The CD is Apple original CD, and squiggly lines have disappeared on reboot. PRAM has been reset without success in booting. Reboot PB from CD. Disk First Aid is identifying the HD, but Repair says "Cannot remount the disk. volume ... could not be mounted. Will attempt reinitializing of HD. Fingers crossed still.
  • IR Doc Level 1 Level 1 (0 points)
    Attempted Drive Setup. Initialization Failed. Does this mean that the hard drive has died?
  • a brody Level 9 Level 9 (64,285 points)
    Yes. Although, some data recovery facilities can extract data from such drives, consumer level recovery options are very rarely able to get data off such drives directly. About the only company I know might be able to do it is http://www.drivesavers.com/
  • IR Doc Level 1 Level 1 (0 points)
    One correction - result of not having used the G3 in quite a while. Its a Wallstreet, not a Pismo. Looked it up and its a G3/233. Originally 6 or 8 GB HD (i think) and 96 MB RAM (got that thanks to bootable CD). Appears that HD has died after all, and PB battery needs to be replaced also. Still wondering whether PRAM battery also needs to be replaced.

    Thanks much for help. Greatly appreciated.
  • a brody Level 9 Level 9 (64,285 points)
    If the PRAM battery hasn't been replaced in 4 years, it likely needs to be replaced.
  • jpl Level 7 Level 7 (28,285 points)
    Dave,

    The internal rechargeable backup battery (PRAM battery) is probably in need of replacing but it requires the almost complete disassembly of the powerbook to do so. I would not bother since it is really not necessary; powerbooks are different than desktops. You can run the powerbook quite nicely with a dead PRAM battery; only if the battery develops an internal short will it cause a problem and you will know because the powerbook will not start...it will appear dead.

    Please try this procedure: Boot to the CD > launch Drive Setup > initialize with the option 'checked' to write all zeros. You will find complete instructions by going up to the menu bar and selecting Drive Setup Help. This procedure will reallocate (spare) any bad blocks if possible and may clean up the HD. After "zeroing", immediately run 'Test Disk'. If it fails, zero and test again. A second failure means the HD is shot. If it passes the test, quit Drive Setup, reinstall OS and test.
  • IR Doc Level 1 Level 1 (0 points)
    jpl

    Tried it. Seems HD is non-existent. It shows up initially then disappears. Guess i'll order a new HD. Not a problem. Just want to make my first powerbook functional again.

    Thanks for all your help.
  • IR Doc Level 1 Level 1 (0 points)
    Ok, so problem solved. Ordered a new hard disk ($40 for a 80GB Seagate from OWC) and installed it. Whoopie - booted perfectly. Then realized the battery had died - it has been a while - so ordered a new one a replaced it ($80 from compsource). Turns out the clock battery has also died. No worries - just ordered a new one from OWC ($25). Will attempt to install myself - save $135/hr bench time, or may get an acquaintance Mac techie to help.

    Thanks for all your help folks. It is all greatly appreciated. Next task: upgrade HD on TiBook from good old 40GB to something with a bit more capacity.

    One other question: do i need to get a special CD to install OS X on the WallStreet? It won't recognize the 10.2 CD from the TiBook.

    Thanks much
  • jpl Level 7 Level 7 (28,285 points)
    IR,

    Your Wallstreet will not boot from a machine-specific OSX CD although there are a few exceptions. You will need to find a retail, full-install set of Jaguar CDs. An alternative is to remove the HD (very simple) and connect the HD to your Ti via a USB and/or FireWire 2.5" HD enclosure and install from the Ti. A cheaper route is to connect the Wallstreet's bare HD to the Ti via a USB adapter cable.

    http://eshop.macsales.com/item/Other%20World%20Computing/USB2PATA/

    Please remember the restriction on the Wallstreet's HD when installing OSX:

    http://docs.info.apple.com/article.html?artnum=25249

    If possible, install just the System Folder from 9.x on the first partition also. The Wallstreet can be quite cranky with OSX and the 9.x System Folder often will get her up and running when all else fails.