Previous 1 2 Next 19 Replies Latest reply: May 18, 2009 7:30 PM by SpurtSpanker
Delapidator Level 1 Level 1 (0 points)
Have done a bit of searching for an answer to this but not found anything. I think the main problem is it's a little awkward putting it into words. My apologies if this has already been posted and I have missed it.

On the I phone keyboard. You know when you touch a key on the keyboard and as you touch the letter it pops up but larger? Well occasionally when I'm typing certain letters don't do it. The letter itself does go into the message body or whatever i'm typing into but it just doesnt pop up big to say that the letter has been typed. Not always the same letter although certain letters do seem to suffer this problem more often than others. S and I are to that this happens to quite a bit. On the other hand sometimes they all work just fine?

I know it's not a really big problem coz at least the letters are working but sometimes if your looking at the keyboard and not what your typing you think you haven't touched the letter and keep on touching it and it ends up looking a bit like ttttttthis! lol.

Any body else had this problem.

Thanks.

PC, Windows XP
  • AKRBTN Level 4 Level 4 (1,165 points)
    Sounds like your keyboard is slightly unresponsive. You're hitting keys - it looks like they are not responding so you're hitting them again and getting the the multiple lllllletter effect.

    Try a reset of the phone to see if it helps.
  • Delapidator Level 1 Level 1 (0 points)
    Thanks i'll try that.

    its not like the phone freezes up though. It's like i'll be typing and everything is fine but then 1 letter will stop enlarging whenever i touch it. The letter registers in the text area and it is just that 1 letter that is affected. the others all work fine straight away.

    If the reset doesn't fix it does that mean the phone is broken and needs to be sent back?
  • Damien Bargiacchi Level 1 Level 1 (0 points)
    I'm having the same problem.

    What we're talking about here is the visual feedback that let's you know you've typed a letter. When touching a "key" on the iPhone keyboard you get the letter pop-up to let you know which key was recognized. Often enough some of the letters don't give this feedback. In fact, when I logged in to post this none of the letters where giving that feedback. The problem is not the keyboard: every "key press" is registerred. It's just the visual feedback that makes typing on the iphone easier.

    This has been happening to me since I bought my iPhone a couple of weeks ago.
  • Blasphemy4kidz Level 1 Level 1 (75 points)
    This could just be a general lag on the iPhone keyboard. This is a known issue with the keyboard, especially when typing in the SMS application.

    However, it seems that in your case, it is happening a little more frequently than most. Try these solutions in order:

    1. Check if your iPhone is updated to 2.2.1 (latest as of this writing)
    2. Rebooting your iPhone. Check if the keyboard is still having the same problems.
    3. If the problem is persisting, try to restore your iPhone to factory settings. Remember to have a backup of your iPhone just in case!

    Hopefully, those problems will fix your issue. If not, perhaps it is a hardware issue, but I HIGHLY doubt it.

    Good luck.
  • Damien Bargiacchi Level 1 Level 1 (0 points)
    I did mention in my previous post that I am indeed running the latest OS and that this has been happening GDM day 1.

    I just got the problem again. I doubt it's hardware or lag.
    My 'i' key just stopped giving feedback. Pressed other keys they were ok. Going back to 'I' still no feedback no matter what. Switch to the number input and back and it gives feedback every time. My guess would be that there is a bug the prevents that animation from being linked to the key press event and that the order the keys are populated leads to I being the worst.
  • Damien Bargiacchi Level 1 Level 1 (0 points)
    (Double post sorry)

    Message was edited by: Damien Bargiacchi
  • Blasphemy4kidz Level 1 Level 1 (75 points)
    That is very odd...it could be related to your digitizer (the touch sensitive screen underneath the glass) malfunctioning.

    It's highly unlikely, but it's possible. I'm afraid the best you can do it take it in to have an Apple Genius take a look at it, and have it replaced.
  • Damien Bargiacchi Level 1 Level 1 (0 points)
    I appreciate you trying to help.

    Like I said in my previous post, the touch is always correctly recognised. You can tell this because the right letter is put into the text field, and it is put there exactly once. So the hardware is recognising the touch properly. The problem is only that the small animation doesn't happen. Unless there's a hardware problem with the graphics subsystem, it seems to me that this is almost certainly a software problem. Don't you agree?
  • Blasphemy4kidz Level 1 Level 1 (75 points)
    Normally I would agree, but a fresh restore would eradicate any such software problems.
  • Rokush Level 1 Level 1 (0 points)
    The exact same thing is happening to me too. When pressing a key, the pop up sometimes does not show but the key is egistered. it happens to different keys, not the same one. I read in another post that this is a bug in the firmware. And the current solution is to disable the auto correction feature in the keyboard settings. Hope apple will release another firmware update soon.
  • Rokush Level 1 Level 1 (0 points)
    So, like I said before, I have been having this exact same problem. The culprit of this problem that I have found out “ at least for me” is the “Auto-Capitalization” option in Settings, General, keyboard. Turn this OFF and all Pop Up keys will display. How did I found these out you ask? Here’s how I tested. First, install the Bank of America mobile application from App Store (It’s free). Make sure that “Auto-Capitalization “ in settings is ON. Now open the Bank of America app and under login type a letter, lets say “G”. As you can see, with “Auto-Capitalization” ON the letter is capitalized. Now after typing the G letter without spacing type the letter “H” or another letter. Now click again letter “G” and the pop up will not show but letter will be recognized. For me this has to do with the “Auto-Capitalization”. When I turn it OFF everything works. I have been testing this for the past 30min. But so far at least for me this is the culprit. So, “Delapidator” and “Damien Bargiacchi” test this out and tell me if shows the same for you.


    The reason for Bank of America App is because that’s where I saw the problem occurring first. But it also happens when typing an SMS.
  • Rokush Level 1 Level 1 (0 points)
    well. don't need bank of America app to test it out. just use safari and go to google.com. when you click the search field to type something you notice that the "caps" keys is not light up. it should because your first letter will capitize since you got capitizstion set to on on settings, keyboard. type a letter and it will be in high cap. go over that same letter and no key animation. it's a bug.
  • steves70119 Level 1 Level 1 (0 points)
    just logging in with the same problem. Especially the s key. I have not noticed any pattern as to when it happens, just that it does happen. My iphone is 2 weeks old running 2.2.1
  • Walkinrain Level 1 Level 1 (0 points)
    Thank you! I have been having this problem since I brought my iPhone 3G in August 2008. My problem was with the "e" key in every application. I turned off auto-capitalization and to problem was solved. I then turned the auto-cap back on to test and all the keys, including the "e" key "popped up". Thanks again for the post!
Previous 1 2 Next