Previous 1 2 Next 15 Replies Latest reply: May 21, 2009 12:16 AM by Phychi
sjam Level 1 (10 points)
I'm getting this message "the itunes library file cannot be saved. an unknown error occurred 13001" when first opening up itunes. It seems to be trying to generate the Genius list and then crashes half way thru...anyone have any suggestions?

iMac core 2 duo 20", Mac OS X (10.5.2), 500GB HD 3gb ram
  • ShawnOb2 Level 1 (0 points)
    I'm experiencing this as well with no matter of troubleshooting to resolve it. I don't know if it's permission related where the iTunes library is saved?

    Is your library local to the Mac or are you access files over a LAN?
  • Rob Bryson Level 1 (5 points)
    delete your genius file "itunes library genius.itdb" in your itunes folder and let it rebuild or replace it with a time machine back-up from a couple of days ago. This is what worked for me.

    Message was edited by: Rob Bryson
  • ShawnOb2 Level 1 (0 points)
    I've deleted the previous *genius.itdb file, restarted my Mac, restarted iTunes and have let Genius "Gathering information about your library" for over 12 hours.

    Since I've done this twice now, I'm thinking something is up with the iTunes 8.1 release that is causing a problem. It worked previously.

    I think I might be giving up on it, unless someone had an idea of how to capture a dump file on what is taking so long.
  • Derek Watson Level 1 (70 points)
    having same trouble, iTunes keep stalling during playback then restarting a few seconds later. Had a call to support but after going through everything, back to square one.
  • sjam Level 1 (10 points)
    i shut off genius and the problem stopped
  • DougDoug Level 1 (40 points)
    I too have been getting the "library cannot be saved unknown error 13001" message. iTunes also VERY slow since 8.1 update. Eventually gave up entirely on genius. Now much more responsive, BUT still occasionally getting same error message, elthough all SEEMS to be normal
  • Derek Watson Level 1 (70 points)
    me too! still getting error but again seems to be okay, annoying to say the least. Any way to revert to previous iTunes?
  • poil66 Level 1 (10 points)
    i was having this same problem. genius was updating and then there was error 13001 i think. i tried deleting the genius files and running it again, but the error message came up again. so, i turned off genius as instructed, which is annoying because i like genius, but whatever. seemed to fix it for a day, but now a new error message is coming up saying cannot save itunes library file, i think error 50. is there a fix for this which does not involve losing all my playcounts and ratings and stuff?
  • Derek Watson Level 1 (70 points)
    I deleted *iTunes Library Genius.itdb* and nervously moved *iTunes Music Library.xml* to desktop (so I could restore if anything drastic happened) and restarted iTunes, this seems to have stopped +itunes library file cannot be saved+ error but genius still won't work.

    Halfway there, I guess Genius needs to be fixed by Apple.
  • brm51 Level 1 (0 points)
    I am getting error 13001. I have tried all suggestions I have read and none seem to work.

    My computer is a family machine, with each family memeber having a user account. We share the iTunes library (or used to, iTunes 8.1 and 8.1.1 don't work). Only my account works, but I get 13001 all of the time. All other accounts get error 13008 and won't open.

    If I could go back to 8.0.52 I would gladly.
  • SpunkySarahe Level 1 (0 points)
    This doesn't work for me.

    I've tried and tried and tried.

    I just updated to the latest version of iTunes 8.1.1 (10) and it still fvcking svcks.

    FIX THIS RUBBISH APPLE!!

    Message was edited by: SpunkySarahe

    Message was edited by: SpunkySarahe
  • Derek Watson Level 1 (70 points)
    I had problem with genius too and posted on that thread solution which solved all my problems anyway, it seems to be QuickTime plugins and Perian Pref pane causing problems...

    Not sure if this will work for all but... I quit iTunes, moved XviD_Codec 1.0 alpha.component from /Library/QuickTime to a new folder /Library/QuickTime Disabled and LAMEEncoder.component, DivX Encoder.component and DivX Decoder.component from ~/Library/QuickTime to a new folder ~/Library/QuickTime Disabled.

    Deleted com.apple.iTunes.plist, iTunes Library Genius.itdb and moved iTunes Music Library.xml to the desktop.

    Restarted iTunes, setup prefs and signed in to iTunes Store, started Genius and it worked!

    I then deleted the iTunes Music Library.xml on the desktop and it seems fine. Will see how long I can last without requiring the DivX components for QuickTime but may try re-installing them one at a time to see which is the problem. I do suspect the LAMEEncoder.component may be the culprit.

    Perian is a big problem with iTunes but should be okay as you can temporarily uninstall it from its preference pane. This is a pain as it is essential for some of the work we do with AVI files for clients.
  • James Riely Level 1 (0 points)
    This also worked for me, although I do not have Perian or Lame. I had no success just removing the DivXEncoder, so I took everything that didn't come from apple out.

    I had to delete com.apple.iTunes.plist, iTunes Library Genius.itdb, iTunes Library Extras.itdb and iTunes Music Library.xml

    Here's a listing from my /Library:

    QuickTime:
    AppleIntermediateCodec.component/ AppleMPEG2Codec.component/

    QuickTime Disabled:
    AppleHDVCodec.component/ EyeTV MPEG Support.component/
    AppleProRes422.component/ FCP Uncompressed 422.component/
    CanonMJPEGAVI.component/ FLV.component/
    CanonMJPEGAVIDec.component/ Flip4Mac WMV Advanced.component/
    CanonText.component/ Flip4Mac WMV Export.component/
    DVCPROHDCodec.component/ Flip4Mac WMV Import.component/
    DVCPROHDMuxer.component/ Google Camera Adapter 0.component/
    DVCPROHDVideoDigitizer.component/ Google Camera Adapter 1.component/
    DVCPROHDVideoOutput.component/ IMXCodec.component/
    DVCPROHDVideoOutputClock.component/ LiveType.component/
    DVCPROHDVideoOutputCodec.component/ Motion.component/
    DesktopVideoOut.component/ SoundboothScoreCodec.component/
    DivX Decoder.component/ macam.component/
    DivX Encoder.component/
  • Phychi Level 1 (0 points)
    I Have the same problem and genius is not activ on my iTunes (too slow and not usefull when you download a lot from Jamendo : new artists are unkown on iTunes Store)

    I also posted on http://discussions.apple.com/thread.jspa?messageID=9497410#9497410 for a clue
Previous 1 2 Next