Previous 1 2 Next 27 Replies Latest reply: Sep 17, 2010 10:18 AM by seburgess Go to original post
  • Sean Dale1 Level 5 Level 5 (4,145 points)
    davidmillermac wrote:


    I'd love to remove the current need to use Word for Mac, Excel for Mac and possibly Powerpoint but I can't - yet.


    Have you tried OpenOffice yet? You can set the default saving preferences to save as office type documents (doc, xls and ppt) so that people you share them with who use office can open them. Interestingly the other day I received a document created in MS Works which could not be opened in Word on either a PC or Mac but could be opened directly from within OpenOffice
  • Ernie Stamper Level 8 Level 8 (37,555 points)
    Are you located in a network where Exchange Server is being used? This is the most common source of these extraneous attachments. They are not added by Mail. Typically it is the IT folks maintaining your Exchange network who must make a change with the network to solve this. See:

    http://www-01.ibm.com/support/docview.wss?uid=swg21343144

    You will note that this is not even discussing Macs or Mail

    Ernie

    Message was edited by: Ernie Stamper
  • holspeed Level 1 Level 1 (0 points)
    Dear All, Dear Ernie,

    Thank you for the information.
    I'm not working in an Exchange Server environement. I'm using a GMAIL account.
    While I send an email from Mail with some text A part + an attached image + text B part to one of my email adresses, the following is happening like explained in the previous posts:

    - If I read it with Outlook on a PC:
    I receive an email with text A and two attachements: the image + an ATT000XX.htm file which contains text B
    - If I read it on www.gmail.com:
    No problem. The message appears complete with only the image as attachement.

    Conclusion: there is still a problem of uncompatibility between Mail and Outlook. May we hope that Apple will fix the problem very soon.

    Best regards.
  • Ernie Stamper Level 8 Level 8 (37,555 points)
    Please open the message you just described in your Sent mailbox, click on Message in the menubar and choose Send Again. Next click on Format in the menubar and choose Make Plain Text. Send and then observe again on the PC with Outlook (and confirm you mean Outlook and not Outlook Express).

    How is the network you are using to connect to the internet configured -- modem with ethernet cable only or modem with router and cable or wireless to various computers?

    If you wish, you may send a similar message to me to observe -- my address can be found by clicking on my name to the left of this post, and looking in the bio line of the resulting Profile.

    Ernie
  • dennisraustin Level 1 Level 1 (5 points)
    @davidmillermac - RE: Mail Attachments Iconizer

    Thanks for this. This workaround has proven to be very functional for me for now.
  • NicPaillard Level 1 Level 1 (0 points)
    I've found a web page indicating a trick that is functionning for me without the need of extra software:

    http://micahgilman.com/play/disable-mac-mailapp-inline-image-attachments/


    That led me to this site which give an utility (prefPane) that helps to play with OSX settings:

    http://secrets.blacktree.com/


    This made the trick if my attachements are images (like often used in signatures). Other contents will make the email revert to it's "att00001.htm" state. This may be a way to unlock a "compatibility feature" of mail.

    Still looking for a real fix... for Outlook...



    The only trick I found to look "somewhat" good on (nearly) every mail client with a graphical signature is to create a real html signature with external image (i.e. hosted on an external site).

    See here for details:
    http://www.createarevolution.com/blog/2008/02/07/creating-an-html-signature-in-a pple-mail/

    (I would recommend Nvu to make your HTML page, but it's really old stuff and is PPC, still it works nicely for simple things like that. I've not tried KompoZer. Google for info.)


    Attachement problem:

    If you put a non-graphical attachement (pdf were used as test material for me) BEFORE your signature, everything is messed up in Hotmail, everywhere else, it's good looking. In Hotmail, everything shows up as an attachement (like in Outlook).

    With non-graphical attached files at the END of the message, the signature is looking good in Gmail, Yahoo and Hotmail. Also in Outlook on Windoze it looks good, but you must enable the downloading of external content.

    With graphical content attached to an HTML signature, everything shows up fine in Gmail, Hotmail and Yahoo with the image placed at the top of the email or at the end. In Hotmail, however, the image is ALSO showing as an attachment if it is put at the top, but still showing nicely.

    If you mix content (image+other) and put it at the top of your email, you will get attachements in Gmail and Yahoo (no att00001.htm), but the html signature is still looking good and the text of your email is showing corectly. In Hotmail everything will show as attachement and you will even loose any message typed in the usual bunch of att0000x.htm files.

    If you put your mixed content at the end of your email, you will still get the attachements in Gmail and Yahoo with a good looking signature (still the message is showing perfectly). But you will get the very same result in Hotmail with a good looking signature!

    So I would recommend you to always put attached file at the END of your emails, and if you use mixed content (images and non-images attachement), it's even more important.

    I'll try with Outlook and post results later.
  • NicPaillard Level 1 Level 1 (0 points)
    I've tested my HTML signature with referenced images (on an external server) in an email with a PDF and a PNG attached at the end of the email. and it is showing fine in Outlook. Still you will get an att0000x.htm but the message is not lost and your attachments will not be lost in a bunch of att000x.htm (only one of these files actually).

    So my recommendation is to use a HTML signature with referenced images (if you need images in your sig.) on every email and to put your attached images at the END of your messages, this way, your email will always show the text and your signature.

    It would be nice if Apple would kindly put an "Outlook compatible email" option check-box in Mail. It would save a lot of headache to a lot of users. Also, as long as Mail doesn't get the job done properly (even if it's an Outlook problem), people will scorn at Apple, and that is not very good for business.
  • NicPaillard Level 1 Level 1 (0 points)
    I almost forgot, you can go there to take info about email-clients:

    http://www.email-standards.org/


    You can also see if your email-client is dealing well with Net standards about emails (the box to put your email is in the first quarter of the page):

    http://www.email-standards.org/acid-test/


    So in the end, Outlook is definitely the culprit, you can't ask for a better proof.
  • MattParr Level 1 Level 1 (0 points)
    I'm using Mac Mail 3.6 in an Exchange environment. I know that others are getting these attachments because I see them attached to my messages in my sent mail. Before, I didn't think too much of it until I went to send 11 *.doc files and saw that the sent message had 22 attachments! Yup, for each doc file, it added an empty htm file. BOO!

    @davidmillermac Just tried your workaround and it works for me too. Thanks!

    @Ernie Stamper
    Any suggestions on what Exchange changes to make?
  • CLWaltrip Level 1 Level 1 (0 points)
    I was unable to fix the problem until I installed Iconizer. It appears to be a required step for some users.
  • Nick L Wingfield Level 1 Level 1 (0 points)
    Just a few observations that I've already put in another forum about the same subject:

    Selecting 'Plain text' (in Preferences - Composing - Message Format) works - but the trade off is that you can't have any 'Rich Text' styling. So nothing bold or italic, etc

    Alternatively, if you install the shareware 'Iconizer' you can use Rich Text. Admittedly the people who didn't see your text at all before will now only be able to see your text in Plain text. But it does mean you won't have to compromise loss of Rich text for all those people who don't have the ATT00001 problem.

    Here's the link for 'Iconizer':
    http://lokiware.info/Mail-Attachments-Iconizer

    One final thing. There have been several forums on this matter most of which have been closed and archived.
    Many people blame the problem on Windows and Outlook Express specifically.
    But my experience is that the problem is far more widespread than that.
    I've had the same problem with other Mac Users using Mail.
    Its also a consistent problem with Hotmail. Yes I know Hotmail is Microsoft but plenty of Mac Users have Hotmail Accounts too. The ATT00001 problem is identical whether you use a Mac or a PC. Incidentally the only thing that bucks the trend is the iPhone - where Hotmail emails don't lose their text.

    The upshot is that this is a BIG problem that Apple should take seriously. When people receive an email with attachments and no text they're likely to be very wary of it. At best they're likely to think the sender has stupidly forgotten to send the text. Virtually no one is going to risk opening up a dodgy file called ATT00001 especially as it comes with a string of others that appear to be empty.

    This is a problem that should be right at the top of Apples TO DO list and not just marked as a 'Solved Thread' in an Apple Forum.
  • finetuned Level 1 Level 1 (0 points)
    I agree, this is outrageous. For the past hour, I've tried every combination of adding attachments inline, at the end, using the Terminal trick, the Mail Iconizer, and the various "Windows Friendly" and "Attachments at the end" options in Mail.app. Frankly, none of them worked. With inline attachments, everything after the first attachment is turned into an attachment as well, and with attachments at the end, there are empty ATT* files attached (probably containing one line-break that I added between the attachments when sending them).

    Now, this problem shows up both in my Sent Items folder within Mail.app, as well as the Sent Items folder in Outlook on Windows, as well as in the inbox in Outlook on windows, and in the inbox in Mail.app as well. It also shows up on the Outlook Web Access webmail client.

    So at least I'm getting a consistent view of what's happening: the problem shows up in both Mail.app as well as in Outlook.

    I've also tried sending the same messages using my non-Exchange mail address (using my ISP's SMTP server), and the result is exactly the same. I recall this being different on Leopard, but I'm not sure.

    Anyhow, it's frustrating. Just had to dig out my old ThinkPad running XP and Office 2003 to send an e-mail to a bunch of people that was important. Makes me very sad, and it's very very strange that Apple has not been doing anything about this.

    Like other people have remarked in this thread: it doesn't matter whether or not Outlook is to blame here, because Outlook is a de facto standard, and if you send your email using Outlook, it comes out perfectly. Apple needs to fix this.
Previous 1 2 Next