10 Replies Latest reply: Apr 20, 2009 5:41 AM by brevon
brevon Level 1 Level 1 (0 points)
Hi,

There is a permition problem with my external hard drive (no time mashine on it!) - can't delete certain files.
I copied my documents on my external hard drive from previous computer with windows and later with linux system on it and there had been changed icons at certain folders previously. I mention this, becouse what linux did was that it locked the changed icon files and I couldn't delete them until I unlocked them manually. But at least it showed me that i don't have permition and i could change it. Well, now I mounted the disk on my new macbook and wanted to delete some files and it seems that there is the same problem with permition, at least it seems to happen with the same files. When I want to delete them, the system asks me for admin password, I give it allright, it makes the sound as if the folder was moved to trash but that's all. the folder is still there even after dismounting and restarting. I already checked the permitions and it says in the info that i can read and write with the file so it looks as if my rights were ok...
Please help, I desperatly need more space for new backup and can't get rid of the files I don't need any more...

Thank you for any sort of simple-ish advice

Message was edited by: brevon

MacBook A1278, Mac OS X (10.5.6)
  • 1. Re: can't delete file from external hard drive
    Kappy Level 10 Level 10 (226,845 points)
    Did you Empty the Trash or just move the folder to the Trash? If you actually want the item deleted then you must Empty the Trash while the external drive is still mounted or the item will not get deleted.

    If the above doesn't apply, then you haven't explained your situation accurately in which case please clarify.
  • 2. Re: can't delete file from external hard drive
    brevon Level 1 Level 1 (0 points)
    I know what you mean but this is not the case, I wasn't clear enough then So: I even didn't get to the emptying because when I clicked on "move to trash" it asked me for the password, which I am sure I typed correctly and then as if nothing happend at all, the folder was still in the Finder and trash was still empty - no action took place in other words..
  • 3. Re: can't delete file from external hard drive
    Kappy Level 10 Level 10 (226,845 points)
    OK, got it. Suggest visiting The XLab FAQs and reading the FAQ on solving Trash related problems. It should help you find a solution, but if not then post back here.
  • 4. Re: can't delete file from external hard drive
    brevon Level 1 Level 1 (0 points)
    Thanx for such qucik reply!!! The pages were great, it had an answer for my problem, but unfortunately it also involved me dealing with it only on the MacIntosh HD itself, not on mounted external drive I suppose... So it didn't work they say that there is an icon in the left corner indicating locked folder - I don't see any icon on it. It says you can untick the box to unlock the folder - there is no tick to be unticked. Finally, they say that if I don't have permition or rights I cannot delete it. But how do i change permittion which already says that i can read and write in it? So everything appears to be normal only I cannot delete it. there is not even any warnig telling me I don't have enough rights, it just requires the password and after me typing it in it makes the sound of scraping paper but does nothing more. I aslo had some problems with emptying Trash after being seemingly succesful with one file and had got so far to have them appear in the Trash (no clue how this one actully got there though..) I followd the advice and emptied the Trash with Terminal. The Folder is still there but it shows 0 Kb... So far so good BUT: It is still on the external drive, so I obviously only managed to copy it into the Trash!!! Phew, innit a bit too tight to poor owners, this macbook?? I want my rights back!
  • 5. Re: can't delete file from external hard drive
    Kappy Level 10 Level 10 (226,845 points)
    The instructions will work on an external drive, but you have to know how to access the external drive in the Terminal. Do this at the prompt:

    cd /Volumes/"Name of Drive"

    Press RETURN. You should now be on the external drive where you can then follow the same basic instructions. Just keep in mind that you cannot use the "~" as a path shorthand or that will take you right back to you startup volume. You will need to use the complete paths.
  • 6. Re: can't delete file from external hard drive
    brevon Level 1 Level 1 (0 points)
    So I followed both yours and their instructions but it was all over the same. I did the deleting process using Terminal but it didn't do any difference. It actually told me (after pressing retourn to delete the same folder I couldn't delete before) that "it is a directory" which wasn't first very helpful couse I really don't understand computers themselves, I am an ordinary user but don't know much when it comes to commands in Terminal... but then I went back to the external driver and tried to delete one file in this folder at a time and it worked. But it took rather a long time couse there were a lot of them... When I chose them all and wanted to delete them it didn't work either, so this manual process was the only way. And there are still some folders which are empty at last but can't be deleted themselves... What exactly is responsible for that? I managed to make free space at last, but it is really confusing having there empty foldres which can't be deleted.. Do you know why this happens? Otherwise thank you for your time and tips!
  • 7. Re: can't delete file from external hard drive
    V.K. Level 9 Level 9 (56,120 points)
    how is the external drive formatted? you mentioned you used it with windows and linux. if the drive is formatted FAT then you can't delete those files at all from OS X if they are locked. you have to do it from windows. or you can do it from linux if you say you did it before. I have no experience with linux and can't comment on that.
    the only other way to do this from os x would be to reformat the whole external drive.
  • 8. Re: can't delete file from external hard drive
    Kappy Level 10 Level 10 (226,845 points)
    To remove a directory use the command - rmdir. To find out how to use any Unix command while in the Terminal enter: man command.
  • 9. Re: can't delete file from external hard drive
    brevon Level 1 Level 1 (0 points)
    Yes, I am afraid there is no other way! I tried everything and deleting these things using someone elses computer with windows seems to be the only way. I can't formate it now - I must back it up first, but I'll do it the first thing after that.
    Thanx!
  • 10. Re: can't delete file from external hard drive
    brevon Level 1 Level 1 (0 points)
    Thanx for help with the commands and references!