9 Replies Latest reply: Feb 3, 2010 7:42 PM by darias
abbeydaisy Level 1 Level 1 (5 points)
I just bought the game. Inserted the DVD, Clicked on the icon to install the game, the files write out to the hard drive. Then I go to finder and launch "spores". A message comes up "An update is available do you want to download and install". If I click yes, then it installs and comes back with the same message after it is complete. If I click no, then shuts the message off and I select spores in finder again to launch the icon pops up on my dock for a split second then disappears and comes back to this same message.
... i don't know what's going on.

I checked out all the requirements all of which I meet, I am running on MacBook
Leopard version 10.5.6
Duo Core Intel Processor
Chipset Model: GMA X3100

macbook, Mac OS X (10.5.6)
  • Leopardized Level 1 Level 1 (0 points)
    I had the same problem w Parental controls and found I had to run in admin account - not good for kids for sure.. . Found I could get most ftns to wk by adding links to parental controls ttp://na.llnet.cdn.ea.com/
    http://na.llnet.cdn.ea.com/u/f/eagames/spore/
    http://na.llnet.cdn.ea.com/u/f/eagames/spore/spore/patches/SPO3-Update-001940.md 5
    http://www.ea.com/

    Bottom line for every ftn you need to run in admin account...

    I am sorry if this caused you any trouble. Most of the EA games runs only on Admin account thus you will need admin account to run this game. If you do not wish to share your domain, you may create new admin account from your kids.

    Creating a new user account:
    1) Click on the Apple Menu select System Preferences.
    2) From the View menu, select Accounts.
    3) You may need to click the Padlock icon to allow changes.
    4) Click the + icon to create a new account.
    5) Log into the new user account and reinstall the game.

    If there is anything else we can help you with please let us know.

    Sincerely,

    EARep Paolo
    Player Relations
  • dechamp Level 4 Level 4 (3,495 points)
    There's no way I'm going to give Admin rights to a kid, just so that they can play a game. No, it will be "go over to your friends house and mess up his machine".

    We used to have problems with issues like this in Win2000 where a person had to have admin rights just to burn a CD. Great, so we gave the admin rights, and then paid the repair bills and the costs of more security software because we had to run admin accounts. Admin accounts can install every version of crap and video codec malware that trashes machines.

    I don't mind having to authenticate as an admin to install a program for a kid, but the only Admin on my machines is me.

    Not going back, thanks for the tip about EA Games Admin requirements
  • Simon S Level 1 Level 1 (145 points)
    I have a similar issue. I install Spore from the disc, and the first time it starts up it asks if I wish to download and install an update. If I say yes, the download begins but it won't install- it gets 95% of the way through the patching process and stalls. If I say no to the update (I have tried both!), the game crashes after the splash screen.

    I do have parental controls turned on. Will try on an admin account and see if it makes a difference.
  • Jeri Crouch Level 1 Level 1 (0 points)
    Before Snow Leopard... the patches had no problem loading. Since SL I have had to uninstall Spore but now it won't load any patches. After a little bit of attempting to load the first patch, it quickly says, "Down Load Error" and opens the game without crashing or freezing. Is there a fix for this?
  • ezraSchwartz Level 1 Level 1 (0 points)
    I'm having exactly the same problem: Got a brand new iMac with Snow Leopard, installed Spore, it downloaded all the updates, but than would not run - not even from my admin account. I uninstalled and re-installed again - same issues. Also wanted to know if it is a problem installing-uninstalling - I read about the draconian copyright restrictions EA has in place for this game, don't want to lock it. It is quite upsetting because my kids were looking forward to this for quite some time - we had the game for 6mo but it would not run on older macs.
    Thank you
  • Jeri Crouch Level 1 Level 1 (0 points)
    I have successfully reinstalled Spore, C&C and GA since posting this. The way you download the patches has changed since SL and as no one said before, because we supposedly had to have the patches first, the patches are in the extensions.

    First you have to properly remove the game with freeware here at Apple called AppCleaner. Delete Spore folder in My Documents, remove from dock, empty trash and clear history. More info on Sporums for backing up saved games and creations.

    Creepy and Cute have patch 1 & 2. Galactic Adventure have patches 3 & 4. A Spore Master finally told me that Patch 5.1 have the prior patches also but won't put that key info in the notes as I have asked them to so I don't know if that is true or not.

    The key is to not let it Auto Patch ever and if you do not have C&C or GA then install Spore and do not auto patch. Open and close the game then do a manual install of the patch 5.1.-do not auto patch.

    I made a detailed post here. And so far is working for me.

    http://forum.spore.com/jforum/posts/list/42209.page
  • Roger Young Level 1 Level 1 (0 points)
    I am having the same sort of problems, Spore installed from DVD.
    Downloaded Patch 5.1 and manually tried to install as suggested but when I run it and locate the app I get "You cannot apply thi patch on this version of the application"

    So does this patch contain all previous? IF not what do I do?
  • Russell Page Level 1 Level 1 (35 points)
    I know it's been a while, and you may have completely given up, but I found a workaround for the kids "parentally controlled" account and Spore. If you give them admin rights, then start the game up using that account, it goes and gets all it's licensing doohickeys and starts up fine. Then go back and change the account from "admin" to "managed". The kids account should still be able to run Spore -- it seems it's just that first load that grabs something from the EA server that fouls things up.

    (did this on a Mac Mini, Snow Leapord system).
  • darias Level 1 Level 1 (0 points)
    I just installed Spore. I installed all the updates when prompted. The game won't start. I've read other posts that say to just skip the updates. This can't be right? If the updates are causing the problem, then why do they exist? I've seen people writing about this same issue from as far back as 2008. Is there an actual solution to this, like another update or something that I can do to avoid having to uninstall? I'm going frigging crazy here!