12 Replies Latest reply: Sep 11, 2009 3:01 PM by Andrej
Sean Booth Level 1 Level 1 (30 points)
Pretty fed up with this now. I‘ve NEVER been able to restore or update my iPod Touch. I always get the same error message, ‘Not enough access privileges.’

I’ve followed everything. Changed USB ports, updated iTunes, re-installed iTunes, repaired permissions but nothing works – same friggin error all the time. Over 1 year with the same problem and never found the answer.

Go onto another Mac and its fine – so why can’t I install/update on my own Mac?

iMac 3.06, Mac OS X (10.5.6)
  • 1. Re: STILL!?? Not enough access privileges!
    Sean Booth Level 1 Level 1 (30 points)
    Just to add. I’ve followed all the instructions and completely removed all traces of iTunes. All the pref files and folders and reinstalled.

    I also set up a new user and hey presto it restored and updated on the new user but when I go back to my account I get the same error!

    Pain in the ***!
  • 2. Re: STILL!?? Not enough access privileges!
    luvlabs Level 4 Level 4 (3,610 points)
    Sean,

    It sounds like you answered your own question. Something in your user profile was set to prevent this activity. Delete your old user profile and assume that new identity.
  • 3. Re: STILL!?? Not enough access privileges!
    A4Apple Level 1 Level 1 (5 points)
    Sean,

    You may have just said screw it and created new profile, but if not, I think I might have the answer you have been waiting so long for.
    Go to your music folder and then open your iTunes folder and select the file named iTunes Library. While the file is selected go to "File" and click on "Get Info". In the info window go to the bottom and click on the arrow next to "Ownership & Permissions" or "Sharing & Permissions" depending if you have Tiger or Leopard. This will tell you whether you can Read Only, Read & Write, or No Access. (Tiger) Click on the triangle next to "Details" and that will tell you the "Owner" of the file and who has access. (Leopard) There will be a list of users on the left and their access privileges on the right. It sounds to me like some how your permission to access this file was changed or erased. You can easily change this by clicking on the "padlock icon" and adding your profile to the list and be sure to give yourself "Read & Write" access. Hope this helps.
  • 4. Re: STILL!?? Not enough access privileges!
    Sean Booth Level 1 Level 1 (30 points)
    Excellent – I shall give this a try. I’ve been putting up with restoring and updating on another profile. Only just seen this response so I’ll give this a go this evening. Thanks.
  • 5. Re: STILL!?? Not enough access privileges!
    Sean Booth Level 1 Level 1 (30 points)
    Well I tried that and no luck. All the files in and including the iTunes folder have read & write access.

    Is there a possibility that my iPod thinks it belongs to someone else? I never have any issues with iTunes in general – only when it comes to updating the Touch. Its not been an issue for months because I haven’t needed to get any updates.
  • 6. Re: STILL!?? Not enough access privileges!
    Sean Booth Level 1 Level 1 (30 points)
    Just to add – I have gone through all the various procedures to delete iTunes and start again – even that didn’t work – which makes me think there is something wrong with the iPod or possibly other hardware like the dock, usb r cable.
  • 7. Re: STILL!?? Not enough access privileges!
    DaMikki Level 1 Level 1 (45 points)
    Sean I doubt there is an issue with your iPod as you mentioned in a previous post that it does work on another machine. What Mac OS X version are you running ? Is it Tiger or Leopard ? Anyway I have a possible solution for you to try but it requires you to use the terminal.

    At the terminal type the following: -

    (For Leopard)
    cd ~
    sudo chown -R YOURUSERNAME:staff *

    (for Tiger)
    cd ~
    sudo chown -R YOURUSERNAME *

    Enter your password when prompted and wait for the command to complete. This command recursively changes the ownership of all files in your home folder so they belong to you.

    Also ensure that you have an SC Info folder in /Users/Shared/

    type the command: -

    ls -l /Users/Shared

    it should show: -

    total 0
    drwxrwxrwx@ 2 YOURUSERNAME wheel 68 28 Jul 13:56 SC Info

    This folder is used for iTunes Authorisation if it's not there create it with the following command: -

    mkdir /Users/Shared/SC\ Info/

    Next start iTunes and goto the store menu and select deauthorise computer and then reauthorise computer. Now try your iPod again.

    If this doesn't work get back to me and I'll see what else I can come up with.
  • 8. Re: STILL!?? Not enough access privileges!
    jaker23 Level 1 Level 1 (25 points)
    did you try "authorizing" the computer in iTunes?
  • 9. Re: STILL!?? Not enough access privileges!
    Sean Booth Level 1 Level 1 (30 points)
    Ok great – thanks for the effort you guys are putting in – much appreciated.

    I’ll give this ago and let you know. Just a quick look and there is nothing in my shared folder.

    I’m using the latest OS10.5.7
  • 10. Re: STILL!?? Not enough access privileges!
    DaMikki Level 1 Level 1 (45 points)
    Sean

    sorry I missed something off the command to show the contents of your shared folder

    it should be

    ls -al /Users/Shared/

    not

    ls -l /Users/Shared/

    the -a shows all files and folder and the SC Info folder is hidden.
  • 11. Re: STILL!?? Not enough access privileges!
    Sean Booth Level 1 Level 1 (30 points)
    Damikki – you are a star

    It worked. I followed your instructions – only bit I stumbled on was the ‘ls -al /Users/Shared/’ but it just said that folder already existed. Restored and updated iPod and its just finished copying everything over. So thanks again.
  • 12. Re: STILL!?? Not enough access privileges!
    Andrej Level 1 Level 1 (35 points)
    Hi folks, well unlike you all, I am not having the same measure of luck. I am still getting the "not enough access privileges" messages.

    I have verified that I have an SC Info folder where it should be.
    My iTunes folder and all of its contents are already set so that I can read and write to everything.
    My account is my own computer admin. account.
    I have tried deauthorizing and then reauthorizing my computer. That didn't work.
    I have tried the sudo chown method on my iTunes folder (haven't done it yet on my entire home folder, I'm afraid of some other problem coming up). That didn't work.

    What's going on?



    iMac G5
    Mac OS X 10.5.7
    iTunes 8.2
    iPod Touch 3.0 software - trying to update to 3.1.1.