6 Replies Latest reply: Mar 29, 2009 3:35 PM by PeterBreis0807
frazzydee Level 1 (15 points)
When you click the "facing pages" option, it changes the page display, but it does not change back when you uncheck this option.

_Steps to reproduce_
1) Create a new document in Pages
2) Open inspector -> Document inspector
3) Check, and then uncheck the "Facing Pages" option under "Document Margins".

_Expected results_
The document looks exactly the same, since you didn't change anything (enabled and then disabled an option)

_Actual results_
The document view is twice as wide.

Notes
The undo feature does not fix this.

Also note that the horizontal scrollbar has expanded, so the + button now makes the window too big rather than bringing it to its proper size.

Screenshots here:
http://img17.imageshack.us/img17/3630/picture6iti.png (after document created)
http://img11.imageshack.us/img11/2068/picture7fdn.png (after "Facing Pages" checked)
http://img21.imageshack.us/img21/7889/picture8qhp.png (after "Facing Pages" unchecked)


Thanks!

Macbook (aluminium), Mac OS X (10.5.5)
  • frazzydee Level 1 (15 points)
    Solved!

    1) Click the pop-up menu at the bottom-left corner. You should notice that "Two Up" is checked.
    2) Click "One Up"

    Screenshot: http://img7.imageshack.us/img7/7985/picture10wiv.png

    This is unexpected behaviour...I will file a bug report.
  • Level 8 (41,790 points)
    No bug at all.

    1st state:

    the document is not using facing pages and the app display one page in width.

    2nd state:

    I activated the facing pages mode.
    This forced the app to activate the 2 pages in width mode.

    3rd state:

    I desactivated the facing page mode.
    There is no reason to automatically disable the 2 pages in width mode.
    The setting may perfectly be an old one and the app is unable to decide.

    Yvan KOENIG (from FRANCE dimanche 29 mars 2009 12:26:07)
  • frazzydee Level 1 (15 points)
    If you don't know how to change this mode back it can be really confusing. IMO if enabling facing pages activated the 2 pages in width mode, disabling it should change the mode back. I can see how implementing this would be difficult as extra information would have to be stored, but at the very least it definitely should change back when using the undo feature.

    But anyways the apple devs will decide, although I suspect they will listen to you =P
  • Level 8 (41,790 points)
    frazzydee wrote:
    But anyways the apple devs will decide, although I suspect they will listen to you =P


    They will not have to listen to me on this point because I will not ask them to change this behavior which I feel correct.

    Yvan KOENIG (from FRANCE dimanche 29 mars 2009 16:38:52)
  • frazzydee Level 1 (15 points)
    sorry, I meant to say I think they'll agree with you. I don't agree, but I'll avoid starting an argument
  • PeterBreis0807 Level 7 (34,587 points)
    frazzydee

    I have to agree with you, this is handled as expected by other programs and there is no reason why Pages has to create a problem where there should not be one.

    Peter