Previous 1 2 Next 29 Replies Latest reply: Sep 10, 2009 5:49 PM by toddlydavis Go to original post
  • JustLetMePostAlready Level 1 Level 1 (0 points)
    I contacted Yahoo Mobile technical support and received this response:

    Thank you for writing to Yahoo! Mobile Tech Support.

    I understand that you are no longer able to access Yahoo! Mail on your
    iPhone. I have taken some steps which, with the following
    troubleshooting steps, should resolve the issue you are encountering.
    I'd suggest the following steps to ensure that your Yahoo! account is
    set up correctly:

    1. Delete the Yahoo! ID currently on your iPhone

    2. Turn off your iPhone

    3. Sign in to Yahoo! with your PC and change your password. Many errors
    are caused by the way the iPhone encrypts some characters. Please ensure
    your new password has no special characters (any character which is not
    a letter or a number, such as @ or *). This will reset our registration
    system and ensure that Apple treats your ID as a new connection.

    4. Turn your iPhone back on

    5. Set up your Yahoo! account on your iPhone using the "Yahoo!" option.
    Please make sure that you enter your new password when setting up the
    account.

    6. Make sure that your iPhone is not set to "Manual Push". To do this,
    please take the following steps:

    - Open Settings
    - Select "Mail"
    - Select "Auto Check" and verify that it is not set to "Manual"

    These steps will trigger a re-sync between your iPhone and our systems.

    If you find that you're encountering issues with registering your
    account, or your iPhone is unable to retrieve email, please write back
    and include the following information:

    - Were you utilizing your iPhone's "Push Mail" function?

    - The exact error message you're receiving on your iPhone when you
    attempt to access your mail

    - What firmware/security update are you currently using on your iPhone?
    (Choose General > About to get information about your iPhone and select
    "Software version")

    - Do you currently have a contract with ATT, are you an ATT Go! Phone
    user, or are you on another network?

    - If you are on another network, who is your carrier? Are you using the
    iPhone strictly via Wi-Fi?

    - Is your iPhone currently hacked to use non-Apple products or
    software, or work on a network other than ATT?

    - What firmware version is running on your iPhone?

    Please feel free to contact us back should you still have other concerns
    or questions. We will be happy to assist you again.

    Thank you again for writing to Yahoo! Mobile Tech Support.
  • jess2089 Level 1 Level 1 (0 points)
    I got that same response, and had already told them that I tried to do those things, so this is what they told me in response.

    Thank you for writing to Yahoo! Mobile.

    I understand that you see an Invalid ID or password message when signing
    into your Yahoo! Mail account on your iPhone. I apologize for any
    inconvenience this has caused you, and I'm glad to be of assistance.

    Our Engineering team is already working on a possible fix for this now.

    Thank you for your patience while we work to resolve the issue you've
    reported.

    Thank you again for contacting Yahoo! Mobile.
  • Kari In Wonderland Level 1 Level 1 (0 points)
    I attempted to open the YouTube app yesterday and it kept popping up with a message saying that I need to first connect to the internet through iTunes. I'm not sure how long this was going on for, since I didn't try opening YouTube when my mail first failed, or if the 2 issues are related in any way, but after I tried a fix for the YouTube issue, my Yahoo mail is now connecting fine. I tried adding a new Yahoo account also, which I was not able to do before, and that also worked without problems. The YouTube fix involved replacing files, so I'm not sure if I can post it here...
  • troutmouse Level 1 Level 1 (0 points)
    This worked, however 6 hours later I'm back to the same place unable to download Yahoo mail
  • goslice Level 1 Level 1 (5 points)
    After reading some of this I'm wondering if this is similar to what I've noticed. I can delete my YAHOO account from the phone and then re-enter the same exact account back into the phone with the WRONG password and it WILL validate. Crazy!
  • chefsteph Level 1 Level 1 (0 points)
    Had the same problems with a brand new iPhone today. Tried everything listed in this forum and nothing helped. So then I opened Safari and went to the Yahoo web page and decided to try and and log into yahoo mail that way. It worked, so I went back to 'Mail' and it immediately started loading all my yahoo emails. Problem solved! Hope this helps others!!!
  • dawgskats Level 1 Level 1 (0 points)
    Same **** problem, just bought the new 3GS upgraded from the 3G. Yahoo Push mail is not working anymore. I'm ready to return the phone for this reason & go back to my 3G.
  • PaulSu Level 1 Level 1 (0 points)
    I have a different problem with Yahoo, and I'm hoping other Yahoo users can try. I just got my iPhone 3GS. I'm in Canada, and use rogers, which uses Yahoo for their email services.

    If I try to email, lets say, a map from my iphone to anybody, rogers.com (yahoo) seems to strip it out. All that comes through is a text message email with no link to my Google map. However, if I send the same email through my iphone over gmail, all is well. The email comes through with the link and an attached VCARD.

    can somebody please test that is on Yahoo?

    This is how I did this:

    Maps => Drop a Pin => Share location => send email

    Thanks

    -Paul
  • Forgotten Rebel Level 1 Level 1 (0 points)
    Im having the same issues. My buisness Yahoo account worked fine on the 3G for the last year but I updated to ver 3.0 software 4 days ago and I haven't been able to send or receive email ever sense!

    Come on Apple WAKE UP !!!
  • geckoazul Level 1 Level 1 (0 points)
    I am having a similar problem with my Yahoo business mail. I am able to receive emails just fine, however after I updated to 3.0 I am no longer able to send emails. It shows the emails as being successfully transmitted, but it never arrives, and a copy of it never shows up in the sent mail folder. I talked at length with Apple and AT&T and they said it was definitely a Yahoo problem. I spoke with technical support over at Yahoo and they were completely useless. I followed their instructions and it messed up my phone so bad that I had to restore it. Yahoo also claims, now, that business mail does not support "push", which it did in the past and still does. I have no solutions, and need help. Pray for Mojo.
  • bobl_iphone Level 1 Level 1 (0 points)
    There is another thread on this topic:

    Topic : Unable to send mail (Yahoo! Mail) after upgrading to OS3.0

    http://discussions.apple.com/thread.jspa?threadID=2052513&tstart=0
  • dbyone Level 1 Level 1 (5 points)
    I'm having the same trouble with yahoo sending a contact or (sharing) a contact. I see the attachment in the email before i sned it but after it's arrived to whomever i send it too it is just a buch of jarbled text. I can send it from my gmail account or my exchange work account and it goes through without trouble. Have you found a fix?
  • Smindsca Level 1 Level 1 (0 points)
    Can you tell me the contact information, such as phone number and URL of yahoo mobile support?

    Thanks.
  • aquariusrick Level 1 Level 1 (0 points)
    I'm having this same issue with sending VCards from my Yahoo account. I have 3 email accounts set up on my iPhone 3GS: Yahoo, Gmail and Exchange. I did a separate test from each email account, where I send a shared location email to all 3 of the accounts. Here are my findings:

    From Yahoo, to Google and Yahoo I get the garbled text and no attachment
    From Yahoo, to Exchange, I don't get any text or attachment.

    From Exchange or Google, to Yahoo, Exchange and Google I get the attachment.

    So basically all the tests from Yahoo failed, and all the tests from Google and Exchange worked fine. Does anyone know how we can fix it?
  • toddlydavis Level 1 Level 1 (15 points)
    I have traced this issue the the server used by the pre-installed Yahoo! email client on the iPhone. I set up the same email account as a POP manually and sent a vCard with success. Switched back to the Yahoo! pre-installed settings and the garbled failure returns. I have contacted Yahoo and my case has been escalated.
Previous 1 2 Next