2 Replies Latest reply: May 19, 2009 1:31 AM by jomats
mcnthuzist Level 1 Level 1 (0 points)
When dragging photo thumbnails into position in a slideshow, the main window sometimes shows a different photo than the thumbnail. Sometimes the thumbnails will freeze so they can't be dragged to a new position. I found that clicking on a different slideshow or album then clicking back on the problem slideshow usually fixes the problem.
If you do get the photos in the right order and then start the slideshow, the photos end up in a different order. This happens even when "Shuffle Slide Order" is not selected.
I also have a problem that only the first song, of several, in a playlist will play. The slideshow continues with no sound.
I tried reinstalling iPhoto '09, and even trashed '08 first, with no luck.
Anyone have any ideas?

iMac, Mac OS X (10.5.3)
  • Terence Devlin Level 10 Level 10 (132,210 points)
    Back Up and try rebuild the library: hold down the apple and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild.

    Regards

    TD
  • jomats Level 1 Level 1 (0 points)
    Re: the slides going out of order, it drove me nuts too. Then I discovered it wasn't a random glitch (had random order turned off too), it was the template. e.g. I used the scrapbook template and the opening slide needed a vertical image - so it chose the first vertical slide in the series for the opening slide - it happened to be the 4th one. It also pulled slides out of order later on in the show whenever it needed a vertical slide.

    In addition, it would sometimes start from the middle of the slide show. That, I found, was because I inadvertently had a slide selected - so again, it went for the first tall slide after that point, then continued from the middle.

    My errors, but really, it took a lot of time to figure out and it should be documented in the instructions don't you think?