Previous 1 2 3 4 5 Next 62 Replies Latest reply: May 9, 2010 8:16 PM by Andrew Rhoades Go to original post
  • Michael Black Level 6 Level 6 (18,720 points)
    Looks like even Western Digital does not know the difference between their MyBook (externally powered drives) and Passport (connector bus-powered portable drives) lines. Asking about a Passport Studio's "power adapter" makes me think they did not truly read you email.
  • bingston Level 1 Level 1 (0 points)
    I thought the exact same thing when I read that...I've responded to them again, we'll see what they have to say next.
  • bingston Level 1 Level 1 (0 points)
    WD is almost worthless, I just got a response saying something about them not dealing with data recovery...I don't even know where that came from. At no point did I mention anything about data recovery:


    I apologize for the inconvenience, but Western Digital does not perform data recovery services. However, you may use one of Western Digital's authorized data recovery service companies. In order to retain the warranty on the hard drive, you must use a Western Digital’s authorized data recovery service company. Please visit the link below for more information about these companies and our data recovery policy.

    Title: How can I repair my drive, recover data on my drive, obtain a circuit board, or find a list of WD data recovery partners?
    URL: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/stdadp.php?p_faqid=70&pcreated=1003446260
  • bluztoo Level 1 Level 1 (75 points)
    Have been using a WD 320 with firewire 800 for about 3 months - it has worked perfect from the start. I'm not saying folks aren't experiencing these problems, but I think it's important to gather all the data, and my experience is completely contrary to those above.
  • imnotatree Level 1 Level 1 (0 points)
    So to update:

    The second 100gb folder transferred fine. And the drive has been working well for me so far, I am using it for final cut so it has been under some labor intensive work with no issues.

    I will post again if it fails on me but for now all is well.

    My suggestion is download the new manager and get rid of the turbo (if installed)

    http://support.wdc.com/product/download.asp?groupid=205&sid=61&lang=en

    Oh and thanks bluztoo good to hear that it can work successfully, helps to boost my faith in the product.
  • berlugana Level 1 Level 1 (0 points)
    Hi everybody,
    I just read your posts, and I'm quite angry. I operate an old Powerbook G4 12", and having some trouble with my hard drive, I purchased the WDMyPassportStudio to be able to boot from an external portable drive in case my HD crashed completely.
    (Old macs like mine can only boot from firewire external drives…)
    First, I experienced some erratic behaviour like you mention, the drive occasionally not mounting, I wonder if there may be a problem with the FW connection cable, or too little power coming from my computer, for I noticed that the drive mounts better when connected through an external Formac FW drive with separate power supply.
    But what I feel most angry about is the fact that WD external drives are not bootable from Firewire. Does anybody know where I could get a list of external portable Hard Drives that are Firewire400-bootable under Mac OS 10.4.11? Don't you feel WD should communicate about this non-FW-bootability of their drives?
    Thanks for any help!
  • imnotatree Level 1 Level 1 (0 points)
    Okay so my final word on this drive is take it back!

    It worked ok for a while and then it started to lag with simple tasks like looking at folders with quicklook etc (my 'mybook studio' doesn't have any issues with this) and when the drive started to unmount itself I gave up, formatted it and returned it to the shop. I have a Lacie rugged on order so we'll see how that goes.
  • bingston Level 1 Level 1 (0 points)
    I didn't seem to get anywhere with WD. I installed the turbo drivers and things seem to be a little better now. I'm kind of giving up at this point, so I'm going to close this thread. Good luck with everything. Thanks for all the help and suggestions.
  • Michael Black Level 6 Level 6 (18,720 points)
    berlugana - any of the Other World Computing drives (http://eshop.macsales.com) will boot for you. I have one of their Mercury On-The-Go firewire-800 bus-powered drives that I've been cloning my powerbook to and booting from for quite awhile.
  • aohren Level 1 Level 1 (0 points)
    I recently got a Western Digital My Passport Studio (WD5000MT) and things are not good. Things started going down hill when my laptop locked-up hard trying to transfer my iTunes library to the drive. After I updated the drivers and the WD Drive Manager software it came with, the thing no longer crashed the system, but the drive would eventually stop responding during a long file transfer.

    What seemed to get things working was junking the Western Digital software (drivers and manager) and reformatting the drive.

    1. First and foremost, eject and unplug the drive.
    2. Unload the Western Digital software.
    - In a terminal, type kextstat to see a list of loaded system software.
    - For each item having a name that starts with com.wdc, type *sudo kextunload -b ITEM_NAME*.
    - Remove the files WD1394HPDriver.kext and WDUSBHPDriver.kext from /System/Library/Extensions/.
    3. Plug the drive in.
    4. Open Disk Utility and reformat the drive. Select the drive on the left, and then use the Partition tab to delete the existing partition(s) and create a new one. This will erase the drive.

    Freshly formatted and without the Western Digital software, things seem to be working great.
  • [Xero] Level 1 Level 1 (0 points)
    Still did your drive works fine after you posted this steps?
  • mprat Level 1 Level 1 (0 points)
    Hi, any news on this? Actually I'm in the same situation and 'not very happy' with my new external disk. I think I've tried all the posted steps no a several times without any improvement of the whole situation. Has anyone solved the problem yet?
    Cheers
  • bingston Level 1 Level 1 (0 points)
    Unfortunately, I'm still in the same boat too. I started this thread, talked to WD, and we keep going around in circles. I have pretty much given up. My boss and I got the drive at the same time and he was having more problems than I was. This thread was actually pertaining to the problems both of us were having. He reformatted the drive and installed the turbo drivers from the site, and his seems to be acting better now..although I think he just started using the usb to avoid having issues. My biggest problem now is that, while the firewire is connected, if you happen to move the drive at all, it becomes unmounted. It's not really practical. I mean I have it connected to a laptop, it seems like it should be a little more "portable" as the name suggests without "unmounting" itself. I wish there was a smaller connection for the firewire 800, it has to stick out a few inches and as soon as it gets nudged, it's unplugged. If anyone has a solution, I'd love to hear it too.
  • thomjw Level 1 Level 1 (55 points)
    It says this is "Answered", exactly where is the answer?
    I just bought the passport studio for mac 500gb, and it will NOT work with firewire 800 plugged into a powerbook G4. All it does is lock up when you try to do anything. If you try to plug in the usb, the drive makes a hitting noise. It will work with the firewire 400 plug, but it still acts up from time to time and freezes the computer. It seems like WD is selling a problem to us. This drive is specifically marketed to Mac users, so I think it should actually WORK for mac users..........
  • bingston Level 1 Level 1 (0 points)
    I marked this "answered" because I had just given up. Just can't seem to find a solution. A lot of people had viewed the thread but no one was saying anything. I just assumed that it wouldn't go anywhere. Once I marked it answered, more people started replying having similar issues. I hope we can find a solution without having to reformat the drive. I just changed it back to "unanswered" so maybe we get a little more attention/help.